Bug #91265 Results grid missing
Submitted: 14 Jun 2018 19:43 Modified: 20 Sep 2018 14:26
Reporter: Gary Martin Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S2 (Serious)
Version:8.0.11/8.0.12 OS:Microsoft Windows (Microsoft Windows 10 Enterprise)
Assigned to: CPU Architecture:x86
Tags: WBBugReporter

[14 Jun 2018 19:43] Gary Martin
Description:
----[For better reports, please attach the log file after submitting. You can find it in C:\Users\Gary.Martin\AppData\Roaming\MySQL\Workbench\log\wb.log]

After a while I have to close and restart MySQL workbench to get the results grid to display query results.

How to repeat:
run queries, keeping it open is the only consistent event. THe quickest it's happened was 2 hours, the longest 5.
[15 Jun 2018 4:22] Miguel Solorzano
Thank you for the bug report. This issue was already reported for others user however so far we aren't able to repeat the issue, looking your log attached I have noticed were some errors returned for queries reporting problems with the where clause (miss dome column) so I am wondering id could be one of the cause for, are you able able to dig that and provide a test case for?. Thanks in advance.
[12 Jul 2018 13:53] Andi Arpo
successful query and no results table

Attachment: Workbench 8.0.11 bug 2018-07-12 15_45_05-MySQL Workbench.png (image/png, text), 20.24 KiB.

[13 Jul 2018 10:01] Andi Arpo
Hello, what type of feedback are you expecting?
[13 Jul 2018 11:00] Miguel Solorzano
Hello, what type of feedback are you expecting?: Instructions step by step that make 100% repeatable the issue or some environment condition involved. Thanks.
[13 Jul 2018 11:04] Miguel Solorzano
[13 Jul 10:01] Andi Arpo: Are you able to attach here a zip file of the dump of the table (create table + data) showed in your screenshot you had provided?. Thanks.
[16 Jul 2018 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[17 Jul 2018 8:50] Andi Arpo
Also, shouldn't this be "S2 (Serious): Represents a severe loss of service, significant functionality is missing; but a workaround is available."?

The query editor not showing the results isn't a "S5 (Performance)" issue.
[17 Jul 2018 13:45] Chiranjeevi Battula
Hello Andi Arpo,

Thank you for the feedback.
I could not repeat the issue at our end using with MySQL Workbench 8.0.11 version on Windows 10.
If you can provide more information, feel free to add it to this bug and change the status back to 'Open'.

Thank you for your interest in MySQL.

Thanks,
Chiranjeevi.
[17 Jul 2018 13:50] Chiranjeevi Battula
Screenshot

Attachment: Bug_91265.PNG (image/png, text), 83.21 KiB.

[17 Jul 2018 16:28] Andi Arpo
Hello Chiranjeevi,

this is one of those bugs that cannot be easily reproduced. As someone else mentioned this problem happens after using Workbench for a few hours in a row. For me it's unfeasible to communicate to you "Instructions step by step that make 100% repeatable", therefore all the actions I perform, all queries I execute etc. during such a long time span, plus the dumps to all databases I'm working on. Regardless, I hope you'll find a way to investigate further.

PS: maybe this was not clear, when this problem presents itself, running a query in any tab (new or already open) hides the old result grid if it was visible, runs the query and then doesn't show the new results. It is not isolated to only one tab or only new tabs.
[17 Jul 2018 19:34] Miguel Solorzano
grid missing

Attachment: grid-hidden.png (image/png, text), 135.72 KiB.

[17 Jul 2018 19:36] Miguel Solorzano
Well I was able to repeat, using several tabs and leaving more than 3 hours idle.
See screenshot.
[18 Jul 2018 6:43] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=91689 marked as duplicate of this one.
[30 Jul 2018 13:03] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=91832 marked as duplicate of this one.
[3 Aug 2018 6:21] Umesh Shastry
Bug #91882 marked as duplicate of this one
[3 Aug 2018 7:00] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=91879 marked as duplicate of this one.
[3 Aug 2018 7:00] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=91874 marked as duplicate of this one.
[8 Aug 2018 15:31] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=91936 marked as duplicate of this one.
[9 Aug 2018 8:29] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=91945 marked as duplicate of this one.
[13 Aug 2018 14:47] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=91991 marked as duplicate of this one.
[13 Aug 2018 18:51] Peter House
I notice the severity is rated S5 for Performance.

Unfortunately when this bug occurs, work stops completely.  As a user, I would not call this a performance issue - it STOPS WORK until the program is restarted and then sometimes requires two or three restarts before work can resume!!!

Should the severity be adjusted to something more serious?
[14 Aug 2018 5:10] Umesh Shastry
Bug #92003 marked as duplicate of this one
[14 Aug 2018 5:38] Rafael Bracho
I know bug #92003, submitted by me, was marked as duplicate of this one.  In reading this thread, I noticed that it cannot be reproduced easily.  I spent some time duplicating it with a minimum of steps and the standard World scheme.  If you look at the bug #92003 description, you may be able to find the problem.
[19 Aug 2018 21:06] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=92065 marked as duplicate of this one.
[20 Aug 2018 5:26] Umesh Shastry
Bug #92072 marked as duplicate of this one
[20 Aug 2018 15:38] Francesco Montanari
For me it happens even after 30 minutes. No errors are written in the logs.

Screencast: https://www.youtube.com/watch?v=Mx2nkydaszQ
[21 Aug 2018 18:33] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=92111 marked as duplicate of this one.
[22 Aug 2018 15:37] Dawid Nawrot
Happens to me on 8.0.12 all the time.. I need to restart the whole program but if I have data imports running I can't restart it.
[24 Aug 2018 5:34] Umesh Shastry
Bug #92171 marked as duplicate of this one
[24 Aug 2018 7:28] Umesh Shastry
Bug #92172 marked as duplicate of this one
[24 Aug 2018 9:47] Diana Lene Sarmiento
Hoping to resolve this issue ASAP as it is not produtive when you need to close and open the workbench when result is not showing again. I am thinking to use older version of workbench until this issue is resolved.
[24 Aug 2018 17:57] Douglas Schumacher
I am also experiencing this issue.  Sometimes it only takes a couple of queries before the result grid stops displaying.
[24 Aug 2018 21:25] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=92182 marked as duplicate of this one.
[27 Aug 2018 21:26] Francesco Montanari
The issue appears to happen only if you have a large number of tabs open.
Workaround: only keep a small number (<10) of tabs and it never happens.
[28 Aug 2018 4:29] Rafael Bracho
I disagree with the last comment.  If you go to Bug #92003 (marked as duplicate of this one), I reproduced the bug from a clean start, with the standard 'world' database, and only two tabs open.  It was the simplest way I found, to assist in finding the problem.
[28 Aug 2018 4:41] Rafael Bracho
While reproducing the problem in the aforementioned Bug #92003 (again, a duplicate), I found that it seems to be an interaction of opening tabs that do not require a "Results Grid", after which it refuses to come back.  In that bug, I exectuted the "Alter Table..." command.

I DO have a WORKAROUND: I now open two CONNECTIONS to the same database, and use one of them EXCLUSIVELY for queries that require a "Results Grid", leaving other commands (like "Alter Table...", etc.) to the other connection.  I have yet to experience "disappearance" of the grid, as long as I don't mix and match tabs that don't require it.
[1 Sep 2018 18:33] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=92261 duplicate of this one.
[10 Sep 2018 9:54] Bart Baeyens
I have exactly the same problem (Workbench 8.0.12, MS Windows 10) and have no clue how to reproduce it. I also have to restart Workbench to get rid of the problem.
[10 Sep 2018 14:29] Andrew Jennings
I can reproduce it easily.  

1. Start several query tabs
2. In at least one of the tabs, include statements that do not require an output (I used Prepare / Execute / Deallocate)
3. In any tab, run a query which requires output, the grid is gone and you have to click the lightening bolt with mag glass, then choose results grid.  This must be done for each execution of an output query.

Some things to note: 

1) you do not need to restart workbench
2) you can comment out the non-output statements, then run an output query
3) if you leave the non-output statements alone, you can leave and re-enter workbench until the cows come home - you will never get the results grid to display.

So the problem seems pinned to the existence of a statement which requires no output.
[10 Sep 2018 17:58] Rafael Bracho
ONCE AGAIN, PLEASE GO TO BUG #92003 (marked as duplicate of this one), JUST CLICK ON THE CROSSED LINK.

I gave a very simple recipe to reproduce the bug.  It is indeed, related to outputs with no results grid, as Andrew Jennings noted.  In that bug report I used the World database and gave simple steps to reproduce the bug, invoking the "Alter Table..." command of Workbench to foobar the results grid.

My WORKAROUND, mentioned earlier in THIS bug, is to open TWO connections.  Use one exclusively for commands or queries that use the results grid, do not mix with other commands (used the other connection for those).  I no longer have to restart (but it is a very stupid state of affairs).
[10 Sep 2018 23:30] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=92356 marked as duplicate of this one.
[11 Sep 2018 2:59] David L
I encounter this problem every time I use Workbench.

If I close the connection tab and reopen it, then I don't see the schemas at all (no databases, no tables...). The only way to fix it is to close the program entirely and restart.

I'm connecting to a 5.7 server.
[12 Sep 2018 12:15] thomas270 Perrone
I am having the same issue.  I have only 3 tabs open and it happens frequently. I need to close workbench and reopen it.  This is not very workable. I am running on MAC OS 10.13.6 workbench 8.0.12
[13 Sep 2018 5:52] Umesh Shastry
Bug #92395 marked as duplicate of this one
[14 Sep 2018 6:10] Umesh Shastry
Bug #92412 marked as duplicate of this one
[15 Sep 2018 3:01] David Webb
I can confirm the same bug. Windows 10 Pro 64-bit. Workbench 8.0.12. The bug appears if I modify a table and then perform a SELECT query (not necessarily on the modified table). WB reports the number of rows returned but does not show the rows. I close WB and re-open, then the select query works.
[16 Sep 2018 22:07] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=92447 marked as duplicate of this one.
[16 Sep 2018 22:22] Rune Antonsen
Same issue here.
When can we expect to see a fix for this bug? Any official people that can respond to this issue?
[17 Sep 2018 9:58] Roni Gonzalez
I can confirm that in Ubnutu 18.04 the same Issue
[20 Sep 2018 14:26] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.13 release, and here's the changelog entry:

Executing queries over an period of time caused the existing result grid
in each query tab to be hidden when the grid was previously visible and
prevented the results grid in new tabs from showing.

Thank you for the bug report.
[21 Sep 2018 7:08] Umesh Shastry
Bug #92514 marked as duplicate of this one
[21 Sep 2018 17:05] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=92531 marked as duplicate of this one.
[2 Oct 2018 17:04] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=92639 marked as duplicate of this one.
[2 Oct 2018 20:35] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=92642 marked as duplicate of this one.
[5 Oct 2018 7:01] Umesh Shastry
Bug #92669 marked as duplicate of this one
[8 Oct 2018 3:51] Umesh Shastry
Bug #92701 marked as duplicate of this one
[11 Oct 2018 14:49] Umesh Shastry
Bug #92752 marked as duplicate of this one
[19 Oct 2018 23:18] John Herndon
Possible Workaround:

1. Open your query for the first time and you will see the results grid.
2. Slide that tab to the left of the default empty Query tab.
3. Always keep this window over to the left of the empty query tab.
4. Results grid will stay open on subsequent queries.

General rule: Keep a tab on the far left that has a result grid.
[2 Nov 2018 4:41] Umesh Shastry
Bug #93051 marked as duplicate of this one
[8 Nov 2018 11:28] Vitor NoĢbrega
same bug
[19 Nov 2018 7:20] Umesh Shastry
Bug #93242 marked as duplicate of this one
[28 Nov 2018 9:09] vikas verma
same problem, it will happen when you run a query which may have an error (syntax or otherwise) and no out put results. Post that, the only option seems to be restart the workbench.
[28 Dec 2018 19:31] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=93759 marked as duplicate of this one.
[4 Jun 18:06] Anthony Mako
I have this problem on Windows 8.1. It happens pretty consistently after issuing ALTER TABLE. This may be related to a mismatch between the database version and the workbench version. Or, it could have something to do with these two lines from the log file:

13:46:02 [WRN][            grt]: C:\Program Files\MySQL\MySQL Workbench 8.0 CE\modules/data/mysql_rdbms_info.xml:1401: link 'om.mysql.rdbms.mysql.driver.native_sshtun' <object > key=owner could not be resolved
13:46:03 [WRN][            grt]: C:\Users\Tony\AppData\Roaming\MySQL\Workbench\connections.xml:27: link '{37AC987C-F540-47CD-9D74-430D9760A7AC}' <object GrtObject> key=owner could not be resolved