Bug #91882 workbench sometimes doesn't show query result
Submitted: 3 Aug 2018 5:36 Modified: 3 Aug 2018 6:20
Reporter: Zhong Willi Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:8.0.12 OS:Microsoft Windows (Microsoft Windows 8.1 China)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[3 Aug 2018 5:36] Zhong Willi
Description:
13:01:01 [ERR][      Workbench]: Console redirection failed.
13:01:01 [INF][      Workbench]: Starting up Workbench
13:01:01 [INF][      Workbench]: Current environment:
	Command line: "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\MySQLWorkbench.exe" 
	CurrentDirectory: C:\Program Files\MySQL\MySQL Workbench 8.0 CE
	HasShutdownStarted: False
	OSVersion: Microsoft Windows NT 6.2.9200.0
	SystemDirectory: C:\Windows\system32
	TickCount: 1724037921
	UserInteractive: True
	Version: 4.0.30319.42000
	WorkingSet: 39251968
13:01:01 [INF][      Workbench]: Environment variables:
	COMPUTERNAME = WILLI-ASUS
	USERPROFILE = C:\Users\Administrator
	HOMEPATH = \Users\Administrator
	LOCALAPPDATA = C:\Users\Administrator\AppData\Local
	PSModulePath = C:\Windows\system32\WindowsPowerShell\v1.0\Modules\;C:\Program Files (x86)\Microsoft SQL Server\120\Tools\PowerShell\Modules\;C:\Program Files\Microsoft Message Analyzer\PowerShell\
	PROCESSOR_ARCHITECTURE = AMD64
	Path = C:\ProgramData\Oracle\Java\javapath;C:\Program Files\Microsoft MPI\Bin\;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files\Microsoft SQL Server\Client SDK\ODBC\110\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\120\Tools\Binn\;C:\Program Files\Microsoft SQL Server\120\Tools\Binn\;C:\Program Files\Microsoft SQL Server\120\DTS\Binn\;C:\Program Files (x86)\Microsoft SQL Server\120\Tools\Binn\ManagementStudio\;C:\Program Files (x86)\Microsoft SQL Server\120\DTS\Binn\;C:\Program Files\Microsoft SQL Server\130\Tools\Binn\;C:\Program Files\Microsoft DNX\Dnvm\;C:\Program Files\dotnet\;C:\Program Files\TortoiseSVN\bin;C:\Program Files\nodejs\;C:\Program Files\PuTTY\;C:\Program Files (x86)\Microsoft SQL Server\Client SDK\ODBC\130\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\140\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\140\DTS\Binn\;C:\Program Files (x86)\Microsoft SQL Server\140\Tools\Binn\ManagementStudio\;C:\Program Files\Git\cmd;C:\Program Files\phantomjs2.1.1\bin;C:\Program Files (x86)\Microsoft VS Code\bin;C:\Program Files (x86)\Java\jre7\bin;C:\Users\Administrator\AppData\Local\Programs\Fiddler;C:\Python27;C:\Users\Administrator\AppData\Roaming\npm
	CommonProgramFiles(x86) = C:\Program Files (x86)\Common Files
	ProgramFiles(x86) = C:\Program Files (x86)
	PROCESSOR_LEVEL = 6
	LOGONSERVER = \\WILLI-ASUS
	PATHEXT = .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
	HOMEDRIVE = C:
	SystemRoot = C:\Windows
	SESSIONNAME = Console
	ALLUSERSPROFILE = C:\ProgramData
	PUBLIC = C:\Users\Public
	FP_NO_HOST_CHECK = NO
	APPDATA = C:\Users\Administrator\AppData\Roaming
	PROCESSOR_REVISION = 3c03
	USERNAME = Administrator
	CommonProgramW6432 = C:\Program Files\Common Files
	VS140COMNTOOLS = C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\Tools\
	CommonProgramFiles = C:\Program Files\Common Files
	OS = Windows_NT
	USERDOMAIN_ROAMINGPROFILE = willi-asus
	PROCESSOR_IDENTIFIER = Intel64 Family 6 Model 60 Stepping 3, GenuineIntel
	FSHARPINSTALLDIR = C:\Program Files (x86)\Microsoft SDKs\F#\10.1\Framework\v4.0\
	GYP_MSVS_VERSION = 2015
	SystemDrive = C:
	TEMP = C:\Users\ADMINI~1\AppData\Local\Temp
	ProgramFiles = C:\Program Files
	NUMBER_OF_PROCESSORS = 8
	ComSpec = C:\Windows\system32\cmd.exe
	MSMPI_BIN = C:\Program Files\Microsoft MPI\Bin\
	TMP = C:\Users\ADMINI~1\AppData\Local\Temp
	ProgramData = C:\ProgramData
	ProgramW6432 = C:\Program Files
	windir = C:\Windows
	USERDOMAIN = willi-asus
13:01:01 [INF][      Workbench]: Current version given by meta info is: 8.0.12
13:01:01 [INF][      Workbench]: Setting PATH to: C:\Windows\system32;C:\ProgramData\Oracle\Java\javapath;C:\Program Files\Microsoft MPI\Bin\;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files\Microsoft SQL Server\Client SDK\ODBC\110\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\120\Tools\Binn\;C:\Program Files\Microsoft SQL Server\120\Tools\Binn\;C:\Program Files\Microsoft SQL Server\120\DTS\Binn\;C:\Program Files (x86)\Microsoft SQL Server\120\Tools\Binn\ManagementStudio\;C:\Program Files (x86)\Microsoft SQL Server\120\DTS\Binn\;C:\Program Files\Microsoft SQL Server\130\Tools\Binn\;C:\Program Files\Microsoft DNX\Dnvm\;C:\Program Files\dotnet\;C:\Program Files\TortoiseSVN\bin;C:\Program Files\nodejs\;C:\Program Files\PuTTY\;C:\Program Files (x86)\Microsoft SQL Server\Client SDK\ODBC\130\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\140\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\140\DTS\Binn\;C:\Program Files (x86)\Microsoft SQL Server\140\Tools\Binn\ManagementStudio\;C:\Program Files\Git\cmd;C:\Program Files\phantomjs2.1.1\bin;C:\Program Files (x86)\Microsoft VS Code\bin;C:\Program Files (x86)\Java\jre7\bin;C:\Users\Administrator\AppData\Local\Programs\Fiddler;C:\Users\Administrator\AppData\Roaming\npm
13:01:01 [INF][ mforms managed]: Initializing mforms wrapper
13:01:01 [INF][   WBContext UI]: Initializing workbench context UI with these values:
	base dir: C:\Program Files\MySQL\MySQL Workbench 8.0 CE
	plugin path: C:\Program Files\MySQL\MySQL Workbench 8.0 CE
	struct path: 
	module path: C:\Program Files\MySQL\MySQL Workbench 8.0 CE/modules
	library path: C:\Program Files\MySQL\MySQL Workbench 8.0 CE
	user data dir: C:\Users\Administrator\AppData\Roaming\MySQL\Workbench
	open at start: 
	open type: 
	run at startup: 
	run type: 
	Force SW rendering: No
	Force OpenGL: No
	quit when done: No
13:01:01 [INF][      WBContext]: WbContext::init
13:01:02 [INF][            WBA]: Looking for extension modules for WBA...
13:01:02 [INF][            WBA]: 0 extension modules found
13:01:02 [WRN][            grt]: C:\Program Files\MySQL\MySQL Workbench 8.0 CE\modules/data/mysql_rdbms_info.xml:1401: link 'om.mysql.rdbms.mysql.driver.native_sshtun' <object > key=owner could not be resolved
13:01:02 [WRN][            grt]: C:\Users\Administrator\AppData\Roaming\MySQL\Workbench\connections.xml:18: link '{52616532-E437-4D70-8B67-5DDB1BBB8B85}' <object GrtObject> key=owner could not be resolved
13:01:02 [INF][      WBContext]: System info:
 	MySQL Workbench Community (GPL) for Windows version 8.0.12 CE build 13312926 (64 bit)
	Configuration Directory: C:\Users\Administrator\AppData\Roaming\MySQL\Workbench
	Data Directory: C:\Program Files\MySQL\MySQL Workbench 8.0 CE
	Cairo Version: 1.10.2
	OS: Microsoft Windows 8.1 China
	CPU: 8x Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz, 7.9 GiB RAM
	Active video adapter Intel(R) HD Graphics 4600
	Installed video RAM: -1984 MB
	Current video mode: 1920 x 1080 x 4294967296 种颜色
	Used bit depth: 32
	Driver version: 10.18.10.3574
	Installed display drivers: igdumdim64.dll,igd10iumd64.dll,igd10iumd64.dll,igdumdim32,igd10iumd32,igd10iumd32
	Current user language: 中文(简体,中国)

13:01:02 [INF][      Workbench]: UI is up
13:01:02 [INF][      Workbench]: Running the application
13:01:04 [INF][SQL Editor Form]: Opened connection 'Local instance MySQL Router' to mariadb.org binary distribution version 10.1.34-MariaDB
13:01:04 [ERR][      WBContext]: Unsupported server version: mariadb.org binary distribution 10.1.34-MariaDB
13:01:04 [INF][        WQE.net]: Launching SQL IDE
13:01:05 [INF][        WQE.net]: SQL IDE UI is ready

How to repeat:
I don't get insight into the cause of the problem. I have just found sometimes that the result sets didn't show after executing query.
[3 Aug 2018 6:20] MySQL Verification Team
Hello Zhong Willi,

Thank you for the report.
This is most likely duplicate of Bug #91265, please see Bug #91265

regards,
Umesh