Bug #87714 Results Grid Not displaying data on OSX High Sierra 10.13 beta (17A630a)
Submitted: 8 Sep 21:56 Modified: 21 Oct 23:09
Reporter: Bob Davenport Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:6.3.9 OS:Mac OS X (High Sierra 10.13)
Assigned to:
Tags: Results Grid on OSX High Sierra 10.13 beta (17A630a)

[8 Sep 21:56] Bob Davenport
Description:
When Viewing results from Query  the results placeholder cell is not displayed 
Also the setFont method of MResultsetViewer.mm has a for loop which errors due to the missing placeholder colunm.

wrong font displayed on High Sierra beta 

How to repeat:
run a query from a new query tab simply selecting a few results from any table

Suggested fix:
in WBExtras > Results Viewer > MResultsetViewer.mm
modify setfont for loop:
1)
// this is better than the old  loop which errors when the grid is not initalised because it uses // the record set count and not the column count of the grid
- (void)setFont:(NSFont*)font
{
  	mFont = font;
	float rowHeight = 0;
	for(NSTableColumn *column in gridView.tableColumns) {
		if (mFont)
		{
			[column.dataCell setFont: mFont];
			rowHeight = MAX(rowHeight, [[column dataCell] cellSize].height + 1);
		}
	}

    if (rowHeight > 0)
        gridView.rowHeight = rowHeight;

}

//

2) in the same module - (void)rebuildColumns

// when removing columns the check for a null identifier needs to also chec the string is empty
// it seems High Sierra initialises the placeholder identity column to an empty string instead of null
// which it is removed so causing the setFont to fail and the placeholder arro not to be displayed.

for (id column in [gridView.tableColumns reverseObjectEnumerator])
  {
  
      if ([column identifier] && [[column identifier] length] != 0 )
         
      [gridView removeTableColumn: column];
      
      
  }

3) font not being found (High Sierra again)
in WBExtras > Results Viewer > mmforms > RecordGridView..mm
// void RecordGridView::set_font(const std::string &font_desc)
// the NSFontDescriptor *fd  doesn't retrieve the correct font
// to pass to viewer setFont:font
// on/about line 185 look for
NSFontDescriptor *fd = [NSFontDescriptor fontDescriptorWithName: @(font.c_str()) size: size];
// this  works better on high sierra beta
NSFontManager *fontManager = [NSFontManager sharedFontManager];
  NSFont *font = [fontManager fontWithFamily:fontName
											traits:(bold ?NSBoldFontMask:0)|(italic ? NSItalicFontMask:0)
											weight:5
											  size:size];
//then call
 [viewer setFont:font];
[8 Sep 22:06] Bob Davenport
missed out suggested variable for issue 3) Oops! my bad
NSString * fontName = @(font.c_str());
[15 Sep 14:13] Miguel Solorzano
Thank you for the bug report. I can't repeat this issue on macOS Sierra 10.12.6 which is stable released version you are reporting a bug of WorBench on Beta release, are you reported this bug to Apple?. Thanks.
[15 Sep 20:39] Bob Davenport
Miguel Solorzano 
If you dont test it on High Sierra its your lookout for what happens when it is released.

And i thnk shte way the code is written iscould be improved.

The (works on macOS Sierra 10.12.6) comment is not helpful. I already know that
The point is what is going to happen when High Sierra 10.13 is released
Perhaps we all hope apple change the semantics to suit mysql (I dont think so)
If youre ok with taking a gamble on this it is up to you. I will sit back and watch.

BTW the font handling may also break as it is sub optimal as i have observed.

Good Luck.
[16 Sep 13:56] Richard Watson
I have the same problem. No output from a query is showing when using 10.13 Beta (17A362a).

As High Sierra will be released in less than two weeks, this problem needs to be addressed asap.  

I have reverted to 6.1.7, which works.
[19 Sep 9:06] Miguel Solorzano
Thank you for the feedback.
[19 Sep 9:43] Miguel Solorzano
In order to submit contributions you must first sign the Oracle
Contribution Agreement (OCA). For additional information please check
http://www.oracle.com/technetwork/community/oca-486395.html

If you have any questions, please contact the MySQL community team at
http://www.mysql.com/about/contact/?topic=community
[27 Sep 15:17] Peter Finch
Mac OS High Sierra is now officially out and this defect is real and impacting users including myself. I believe defect #87862 is a duplicate which, fortunately, is tagged as S1 (Critical).
[27 Sep 15:38] Tom Donovan
Incredibly frustrating, but at least it seems I'm not alone here... 

Please MySQL team, do something about this before you start losing many users to Navicat... ugh
[27 Sep 17:32] Rupesh Gupta
This was a known issue in previous releases and has been fixed so why not fix quickly for High Sierra 10.13.
More and more people will be downloading this version as it is officially available starting 09/25/17.

Appreciate a quick fix.
[28 Sep 16:34] Xavier Maquil
a fix would be cool, I am already looking for an alternative
[28 Sep 20:20] Bob Davenport
if anybody wants a fix i have compiled up the 6.3.9 source code on High Sierra and will be happy to provide the .dmg install and source code i used.

have a look here 
https://drive.google.com/drive/folders/0B2fTesDcrHzVRGVFWEdILWpuaEE?usp=sharing

it's syncing at the moment so all should be available in 30 minutes

the dmg is in the root folder as i didn't wait for MySql to fix

as well as all the source code i downloaded from MSQL and patched

I advised weeks ago this would be a problem

even put a nice icon on the dmg for them
[29 Sep 8:57] Jonas Trollvik
Thanks for the great work Bob, as you say this should have been fixed before the official release of High Sierra.

 It would be great if you can provide the dmg. I tried compiling it from source yesterday with the patches you provided, but I got stuck on finding the lib that provides "MySQLLexer.h"
[29 Sep 10:42] Bob Davenport
dmg is in this shared folder

https://drive.google.com/drive/folders/0B2fTesDcrHzVRGVFWEdILWpuaEE?usp=sharing 

"MySQLLexer.h" is generated by running  a shell script build-parsers-mac 

"./build-parsers-mac mysql"

which is in the src code's folder path "library/parsers/grammars/"
[1 Oct 12:38] Darren Coleman
Bob's .DMG file didn't work for me on a Late 2016 MacBook Pro running High Sierra.  Crashes on startup: https://pastebin.com/2fD1bPYH

Thanks anyway Bob.  Ridiculous that this has been known for so long and unfixed.  Unlike Windows it's safe to assume that most if not all Mac owners will be upgrading to High Sierra as a matter of course.
[1 Oct 13:44] Laurent Cocea
"Bob's .DMG file didn't work for me on a Late 2016 MacBook Pro running High Sierra." -- Same thing here on a Mac mini running High Sierra. Of note, the size of that .dmg is 30MB compared to the 100MB of the published 6.3.9 .dmg. 

Trying to rebuild from source now. Does the source tree dated Sep 28 includes all the latest revisions? Is there anything else required?
[1 Oct 16:08] Bob Davenport
Thanks for the info Darren

looks like  libfontconfig.1.dylib isn't being found from your paste-bin 

Dyld Error Message:
  Library not loaded: @executable_path/../Frameworks/libfontconfig.1.dylib
  Referenced from: /Applications/MySQLWorkbench.app/Contents/Frameworks/libcairo.2.dylib
  Reason: image not found

I need to check a post build phase it should have included the libs in the dmg.

Bob
[1 Oct 16:26] Bob Davenport
Yes the source tree dated dte Sep 28 is the latest

Good luck Laurent hope it builds ok

I think the issue is with dylibs  which are added to the packaged app  in MySQLWorkbench.app/Contents/Frameworks 
in the build their is a post build phase which ensure all the dylib's are present and linked correctly.

I've found a mac pro on which the library problem shows up so i can use it as a test target.
[4 Oct 11:05] Darren Coleman
Any more updates on this Bob?  Appreciate you've gone out of your way to try and build a community version that works, given Oracle can't be bothered seemingly.
[4 Oct 12:53] Bob Davenport
Hi Darren,

Ive  created an updated dmg at :
https://drive.google.com/drive/folders/0B2fTesDcrHzVRGVFWEdILWpuaEE?usp=sharing

I found that i wasn't linking the dylibs correctly  for the app and on my development machine it was being compensated for by the development environment Oops My bad!

Anyway the lates attempt i have now tried on 3 other macs including an older Yosemite  version.

All seems good so if anyone would like to try please do.

I found a very useful app which will show application dependencies so thanks to Konrad Windszus who provided this utility.
https://github.com/kwin/macdependency

Bob
[4 Oct 13:02] Jonas Trollvik
Thanks Bob!
Can confirm this build works on my mac
[4 Oct 13:21] mike coutinho
Thank you Bob.  

I can also confirm that what you did worked.  

15 inch macbook pro 2017 and works great after two queries
[4 Oct 13:37] Darren Coleman
Thanks Bob, you're a star.

Unfortunately your build doesn't work on my iMac, I just get "Cannot start SSH tunnel manager" with my connection.  Have completely uninstalled MySQLWorkbench and the configuration (~/Library/Application Support/MySQL) to no avail.

Thanks anyway :(
[4 Oct 13:41] Darren Coleman
Some relevant debug as to why I can't use SSH on Bob's package:

2017-10-04 14:39:35.286 MySQLWorkbench[8533:7431710] *** WARNING: Textured window <WBWindow: 0x7faf0af4ab60> is getting an implicitly transparent titlebar. This will break when linking against newer SDKs. Use NSWindow's -titlebarAppearsTransparent=YES instead.
Traceback (most recent call last):
  File "/Applications/MySQLWorkbench.app/Contents/Resources/plugins/wb_admin_ssh.py", line 46, in <module>
    import paramiko
ImportError: No module named paramiko
Warning! Can't use connect with timeout in paramiko None
Ready.

2017-10-04 14:39:35.963 MySQLWorkbench[8533:7431710] TODO: restore edit menu
Traceback (most recent call last):
  File "/Applications/MySQLWorkbench.app/Contents/Resources/sshtunnel.py", line 32, in <module>
    import paramiko
ImportError: No module named paramiko

** (process:8533): WARNING **: Tunnel manager could not be executed
[4 Oct 16:41] Michael Brogley
Bob's package (announced in comment 4 Oct 12:53) works on my mid-2014 vintage 15" MacBook Pro running High Sierra (10.13)
[4 Oct 16:42] Darren Coleman
Does it need to be installed over the top of the Oracle released version?
[4 Oct 17:03] Bob Davenport
Hi Everyone,

the SSH fix is on the way...
its simply a directory path in the  apps Contetns/Resources/plugins/paramiko  folder 
testing on a local mac so should be about 10mins

Bob
[4 Oct 17:10] Darren Coleman
Bob, you're a prince among men. :)
[4 Oct 17:20] Bob Davenport
SSH is looking good:

Latest dmg is in folder:
 https://drive.google.com/drive/folders/0B2fTesDcrHzVRGVFWEdILWpuaEE?usp=sharing

paramiko is packaged within the app
 i just needed to make sure the path was correct.

MySql team have put a lot of work in to this app's packaging. 
But once you realise what goes where (without documentation) all becomes logical. 

Cheers,
Bob
[4 Oct 18:52] Ian Rutson
Thanks for your hard work, Bob.

I'm getting:
"Cannot start SSH tunnel manager"

with this build. Any clues?

Cheers
[4 Oct 19:40] Darren Coleman
Same for me sadly, same error as the previous build.

I'm guessing your development environment has a load of librarys & tools available that we don't, which explains why it works on yours (and possibly others with the devtools too).

The build you uploaded is only 28MB whereas the official one is (last I checked) circa 100MB, probably because they are statically linking libraries and you aren't.

Thanks for your continued efforts on this, won't be upset if you decide you've had enough! :)
[4 Oct 20:17] Bob Davenport
My Apologies i was too hasty in preparing the dmg  package for upload
i've redone it and uploaded
 to google drive again

Cheers,

Bob
[4 Oct 21:07] Darren Coleman
Working like a charm now - connection & queries work fine.  You're a star, thanks so much :)
[5 Oct 6:28] Mike Lischke
Bug #87862 marked as duplicate of this bug.
[5 Oct 8:57] Bob Davenport
Excellent
Thanks for the feedback Darren.

Hopefully MySql Team will fix the official version soon. Meanwhile. If any problems with my
(unofficial) fix please let me know.

Cheers,

Bob
[5 Oct 22:15] Ben Matis
Bob Davenport you're the best! MySQL WorkBench is working again following the update I did using your dmg!
[6 Oct 7:23] Umesh Shastry
Bug #88007 marked as duplicate of this one
[10 Oct 3:43] Sean Pratt
I had the same issue with the official release of High Sierra 10.13 (17A405).

I downgraded to 6.1.7 and it seems to work fine with High Sierra.

Will be very pleased when the official MySQL newest version works properly with High Sierra.
[10 Oct 5:55] Umesh Shastry
Bug #88035 marked as duplicate of this one
[10 Oct 5:57] Umesh Shastry
Bug #88037 marked as duplicate of this one
[11 Oct 23:59] Christine Cole
Posted by developer:
 
Executing a query in MySQL Workbench on a host running macOS High Sierra failed to load the result grid completely and result 
data from the query were not visible within the Result Grid tab.
[12 Oct 0:03] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 6.3.10 release.
[12 Oct 9:24] Umesh Shastry
Bug #88074 marked as duplicate of this one
[12 Oct 11:22] Alan Murphy
Thanks Bob! The mod works for me.
[13 Oct 6:35] Umesh Shastry
Bug#88085 marked as duplicate of this one
[13 Oct 16:47] Víctor Chávez
THANK YOU Bob! Great job
[14 Oct 0:48] Ryan Harper
Thank you to Bob as well!  I appreciate your work!
[14 Oct 11:43] Owen Matthews
Thank you Bob. I set up an Oracle account just to say that you saved my life!
[16 Oct 2:37] L Y
Thank you to Bob! good work!
[16 Oct 15:50] Romain Riche
Has anyone an idea on when the official 6.3.10 version will be available? Thanks
[17 Oct 2:30] Daniel Henson
You're amazing, Bob. Sadly, my org won't allow me to install your dmg. Oracle, you should be embarrassed.
[17 Oct 10:30] Karthikeyan M
When can we expect 6.3.10 release to publci?
[18 Oct 9:02] Simon Melouah
Hey guys,

Did anyone else's Mac prompt for every password in the keychain again when Bob's .dmg file was installed? I got prompted for github, email, database instances, icloud password.

Is this file to be trusted?
[18 Oct 9:07] Darren Coleman
Obviously you should only ever use any unverified software in a suitably sandboxed environment, or - if not - accept the risks of running it on your systems.

For what it's worth - I haven't experienced any password request anomalies like that, nor noticed any spurious outbound traffic.  ESET reports no issues with the .DMG file.  That's not a guarantee of anything of course, your mileage may vary.
[18 Oct 9:50] Bartosz K
After install Bob's version Workbench asked me about password to keychain. I gave a bad password and now I get message: "There was an error storing the password:Error storing password:The user name or passphrase you entered is not correct." Any idea how to change keychain password in workbench?
[18 Oct 12:18] Bob Davenport
Thanks for the feedback.

The keychain access prompt is normal  for any unsigned app. but if you grant it will be ok.
Sometimes you need to remove the keychain stored password and re-apply 
I dont know why this is but... after a few test i found it worked.

To provide a code signed app I need to pay apple £100+ and carry out various verification checks which i am quire happy to do [just not the cash to by the cert yet],  as i'm offering a free [one off] fix  ...

I also looked in to doing the paperwork to become an oracle contributor but this means my fix would still not be released, just sit in their queue. [but possibly speed the queue up by an unknown amount]

I know My work can be trusted, i trust it. but if you dont trust then dont use the dmg, just wait for oracle to fix. the choice is yours. 

I have also emailed the oracle sales/support team the fix too, so the are fully aware of this fix and have my lines of code to apply.

As always Thanks for everyones feedback.  if you get stuck i will try my best to help.

For those who are curious add have an hour or 2...  
[long list of how to fix yourself below ] [all with signed software & source  code from oracle]

The code that compiled the app that is in the dmg is also in the same location.

If anyone prefers and has the time i would suggest  this remedy to trusting the software....

1) download the my sql source code [zip file] from oracle its in the list of downloads where their official [non working 6.3.9 ] release is.

2) Create a folder called workbench or similar [name isnt important but folder names / path must not have spaces as xcode has issues with spaces]

3) Extract the source to it (so you have  she source code folder in the folder) from 
copy the folder "mysql-mac-res"
from https://drive.google.com/open?id=0B2fTesDcrHzVRGVFWEdILWpuaEE
/xcode_workbench/
put the  "mysql-mac-res" folder in  to the folder cerated in (2)

This mac-res is the dependant libraries mysql-needs.

You can also find these files by following the instructions in their Readme file
Their instructions are good but fail to mention the requirement of the mac-res folder or what should be in it, this took me some time to get right.

There are more instructions in the readme as to getting apples xcode to compile the app.

I would suggest xcode 8.3 and not later.

4)  in the readme their i think also no mention of running the requirement to run
<source_folder>/library/parsers/grammars/build-parsers-mac
this creates some required files.

at this stage xcode should compile the code you have from oracle.

All you now need to do now is apply the fix as documented in the beginning of the bug i logged.

 the whole fix is no more than  a few lines of code . but takes a long while to set up the programming environment and time to compile.

the main culprit in the code is in a file MResultsViewer.mm 
look for "- (void)rebuildColumns" and a few lines below
 
//change 
if ([column identifier] ){
          [gridView removeTableColumn: column];
      }
//to 
if ([column identifier] && [[column identifier] length] != 0){
          [gridView removeTableColumn: column];
      }

 just adding the "&& [[column identifier] length] != 0" is the fix

also in the same file search for "if (aTableColumn.identifier != nil" and add 
"&& aTableColumn.identifier.length != 0" before the end ")"

That is pretty much it  their "nil" testing and the results viewer   in high sierra just needs an additional  test  
Its not oracles fail , these niggling things happen often in the real world.
I blame apple but getting them to change is harder than getting oracle to change 
as the semantic apple changed doesn't appear to have broken other apps so sadly oracle probably has limiterd leverage on apple.

Cheers,

Bob
[18 Oct 14:52] Bob Davenport
FYI:
https://support.apple.com/en-gb/HT201609

Forgot to mention to clear keychain of mysql stored info 
launch apples  keychain access app
mysql@ in the search box
pick out the ones you want to clear.

The repeated prompts for acess also i think can be cured by making sure workbench is closed [check its gone on force quit list]

Then when opening or prompted click the always allow rather than allow once button when prompted to store/ retrieve info.
[18 Oct 15:14] Bob Davenport
also worth reading this to see more detail on the  keychain

https://developer.apple.com/library/content/documentation/Security/Conceptual/keychainServ... 

You should always be prompted when accessing keys that a specific application didn't originally create. 

in the keychain app you can also see who has access to what by double clicking an entry and selecting Access Control

Easy to know who is seeing what and to reconfigure an individual item.
[18 Oct 17:30] Daniel Henson
Bob, again, you've gone above and beyond. I'm sure there's a lot of people struggling and your fix is a godsend to those users.

Not to take anything away from Bob's work here, but for those of you who are unable to install his dmg for security reasons, here's a fix that was in a another forum(stackoverflow): 

Install version 6.1.7 of MySQL Workbench. You're able to install it right alongside of your current MySQL Workbench instance. For myself, it brought over all my settings.

Here's the link:

https://dev.mysql.com/get/Downloads/MySQLGUITools/mysql-workbench-community-6.1.7-osx-i686...
[19 Oct 12:23] Sean Pratt
Is there any indication of timeframe that 6.3.10 will be released? Or a place that talks about upcoming releases? I see the bug is marked as "Closed" because of the impending fix, I believe.

I'm not able to do the fix that Bob put in here unfortunately. I was able to downgrade to 6.1.7 so that the results show up, but there are separate bugs that I am dealing with in that version. I need a totally working version.
[19 Oct 14:48] asd asd
Great work by the community, but don't think this should be considered closed until a fix has been pushed upstream and rolled into a release (or in the pipeline for a release).
[20 Oct 9:07] Umesh Shastry
Bug #88089 and Bug #88022 marked as duplicate of this one
[20 Oct 10:32] Bob Davenport
Changing back to open
[20 Oct 10:36] Bob Davenport
I've changed back to open as its not fixed till the release is available.
I never  clsed it perhaps the pperson who closed it could come forward and explain how a bug rendering a product 99% unusable can be marked as closed?
[20 Oct 12:12] Mike Lischke
This bug entry was closed as part of our internal processes. Please don't touch the status of a bug anymore, once it closed.
[20 Oct 15:25] Bob Davenport
Mike Lischke

Why is a bug closed when their is no fix ? 
Or can you advides the date the fix was released?

Very disappointing that the attitude of yours is so poor.

Maybe next time i wont bother to post a bug report or how to fix.
Also mustn't forget Mike Lischke who also wasted time with the "Works on My PC"  attitude in the firs place.

A discredit to the community.
[20 Oct 15:34] Michael Brogley
I agree with Bob. Based on my experience running just such an effort, a critical status bug should only be changed to "Status: Closed" if a fix has been tested and released. Otherwise any Oracle manager that's tracking open bugs will be misled on the product's status. Playing bug status games like this basically cuts the nerves between the user community and management, leading to misallocation of resource problems downstream, and managers and executives getting blindsided by angry users.

Is there no "Pending" status in this system?
[20 Oct 15:37] Darren Coleman
Why would a bug be closed if the problem is not fixed?

I've never heard of a bug tracking system where people close bugs without actually resolving the problem??

Is it just inconvenient for Oracle to see this (very simple) bug on their TODO list?  It's ridiculous enough as it is that a community member has to go out of their way to patch a bug that existed and was reported more than once while macOS High Sierra was in BETA.. but to close the bug without resolution is just egregious.
[20 Oct 15:57] Mike Lischke
The typical workflow for a bug report in this bug database is like this:

- The bug gets reported.
- A support person checks the validity and clarifies things when necessary.
- The bug is transfered to our internal bug system where the developers are notified.
- The developers fix the bug.
- QA tests the fix.
- The documentation team takes a note for the change log and sets the bug to closed (both internally and externally).
- Once all bugs for a release are closed the new version is released.

Hopefully this makes the process more clear.
[21 Oct 15:12] Bob Davenport
Mike Lischke/ Oracle Can you please  advise:

How many bugs are currently open and closed and a release date please?

The bug renders the application unable to display any query results on high sierra. This isn't an insignificant or cosmetic issue, it's a show stopper.

If some other bugs are still unfixed could you advise a cut-off date when a release will be provided?

Is this also affecting Oracle Enterprise customers?
I think it is.

For what it's worth...

I was performing some beta testing for apple and found the fault so decided to report to Oracle.

I provided Oracle with a suggested fix which is relatively easy to implement and is verified as working.

The fix would be effortless & without risk to deploy as a 'patch' if in an Agile development environment was utilised.

I would have thought Oracle would be up to date on this technology by now.
[22 Oct 22:19] Aaron Langley
It's becoming apparent that Oracle's senior management intends to starve MySQL of oxygen in the hope it's user base with move on to other alternatives.
[23 Oct 5:39] Umesh Shastry
Bug #88180 marked as duplicate of this one
[24 Oct 4:49] Umesh Shastry
Bug #88193 marked as duplicate of this one
[24 Oct 12:04] Ali Akbar
Hi,
This is to bring in your kind notice that-
Results Grid is Not displaying data on Mac OSX High Sierra & MySql Workbench is unstable & crashing a lot in new Mac OS.
Kindly look into this issue. It's quite frustrating. This was not expected from oracle at least.
Regards,
Ali
[24 Oct 12:05] Ali Akbar
Hi,
This is to bring in your kind notice that-
Results Grid is Not displaying data on Mac OSX High Sierra & MySql Workbench is unstable & crashing a lot in new Mac OS.
Kindly look into this issue. It's quite frustrating. This was not expected from oracle at least.
Regards,
Ali
[25 Oct 15:37] Michael Tornado
Bob, thanks a lot for your work! Your solution works for me.
[26 Oct 16:47] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=88235 marked as duplicate of this one.
[27 Oct 5:11] Umesh Shastry
Bug #88244 marked as duplicate of this one
[29 Oct 4:55] Umesh Shastry
Bug #88284 marked as duplicate of this one
[31 Oct 20:16] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=88308 marked as duplicate of this one.
[1 Nov 10:35] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=88314 marked as duplicate of this one.
[1 Nov 19:55] Sean Pratt
Will there be an update on when 6.3.10 is released so this software is usable again in macOS 10.13? Is there somewhere that lists that info? Does anyone know that info?
[2 Nov 0:09] Cayo Bayestorff
Thanks bob for the great job. It works for me.
Really appreciate that. Cheers.
[2 Nov 9:45] Maurice Samulski
Why is this bug report closed? The custom package from Bob Davenport is working well, but the patch has not been applied to an official release yet. Is there an ETA available?
[2 Nov 23:44] Jeffrey Shaikh
Running latest MySQL Workbench version 6.3.9. Doesn't work in High Sierra (10.13) not beta. The data grid view doesn't display and experiencing crashing.
[2 Nov 23:45] Jeffrey Shaikh
Running latest MySQL Workbench version 6.3.9. Doesn't work in High Sierra (10.13) not beta. The data grid view doesn't display and experiencing crashing.
[3 Nov 0:44] Pat Patterson
Bob Davenport's fix works for me. Poor show by the Oracle/MySQL team that they can't release a fix in time for the High Sierra release despite being notified during the High Sierra beta.
[3 Nov 0:45] Pat Patterson
Thanks, Bob!
[3 Nov 2:21] Kim Vandenbroek
Thanks Bob, your fix worked for me.
[3 Nov 18:41] sdasddas das
Why is this closed? I have just downloaded the latest 6.3.9 build and using high sierra (10.13.1): bug is still there!
[4 Nov 0:31] Azaman Suleiman
Thanks so much @Bob Davenport 
Your solution works GREAT..
macOS: High Sierra 10.13.1
MacBook Retina Late 2013
[7 Nov 9:44] austin woz
hasn't been resolved and released to public. waiting on version 6.3.10, will this ever be released?
[7 Nov 10:19] Darren Coleman
Just use Bob's .DMG file posted earlier in the comments.  It works, have been using it daily since he posted it without issue.  

No one has any clue when 6.3.10 will appear, and Oracle don't seem to care about keeping anyone in the loop.
[8 Nov 1:52] Oscar Hernández
Bob.

You are the best!
Thanks for the solution.
[9 Nov 11:37] Adam Rabinowitz
Bob you're a lifesaver!!
[9 Nov 12:00] Klaus Wohlgemuth
thank you very much, bob.
Your solution works well for me.
[10 Nov 13:27] Jonathan D
Any update on when we can expect a release? Using a 3rd party DMG is not an option for all of us and the application has been completely broken for a month and a half.

Oracle reps have contacted me several times to move our business to your cloud hosting from AWS. The way you treat updates to this application is a major reason we would not consider doing so.
[10 Nov 13:39] Darren Coleman
Jonathan D - you can build the DMG from source downloaded from Oracle yourself if you like, Bob gave instructions further up in the comment thread.
[11 Nov 13:22] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=88445 marked as duplicate of this one.
[12 Nov 23:53] Nabeel Sarip
Thanks Bob!
[13 Nov 2:28] uihwan hwang
Thanks Bob!
[13 Nov 9:27] Andrei Popa
Thank you Bob.  

I can also confirm that the last build (mysql-workbench-High_Sierra-6.3.9-osx-x86_64) works.  

15 inch macbook early 2011 .
[13 Nov 16:36] Carl Fitzsimmons
Bob - thank you - I have been looking for a solution for a while. For me the latest version of Mysql Workbench failed to display table vales. I have several computers all OS X High Sierra and desktop or laptop I use to look into MySQL. This worked - Thank You
[14 Nov 4:13] Jeff Chan
Just upgraded to High Sierra and spent half an hour to figure out what happened to my mySql server...

Luckily google bought me here. Thanks, HERO BOB!
[14 Nov 10:27] Maxime HAMM
Thank you Bob !
[14 Nov 21:53] Juan Miguel Durán
2 months waiting for a patch?
[14 Nov 22:56] Joe Polcari
Bob - your version works AOK. Thanks!
[15 Nov 16:36] Robert Rapplean
Kudos, Bob. Another confirmed install, works just fine.
[15 Nov 18:25] Rogelio Trejo Garcia
Bob! thank you for your dmg file, works for me
Thank you!!
[16 Nov 9:42] Harry Layman
Thanks much Bob!!! 6.3.9 standard version still not working 11/16/2017, Big help!!
[16 Nov 9:42] Harry Layman
Thanks much Bob!!! 6.3.9 standard version still not working 11/16/2017, Big help!!
[16 Nov 11:51] Juan Miguel Durán
I saw they published the release notes, but they forgot to publish the download.
https://dev.mysql.com/doc/relnotes/workbench/en/wb-news-6-3-10.html
[16 Nov 22:54] Romain Riche
6.3.10 is now out FINALLY! Working as expected on High Sierra.
[17 Nov 6:58] Jon Jones
6.3.10 works great, thanks for fixing.