Bug #88308 No Results Grid in 10.13 High Sierra
Submitted: 31 Oct 2017 19:04 Modified: 31 Oct 2017 20:15
Reporter: john fetter Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:6.3.9 OS:Mac OS X (10.13)
Assigned to: CPU Architecture:Any
Tags: osx, workbench

[31 Oct 2017 19:04] john fetter
Description:
In Mac OS X High Sierra (10.13) when a query is executed, the results grid does not show up. this is not a function of window size, query type, or the server its being run against.

I am resubmitting this because all previous submissions have been marked as duplicates of each other leaving NONE as open and because this it is a critical issue that prevents MySQL from being usable.

Here is a list of the duplicates all of which refer back to each other:

87230 directs to 86649 which directs to 87167 and 87230, both of which are marked as duplicates and refer to 86649 again. There are numerous other examples of this, but when searching for open bugs for OSX none are active, open, under development, in QA, analyzing, verified, in progress, or patch pending for this issue

How to repeat:
Open a connection to any MySQL server, of any version, execute select statement... once its complete there is no results grid.

Suggested fix:
Bob Davenport suggested a fix in 87714 which was marked as closed, but this work around does not work in all environments and because it is unofficial cannot be deployed in some areas.
[31 Oct 2017 20:15] Miguel Solorzano
Thank you for the bug report. Duplicate of https://bugs.mysql.com/bug.php?id=87714.
[2 Nov 2017 23:54] Bob Davenport
If anyone is interested
my workaround (until Mysql release fixes the issue)...

I downloaded oracle's source code , found the issue and recompiled & created a distribution dmg

https://drive.google.com/drive/folders/0B2fTesDcrHzVRGVFWEdILWpuaEE

this has worked for some people as per the original bug I logged on 5 sept
https://bugs.mysql.com/bug.php?id=87714