Bug #87862 MySQL does not work on MacOS High Sierra
Submitted: 26 Sep 2017 7:27 Modified: 21 Nov 2017 15:00
Reporter: austin woz Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:6.3.9 OS:Mac OS X
Assigned to: CPU Architecture:Any

[26 Sep 2017 7:27] austin woz
Description:
Since upgrading to High Sierra released today to the public I am no longer able to use Workbench, bummer. 
It opens and I can connect but when I run query I get no results. 

Also if I open the adminstrator part and view open connections I get message about permissions, yet I have all the permissions needed and can get the results with show processes. 

How to repeat:
execute a query
[26 Sep 2017 19:36] Godofredo Miguel Solorzano
no results

Attachment: high-sierra.png (image/png, text), 1.45 MiB.

[26 Sep 2017 19:38] Godofredo Miguel Solorzano
Thank you for the bug report.
[26 Sep 2017 20:01] Godofredo Miguel Solorzano
https://bugs.mysql.com/bug.php?id=86649 marked as duplicate of this one.
[27 Sep 2017 0:02] Tim Bradshaw
+1 for this, same issue, no results show in the results grid even though results were returned.
[27 Sep 2017 6:09] Jon Jones
Same issue and it continuously loops causing me to force quit the application
[27 Sep 2017 6:22] Jimmy Yang
same bug for this, no results grid
[27 Sep 2017 7:18] Muhammad Usman
I am facing same issue on Mac OS High Sierra. Please fix this bug ASAP.
[27 Sep 2017 7:57] Alan Murphy
+1. Poor form. This was first reported in June.
[27 Sep 2017 8:35] Kevin Mayfield
Same fault.
[27 Sep 2017 9:16] Mario Caldareri
Same here. Please fix it ASAP, as I can't work without Workbench..
[27 Sep 2017 9:20] Mario Caldareri
I can't even close the application, I have to force it to close
[27 Sep 2017 12:38] Simon Baines
Seems to connect ok but as noted above no Results Window / seems to hang and have to close App. Bit of an issue if you just want to run a query and export the results as .csv.
[27 Sep 2017 14:19] Craig Boal
For now I have switched over to DBeaver. It at least allows me to be able to execute queries and scripts without having to exclusively rely on running them in a terminal window.
[27 Sep 2017 15:19] Peter Finch
I believe defect #87714 is a duplicate containing a proposed code fix.
[27 Sep 2017 15:42] Tom Donovan
I'm also affected here with no results window displaying after a query successfully executes... also on the public release of 10.13 High Sierra... 

Shot in the dark here, but how long does an S1 "Critical" severity typically take to get fixed by MySQL? Anyone know?
[27 Sep 2017 15:43] David Garratt
I can't even get past the initial screen to make a connection.
[28 Sep 2017 1:34] youmoo Lee
Any progress on this ?
[28 Sep 2017 1:45] Joshua Pepperman
+1. Can execute one singe query which succeeds and tells me how many rows were returned, but doesn't show them. Then trying another query just spins, and the application must be forcibly closed.
[28 Sep 2017 9:05] Daniel Romero
I have downgraded to version 6.1.7 and it works correctly.

While fix the bug, I can work....
[28 Sep 2017 9:28] Godofredo Miguel Solorzano
https://bugs.mysql.com/bug.php?id=87891 marked as duplicate of this one.
[28 Sep 2017 14:58] Michael Sayer
+1 - Runs the query. No results. Downgraded to 6.1.7. and still seeing the same issues. Help us Oracle. You're our only hope.
[28 Sep 2017 15:22] Craig Boal
Downgrading to 6.1.7 worked for me, I tried the next stable release version 6.2.3 but that didn't work, so from my experimentation 6.1.7 is the most recent version that works.
[28 Sep 2017 16:53] Michael Sayer
I tried uninstalling and reinstalling 6.1.7 and now it works. Thanks everyone
[28 Sep 2017 18:58] austin woz
if your looking for a workable solution i found "Navicat" to be a reasonable product.  I still prefer workbench when it works, but do really like Navicat's awesome query builder GUI. If only workbench had this feature and worked of course.
[28 Sep 2017 19:27] Greg French
I just installed Oracle SQL Developer, and the MySQL JDBC connector. Connected to my databases, looks like it will work:

http://www.oracle.com/technetwork/developer-tools/sql-developer/overview/index.html

https://www.mysql.com/products/connector/

Instructions:

http://www.oracle.com/technetwork/developer-tools/sql-developer/mysql-connection-viewlet-s...
[28 Sep 2017 20:03] austin woz
This bug is most likely a repeat of the same issue when MacOS sierra was released, the issue details here. Don't hold your breath, see how long this one took to be fixed. It looks like workbench is no longer in active development. 

https://bugs.mysql.com/bug.php?id=83658
[28 Sep 2017 20:29] Tom Donovan
Well, the @MySQLWorkbench Twitter account was kind enough to get back to my plea for help yesterday... but the answer didn't show much urgency which wasn't quite very reassuring - "I'm afraid this will take a few weeks to fix. But we are aware of the problem..."

https://twitter.com/MySQLWorkbench/status/913081672517718016 

Sooooo... don't hold your breath...
[28 Sep 2017 22:28] Godofredo Miguel Solorzano
https://bugs.mysql.com/bug.php?id=87905 marked as duplicate of this one.
[29 Sep 2017 0:13] Michael Brogley
Installed 6.1.7 and it's working (displaying results pane, with actual results) correctly.
[30 Sep 2017 0:25] Godofredo Miguel Solorzano
https://bugs.mysql.com/bug.php?id=87924 marked as duplicate of this one.
[1 Oct 2017 15:54] Godofredo Miguel Solorzano
https://bugs.mysql.com/bug.php?id=87931 marked as duplicate of this one.
[2 Oct 2017 18:30] charles palmer
Really unfortunate - bug appeared LIVE in class during my lecture/demo.  80 students.
[2 Oct 2017 20:56] austin woz
80 students, gets them all to subscribe to this bug. Unfortunately workbench is not important to Oracle and doesn't get much development time unless it looks important so those subscribes help
[4 Oct 2017 5:42] Jerry Tan
Yes it affects me! I use workbench for work. Pls prioritize this. Thanks so much! :)
[5 Oct 2017 6:28] Mike Lischke
Duplicate of Bug #87714
[5 Oct 2017 20:06] emil nik
yes, it affects me! Pls fix!
[6 Oct 2017 7:10] Akira Sekiguchi
I've downgraded to ver6.0.9 and it seems working.
[8 Oct 2017 1:22] Aisling nic Lynne
Affected by this bug on 10.13 (17A405). Connects to DB successfully over SSH, queries appear to run, however, no results appear even though a response is acknowledged and the query is marked complete. After attempting any additional query, app gives bottom status bar as "Query Completed", but Action Output does not show the second query completed, the query tab shows the "working" spinning gear, and the app can only be force-quit as attempting to quit gives error "Cannot close SQL IDE while being busy"
[8 Oct 2017 8:01] Bilal Issa
+1
[8 Oct 2017 8:02] Bilal Issa
+1
[9 Oct 2017 2:13] mike coutinho
Bob Davenport complied a version of workbench that works.  Check out this bug report...  

https://bugs.mysql.com/bug.php?id=87714
[10 Oct 2017 3:45] Sean Pratt
I had the same issue with the official release of High Sierra 10.13 (17A405). Query would appear to run, but the tables never showed up.

I downgraded to 6.1.7 and it seems to work fine with High Sierra.

Will be very pleased when the official MySQL newest version works properly with High Sierra.
[10 Oct 2017 6:29] J van Hooren
+1
[10 Oct 2017 17:09] Camilo Soler
+1
[10 Oct 2017 20:36] Rodrigo Sobrero
+1
[11 Oct 2017 1:45] Mohd Hasnol
+1
[12 Oct 2017 11:43] Jerry Arnold
+1
[12 Oct 2017 20:45] Louis Mulder
+1
[13 Oct 2017 13:08] john fetter
+1
[13 Oct 2017 13:09] john fetter
+1
[13 Oct 2017 16:17] Steve Fatula
+1
[15 Oct 2017 6:23] Wim Verhoef
+1
[16 Oct 2017 15:32] Ben Sevier
Exact same problems. This means that MySqlWorkbench is now useless, as I can't see results of queries or do any sort of data edits using the tool.  

Not sure what in the OS update affects things like this, but it would seem to point to poor coding in the application, since I've seen none of my tools have any issues after the update.

Ben Sevier
[17 Oct 2017 1:01] Daniel Henson
Also experiencing this issue. No results when I run an initial query, then the application just loops/locks requiring a force close.
[17 Oct 2017 9:24] Simon Baines
I am not expert here but it seems we have number of Bugs that have been marked as a duplicate of this but this Bug #87862 also has a status of Duplicate... I am not sure is that matters or not but I was trying to track down the Bug # with the Active status to see what the status was and I failed. Perhaps someone more skilled can point me at it.  My worry is all related Bugs are now duplicates and none Active so maybe no one will be looking at this - hopefully I have this all wrong!
[17 Oct 2017 10:15] Mike Lischke
If people would actually read instead of blindly adding +1 to a bug report that is clearly marked as a duplicate, it would be much more obvious what the bug number is it duplicates.

See my comment from Oct 5th. This bug duplicates bug #87714, which is already marked as fixed.
[19 Oct 2017 12:02] Edgar Alabau
+1
[19 Oct 2017 12:55] Chad Windnagle
Bob's fix worked for me. Thanks Bob for the great and easy to implement solution.
[19 Oct 2017 13:11] austin woz
Why is #87714 marked as fixed if the solution is to download a version held on someone’s personal hosting. It should be marked as fixed when 6.3.10 is released to public.
[23 Oct 2017 5:39] Rogelio Trejo Garcia
When the version 6.3.10 will be ready?
I downgraded to 6.1.7 but this version have many errors and crash in many situations.
[7 Nov 2017 9:36] austin woz
patently waiting on 6.3.10 as i still cant use workbench
[7 Nov 2017 9:42] austin woz
hasn't been resolved and released to public. waiting on version 6.3.10
[9 Nov 2017 14:47] Daniel Chamorro
In another post, Bob modified workbench and fixed the issue. Works Flawless for me on Mac HighSiera here is the link: https://bugs.mysql.com/bug.php?id=87714
[10 Nov 2017 14:03] austin woz
I am well aware that Bob kindly made a fix, but I need an official fix downloadable from this website. I have customer data on my servers I cant use tools from someone personal hosting even if bob appears genuinely nice and helpful. Neither can you, the ICO will take a dim view.
[21 Nov 2017 14:37] Richard Willis-Owen
Looks like 6.3.10 was released a few days ago which works with High Sierra. Downloadable from https://dev.mysql.com/downloads/workbench/
[21 Nov 2017 14:50] Michael Owen
The updated mention by Richard Willis-Owen works for me on High Sierra 10.13.1
[21 Nov 2017 15:00] austin woz
thank you to the developer
[21 Nov 2017 15:51] Mike Lischke
Thanks for the confirmation!
[24 Jan 17:59] Greg Beer
I happened across this report after updating to High Sierra 0.13.3 (17D47) and then not seeing query results. I followed the advice and updated to MySQL Workbench 6.3.10 but not it's not recognizing the connection using id_rsa key. Keeps asking for the password.

I can ssh directly into the server as my user with the key in place without a problem.

Any thoughts?
[30 Jan 11:10] Elephi Dong
I will not use MySQL Workbench anymore. It took long time to fix this critical bug.