Bug #55312 System.OutOfMemoryException (big script loading)
Submitted: 16 Jul 2010 8:20 Modified: 18 Jul 2012 7:10
Reporter: Cyrille Giquello Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.25, 5.2.38, 5.2.39, 5.2.40 OS:Microsoft Windows
Assigned to: Mike Lischke CPU Architecture:Any
Tags: exception, OutOfMemory

[16 Jul 2010 8:20] Cyrille Giquello
Description:
Hello,

When opening an big sql file "File / Open SQL Script..." a System.OutOfMemoryException is throwed.
My SQL script is about 120 Mo.

I use to open such big files with MySQL Query Browser without any problem.

Regards
Cyrille.

How to repeat:
Menu "File / Open SQL Script..."
Choose a big sql file (>=120Mo)
[16 Jul 2010 8:35] Cyrille Giquello
Remove product name in "Version" field
[16 Jul 2010 8:59] Susanne Ebrecht
Has the script more then 32000 characters?
[16 Jul 2010 9:13] Cyrille Giquello
The loaded script has more than 32000 characters, it's size is around 120 Mo (123 673 862 bytes).
It's from a mysql dump, and with MySQL Query Browser I used to open them. With MySQL Workbench I've to change my habits...
[16 Jul 2010 12:59] Valeriy Kravchuk
Please, send the results from Help > System Info menu item.
[16 Jul 2010 16:06] Cyrille Giquello
MySQL Workbench CE for Windows version 5.2.25
Data Directory: C:\Program Files\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.
OpenGL Driver Version: 2.1.1
OS: Microsoft Windows XP Professional Service Pack 3 (build 2600)
CPU: 2x Intel(R) Core(TM)2 Duo CPU     T7500  @ 2.20GHz, 3.5 GiB RAM
Video adapter info:
Adapter type: NVIDIA Quadro NVS 140M
Chip Type: Quadro NVS 140M
BIOS String: Version 60.86.47.00.01
Video Memory: 524288 KB
[16 Jul 2010 16:48] MySQL Verification Team
Thank you for the bug report. Verified on Vista Home Premium 4GB 64-bit box.
[28 Jul 2010 12:50] MySQL Verification Team
Bug: http://bugs.mysql.com/bug.php?id=55438 marked as dupliocate of this one.
[30 Aug 2010 20:40] Alfredo Kojima
Marked bug #56167 as duplicate
[2 Sep 2010 14:36] Alfredo Kojima
bug #56388 is a duplicate
[28 Oct 2010 14:39] Alfredo Kojima
added bug #57674 as duplicate
[13 Nov 2010 1:43] Alfredo Kojima
Marked bug #58044 as duplicate
[15 Mar 2011 17:15] Johannes Taxacher
marked Bug #57939 as duplicate of this one
[15 Mar 2011 17:17] Johannes Taxacher
Bug #60363 was marked as duplicate of this one
[7 Apr 2011 17:13] Alfredo Kojima
marked bug #60780 as a duplicate of this one
[6 May 2011 7:40] Mike Lischke
The MySQL Workbench SQL Editor is by design not able to load such big scripts. The upper limit is around 100MB, depending on available RAM. A new tool will soon be available to allow executing large scripts (without source
code support, like syntax highlighting, or edit abilities).
[23 May 2011 14:37] MySQL Verification Team
http://bugs.mysql.com/bug.php?id=61262 marked as duplicate of this bug.
[20 Jun 2011 9:36] Alfredo Kojima
bug #61531 is a duplicate
[2 Mar 2012 8:14] Valeriy Kravchuk
Sorry, but based on numerous duplicates in all versions up to recent 5.2.38 and fact that even 50M of .sql can NOT be processed on system with 8G of RAM, I doubt we can accept "Won't fix" here.
[2 Mar 2012 8:22] Valeriy Kravchuk
Bug #64497 and Bug #64515 were marked as duplicates of this one.
[2 Mar 2012 8:27] Valeriy Kravchuk
Bug #64271 was marked as a duplicate of this one.
[7 Mar 2012 18:52] Valeriy Kravchuk
Bug #64572 was marked as a duplicate of this one.
[13 Mar 2012 21:48] MySQL Verification Team
http://bugs.mysql.com/bug.php?id=64638 marked as duplicate of this one.
[18 Mar 2012 8:42] Valeriy Kravchuk
Bug #64679 was marked as a duplicate of this one.
[19 Mar 2012 16:02] Valeriy Kravchuk
Bug #64694 was marked as a duplicate of this one.
[25 Mar 2012 17:43] Valeriy Kravchuk
Bug #64757 was marked as a duplicate of this one.
[2 Apr 2012 15:54] Valeriy Kravchuk
Bug #64844 was marked as a duplicate of this one.
[10 Apr 2012 16:06] Valeriy Kravchuk
Bug #64930 was marked as a duplicate of this one.
[12 Apr 2012 3:58] Valeriy Kravchuk
Bug #64950 was marked as a duplicate of this one.
[13 Apr 2012 6:16] Valeriy Kravchuk
Bug #64962 was marked as a duplicate of this one.
[19 Apr 2012 15:57] Valeriy Kravchuk
Bug #65039 was marked as a duplicate of this one.
[2 May 2012 19:04] Rafael Antonio Bedoy Torres
65170 was marked as duplicated of this one
[8 May 2012 16:01] Rafael Antonio Bedoy Torres
Bug #65240 was marked as a duplicate of this one.
[12 May 2012 9:52] Valeriy Kravchuk
Bug #65293 was marked as a duplicate of this one.
[18 May 2012 15:15] Valeriy Kravchuk
Bug #65363 was marked as a duplicate of this one.
[18 May 2012 16:47] MySQL Verification Team
http://bugs.mysql.com/bug.php?id=65260 marked as duplicate of this one.
[18 May 2012 19:06] Rafael Antonio Bedoy Torres
Bug #65366 was marked as duplicated of this one
[21 May 2012 7:10] Valeriy Kravchuk
Bug #65377 was marked as a duplicate of this one.
[22 May 2012 16:05] MySQL Verification Team
http://bugs.mysql.com/bug.php?id=65395 marked as duplicate of this one.
[25 May 2012 0:54] MySQL Verification Team
http://bugs.mysql.com/bug.php?id=65417 marked as duplicate of this one.
[26 May 2012 5:26] Valeriy Kravchuk
Bug #65424 was marked as a duplicate of this one.
[30 May 2012 14:54] MySQL Verification Team
http://bugs.mysql.com/bug.php?id=65464 marked as duplicate of this one.
[1 Jun 2012 17:42] Valeriy Kravchuk
Bug #65474 was marked as a duplicate of this one.
[14 Jun 2012 5:44] Valeriy Kravchuk
Bug #65610 was marked as a duplicate of this one.
[16 Jul 2012 23:10] MySQL Verification Team
http://bugs.mysql.com/bug.php?id=65915 marked as duplicate of this one.
[18 Jul 2012 7:10] Philip Olson
Loading large files (over 100MB) using "File", "Open SQL
Script..." would fail to load the script, and throw an out of memory
exception while halting operation. 

Now, MySQL Workbench warns users if a file exceeding 100MB is attempted to be
loaded, and no longer crashes when running out of memory but instead
reports that the file was unable to be loaded.
[12 Dec 2013 13:11] MySQL Verification Team
http://bugs.mysql.com/bug.php?id=71133 duplicate of this one.