Bug #58044 The failure occured when trying to open a large script file (about 75 MB in size
Submitted: 8 Nov 2010 11:24 Modified: 13 Nov 2010 1:42
Reporter: Guy Meredith Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S2 (Serious)
Version:5.2.29 OS:Microsoft Windows (V 7.0)
Assigned to: CPU Architecture:Any

[8 Nov 2010 11:24] Guy Meredith
Description:
On attempting to open a large SQL script file of 75 MB in size, the Workbench just kept on giving 'exception of type "system.outofmemoryexception"'. The PC I am running on has 4 GB of memory so don't know why a 75MB file is causing it to crash.

How to repeat:
Open SQL Workbench, and try and open a SQL script file of 75 MB or larger.
[8 Nov 2010 12:54] MySQL Verification Team
Could you please provide the output of Help->System Info?. Thanks in advance.
[8 Nov 2010 14:43] Guy Meredith
Further info. The first error that is thrown is one which states "external component has thrown an exception". Then, after a long wait the memory exception is thrown. This message is then thrown repeatedly and one has to eventually use the task manager to kill the application.

System info is as follows:

MySQL Workbench CE for Windows version 5.2.29

Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE

Cairo Version: 1.8.8

Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.

OpenGL Driver Version: 3.1 NVIDIA 187.83

OS: Microsoft Windows 7 Home Premium Edition (build 7600), 64-bit

CPU: 4x Intel(R) Core(TM) i3 CPU       M 330  @ 2.13GHz, 3.9 GiB RAM

Video adapter info:

Adapter type: 

Chip Type: GeForce 310M

BIOS String: Version 70.18.30.0.e

Video Memory: 524288 KB

Current user language: English (South Africa)
[13 Nov 2010 1:42] Alfredo Kojima
This is a duplicate of bug #55312