Bug #64757 Open large SQL-file from USB in MySQL Workbench - out of memory
Submitted: 25 Mar 2012 13:25 Modified: 25 Mar 2012 17:41
Reporter: Jesper Löfberg Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.32 CE OS:Microsoft Windows (W7 pro)
Assigned to: CPU Architecture:Any

[25 Mar 2012 13:25] Jesper Löfberg
Description:
Tried to open a backup-file (created from MySQL Workbench on another computer) with size 74 125 MB from an USB-memory. I moved the file to internal hard disk but I got the same result, 'System.OutOfMemoryException'.

The file was creatd with this command on server version 5.5.21:
mysqldump --user root --password=secret_secret sf_skywin > filename

How to repeat:
1. mysqldump --user root --password=secret_secret sf_skywin > filename
2. Open the file, which must me large, in WorkBench using File, Open, Script
[25 Mar 2012 16:12] Valeriy Kravchuk
Please, send the output of Help > System Info menu item and exact file size. 

This can be a duplicate of bug #55312 actually.
[25 Mar 2012 16:36] Jesper Löfberg
Output from System info:

MySQL Workbench CE for Windows version 5.2.32

Configuration Directory: C:\Users\Jesper\AppData\Roaming\MySQL\Workbench

Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE

Cairo Version: 1.8.8

Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.

OpenGL Driver Version: 3.1.0

OS: Microsoft Windows 7  Service Pack 1 (build 7601), 64-bit

CPU: 8x Intel(R) Core(TM) i7 CPU         860  @ 2.80GHz, 6.0 GiB RAM

Active video adapter: NVIDIA Quadro FX 580

Installed video RAM: 512 MB

Current video mode: 1920 x 1200 x 4294967296 colors

Used bit depth: 32

Driver version: 8.15.11.9038

Installed display drivers: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um

Current user language: Swedish (Sweden)

Exact file size: 72,3 MB (75 903 881 bytes)
[25 Mar 2012 17:41] Valeriy Kravchuk
So, you have more than enough RAM. Then this is a duplicate of bug #55312.