Bug #66130 server host require
Submitted: 31 Jul 2012 20:39 Modified: 20 Sep 2012 20:04
Reporter: javier Alejandro Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.41, 5.2.42 OS:Microsoft Windows (Microsoft Windows Vista Starter Edition Service Pack 2 (build 6002), 32-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter
Triage: Needs Triage: D1 (Critical)

[31 Jul 2012 20:39] javier Alejandro
Description:
I need server host to run the programm in my PC thanks

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9727
Configuration Directory: C:\Users\Javier\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows Vista Starter Edition Service Pack 2 (build 6002), 32-bit
CPU: 2x Intel(R) Pentium(R) Dual  CPU  T3200  @ 2.00GHz, 1.7 GiB RAM
Active video adapter (0): VIA Chrome9 HC IGP Family WDDM  
Installed video RAM: 256 MB
Current video mode: 1280 x 800 x 4294967296 colores
Used bit depth: 32
Driver version: 7.14.14.0043-21.05.01h
Installed display drivers: VTGUModeDX32.dll
Current user language: EspaƱol (Argentina)

Exception = System.InvalidOperationException
Message = No se puede llamar a Invoke o a BeginInvoke en un control hasta que se haya creado el identificador de ventana.
FullText = System.InvalidOperationException: No se puede llamar a Invoke o a BeginInvoke en un control hasta que se haya creado el identificador de ventana.
   en System.Windows.Forms.Control.MarshaledInvoke(Control caller, Delegate method, Object[] args, Boolean synchronous)
   en System.Windows.Forms.Control.Invoke(Delegate method, Object[] args)
   en MySQL.GUI.Workbench.Program.SingleInstanceCallback(Object sender, InstanceCallbackEventArgs args)
   en MySQL.Workbench.ApplicationInstanceManager.WaitOrTimerCallback(Object state, Boolean timedOut)
   en System.Threading._ThreadPoolWaitOrTimerCallback.WaitOrTimerCallback_Context(Object state, Boolean timedOut)
   en System.Threading._ThreadPoolWaitOrTimerCallback.WaitOrTimerCallback_Context_f(Object state)
   en System.Threading.ExecutionContext.runTryCode(Object userData)
   en System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
   en System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
   en System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)
   en System.Threading._ThreadPoolWaitOrTimerCallback.PerformWaitOrTimerCallback(Object state, Boolean timedOut)

How to repeat:
I need server host to run the programm in my PC thanks
[31 Jul 2012 22:57] Miguel Solorzano
Could you please provide step by step instructions how to repeat the issue. Thanks.
[22 Aug 2012 15:57] Alfredo Kojima
Marking as Verified from code analysis and large number of duplicates.
[22 Aug 2012 16:10] Alfredo Kojima
Following bugs marked duplicate of this one:
Bug #66164
Bug #66177	
Bug #66433
Bug #66466
Bug #66212
Bug #66456
Bug #66290
Bug #66424	
Bug #66447
Bug #66406
Bug #66425
[27 Aug 2012 8:09] Valeriy Kravchuk
Bug #66544 was marked as a duplicate of this one.
[30 Aug 2012 13:00] Valeriy Kravchuk
Bug #66612 was marked as a duplicate of this one.
[31 Aug 2012 10:19] Valeriy Kravchuk
Bug #66629 was marked as a duplicate of this one.
[20 Sep 2012 20:04] Philip Olson
Fixed as of the upcoming MySQL Workbench 5.2.44, and here's the changelog entry:

 MySQL Workbench would sometimes crash at startup due to a race
 condition. The logged error included "Invoke or
 BeginInvoke cannot be called on a control until the window
 handle has been created."

Thank you for the bug report.