Bug #66290 error launching workbench
Submitted: 9 Aug 2012 20:54 Modified: 22 Aug 2012 16:00
Reporter: Harold Ward Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows 7 Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[9 Aug 2012 20:54] Harold Ward
Description:
"MySQL Workbench has encountered a problem"  "Invoke or BeginInvoke cannot be called on a control until the window handle has been create"

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9724
Configuration Directory: C:\Users\hward\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench CE 5.2.41
Cairo Version: 1.8.8
OS: Microsoft Windows 7  Service Pack 1 (build 7601), 64-bit
CPU: 4x Intel(R) Core(TM) i5-2450M CPU @ 2.50GHz, 5.9 GiB RAM
Active video adapter (0): Intel(R) HD Graphics Family
Installed video RAM: -1259 MB
Current video mode: 1366 x 768 x 4294967296 colors
Used bit depth: 32
Driver version: 8.15.10.2266
Installed display drivers: igdumd64.dll,igd10umd64.dll,igd10umd64.dll,igdumdx32,igd10umd32,igd10umd32
Current user language: English (United States)

Exception = System.InvalidOperationException
Message = Invoke or BeginInvoke cannot be called on a control until the window handle has been created.
FullText = System.InvalidOperationException: Invoke or BeginInvoke cannot be called on a control until the window handle has been created.
   at System.Windows.Forms.Control.MarshaledInvoke(Control caller, Delegate method, Object[] args, Boolean synchronous)
   at System.Windows.Forms.Control.Invoke(Delegate method, Object[] args)
   at MySQL.GUI.Workbench.Program.SingleInstanceCallback(Object sender, InstanceCallbackEventArgs args)
   at MySQL.Workbench.ApplicationInstanceManager.WaitOrTimerCallback(Object state, Boolean timedOut)
   at System.Threading._ThreadPoolWaitOrTimerCallback.WaitOrTimerCallback_Context(Object state, Boolean timedOut)
   at System.Threading._ThreadPoolWaitOrTimerCallback.WaitOrTimerCallback_Context_f(Object state)
   at System.Threading.ExecutionContext.runTryCode(Object userData)
   at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)
   at System.Threading._ThreadPoolWaitOrTimerCallback.PerformWaitOrTimerCallback(Object state, Boolean timedOut)

How to repeat:
Don't know.
[10 Aug 2012 1:03] Alfredo Kojima
What were you doing when the bug appeared? Can it be repeated? What steps do we need to take for it to happen again for us?
[22 Aug 2012 16:00] Alfredo Kojima
Duplicate of bug #66130