Bug #66466 Dialog appeared, telling me that an error happened. But I did noticed anything
Submitted: 20 Aug 2012 14:59 Modified: 22 Aug 2012 16:00
Reporter: Giuseppe Piscopo Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.42 OS:Microsoft Windows (Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[20 Aug 2012 14:59] Giuseppe Piscopo
Description:
Dialog appeared, telling me that an error happened. But I did noticed anything.
This was the first time I started MySQL Workbench on this machine. I think error dialog appeared as soon as I double clicked on the one and only local connection found, in the leftmost panel on welcome page.

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.42  revision 9752
Configuration Directory: C:\Users\jos\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit
CPU: 2x Intel(R) Core(TM)2 Duo CPU     P8600  @ 2.40GHz, 4.0 GiB RAM
Active video adapter (0): ATI Mobility Radeon HD 4600 Series  
Installed video RAM: 1024 MB
Current video mode: 1440 x 900 x 4294967296 colori
Used bit depth: 32
Driver version: 8.634.1.0
Installed display drivers: atiumd64.dll,atidxx64.dll,atiumdag,atidxx32,atiumdva,atiumd6a.cap,atitmm64.dll
Current user language: Italiano (Italia)

Exception = System.InvalidOperationException
Message = Impossibile chiamare Invoke o BeginInvoke su un controllo finché non viene creato un handle di finestra.
FullText = System.InvalidOperationException: Impossibile chiamare Invoke o BeginInvoke su un controllo finché non viene creato un handle di finestra.
   in System.Windows.Forms.Control.MarshaledInvoke(Control caller, Delegate method, Object[] args, Boolean synchronous)
   in System.Windows.Forms.Control.Invoke(Delegate method, Object[] args)
   in MySQL.GUI.Workbench.Program.SingleInstanceCallback(Object sender, InstanceCallbackEventArgs args)
   in MySQL.Workbench.ApplicationInstanceManager.WaitOrTimerCallback(Object state, Boolean timedOut)
   in System.Threading._ThreadPoolWaitOrTimerCallback.WaitOrTimerCallback_Context(Object state, Boolean timedOut)
   in System.Threading._ThreadPoolWaitOrTimerCallback.WaitOrTimerCallback_Context_f(Object state)
   in System.Threading.ExecutionContext.runTryCode(Object userData)
   in System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
   in System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
   in System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)
   in System.Threading._ThreadPoolWaitOrTimerCallback.PerformWaitOrTimerCallback(Object state, Boolean timedOut)

How to repeat:
Not sure. Please read description
[20 Aug 2012 15:02] Miguel Solorzano
Thank you for the bug report. That's repeatable or just happened once?. Thanks.
[20 Aug 2012 19:34] Giuseppe Piscopo
I haven't the slightest idea, I'm sorry. That's because I did not even realized that an error dialog showed up (I guess because it was not modal).
I started the workbench for the first time after install.
Then I double clicked on the already existing connection to local instance.
Once connected, I just browsed through the some (default?) "Test" database and its empty "subfolders".
Then I realized from windows taskbar that Workbench had another windows open, and that was an error dialog.
So it happened somewhere in between.

I choose to report the error, then I was brought back to the error dialog.
As soon as I clicked on close button, the entire workbench crashed and the Windows 7 crash dialog appeared (the one asking to restart the app, and 2 more choices).
[22 Aug 2012 16:00] Alfredo Kojima
Duplicate of bug #66130