Bug #66177 Not Responding
Submitted: 3 Aug 2012 7:21 Modified: 22 Aug 2012 15:59
Reporter: ching nette Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows 7 (build 7600), 32-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[3 Aug 2012 7:21] ching nette
Description:
Got crashed  when trying to connect OVER SSH

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9727
Configuration Directory: C:\Users\michael-estanislao\AppData\Roaming\MySQL\Workbench
Data Directory: D:\Development Tools\mysql_workbench
Cairo Version: 1.8.8
OS: Microsoft Windows 7  (build 7600), 32-bit
CPU: 2x AMD Turion(tm) X2 Ultra Dual-Core Mobile ZM-84, 1.8 GiB RAM
Active video adapter (0): ATI Radeon HD 3200 Graphics 
Installed video RAM: 256 MB
Current video mode: 1366 x 768 x 4294967296 colors
Used bit depth: 32
Driver version: 8.632.1.2000
Installed display drivers: atiumdag.dll,atidxx32.dll,atidxx64,atiumdva.cap,atiumd64,atiumd6a,atitmm64
Current user language: English (United States)

Exception = System.InvalidOperationException
Message = Invoke or BeginInvoke cannot be called on a control until the window handle has been created.
FullText = System.InvalidOperationException: Invoke or BeginInvoke cannot be called on a control until the window handle has been created.
   at System.Windows.Forms.Control.MarshaledInvoke(Control caller, Delegate method, Object[] args, Boolean synchronous)
   at System.Windows.Forms.Control.Invoke(Delegate method, Object[] args)
   at MySQL.GUI.Workbench.Program.SingleInstanceCallback(Object sender, InstanceCallbackEventArgs args)
   at MySQL.Workbench.ApplicationInstanceManager.WaitOrTimerCallback(Object state, Boolean timedOut)
   at System.Threading._ThreadPoolWaitOrTimerCallback.WaitOrTimerCallback_Context(Object state, Boolean timedOut)
   at System.Threading._ThreadPoolWaitOrTimerCallback.WaitOrTimerCallback_Context_f(Object state)
   at System.Threading.ExecutionContext.runTryCode(Object userData)
   at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)
   at System.Threading._ThreadPoolWaitOrTimerCallback.PerformWaitOrTimerCallback(Object state, Boolean timedOut)

How to repeat:
Got crashed  when trying to connect OVER SSH
[17 Aug 2012 15:20] Armando Lopez Valencia
Hello Cheng.
Can you please try with the latest WB 5.2.42 and let us know the outcome?
I'll suggest to uninstall WB 5.2.41 and backup/delete the "C:\Users\[YOUR_USER]\AppData\Roaming\MySQL\Workbench" folder before install WB 5.2.42.
Please be aware that all your connections and setting will be lost.
You can download the latest WB from here: http://dev.mysql.com/downloads/workbench/5.2.html
[22 Aug 2012 15:59] Alfredo Kojima
Duplicate of bug #66130