Bug #66164 first start, come bug reporter
Submitted: 2 Aug 2012 15:37 Modified: 22 Aug 2012 15:59
Reporter: Erdem Senol Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows XP Professional Service Pack 3 (build 2600))
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[2 Aug 2012 15:37] Erdem Senol
Description:
when click start, open the window: ''MySQL Workbench Unexpected Error'', says: ''MySQL WB has encountered a problem; and:while configuring monitor can't call Invoke or Begininvoke

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9727
Configuration Directory: C:\Documents and Settings\user\Application Data\MySQL\Workbench
Data Directory: C:\Program Files\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows XP Professional Service Pack 3 (build 2600)
CPU: 2x Genuine Intel(R) CPU           T2300  @ 1.66GHz, 503 MiB RAM
Active video adapter (0): Mobile Intel(R) 945 Express Chipset Family
Installed video RAM: 128 MB
Current video mode: 1280 x 800 x 4294967296 renkler
Used bit depth: 32
Driver version: 6.14.10.4906
Installed display drivers: igxprd32.dll
Current user language: Türkçe

Exception = System.InvalidOperationException
Message = Pencere işleyicisi oluşturuluncaya kadar denetim üzerinde Invoke veya BeginInvoke çağrılamaz.
FullText = System.InvalidOperationException: Pencere işleyicisi oluşturuluncaya kadar denetim üzerinde Invoke veya BeginInvoke çağrılamaz.
   konum: System.Windows.Forms.Control.MarshaledInvoke(Control caller, Delegate method, Object[] args, Boolean synchronous)
   konum: System.Windows.Forms.Control.Invoke(Delegate method, Object[] args)
   konum: MySQL.GUI.Workbench.Program.SingleInstanceCallback(Object sender, InstanceCallbackEventArgs args)
   konum: MySQL.Workbench.ApplicationInstanceManager.WaitOrTimerCallback(Object state, Boolean timedOut)
   konum: System.Threading._ThreadPoolWaitOrTimerCallback.WaitOrTimerCallback_Context(Object state, Boolean timedOut)
   konum: System.Threading._ThreadPoolWaitOrTimerCallback.WaitOrTimerCallback_Context_f(Object state)
   konum: System.Threading.ExecutionContext.runTryCode(Object userData)
   konum: System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
   konum: System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
   konum: System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)
   konum: System.Threading._ThreadPoolWaitOrTimerCallback.PerformWaitOrTimerCallback(Object state, Boolean timedOut)

How to repeat:
after bug report, open the monitor
[2 Aug 2012 22:19] Rafael Antonio Bedoy Torres
Can you please specify step by step how you get you problem?

please check the prerequisites on http://dev.mysql.com/resources/wb52_prerequisites.html

Thanks in advance!
[22 Aug 2012 15:59] Alfredo Kojima
Duplicate of bug #66130