Bug #66406 endless run on an sql file
Submitted: 15 Aug 2012 19:06 Modified: 22 Aug 2012 16:08
Reporter: Sarah Lin Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S1 (Critical)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows Vista Business Edition Service Pack 2 (build 6002), 32-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[15 Aug 2012 19:06] Sarah Lin
Description:
source a .sql file and left the database run for an hour, MySQL Workench Unexpected Error appears.

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9724
Configuration Directory: C:\Users\admin\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files\MySQL\MySQL Workbench CE 5.2.41
Cairo Version: 1.8.8
OS: Microsoft Windows Vista Business Edition Service Pack 2 (build 6002), 32-bit
CPU: 2x Intel(R) Core(TM)2 CPU          4400  @ 2.00GHz, 2.0 GiB RAM
Active video adapter (0): Intel(R)  946GZ Express Chipset Family
Installed video RAM: 384 MB
Current video mode: 1280 x 768 x 4294967296 colors
Used bit depth: 32
Driver version: NULL
Installed display drivers: igdumd32.dll
Current user language: English (United States)

Exception = System.InvalidOperationException
Message = Invoke or BeginInvoke cannot be called on a control until the window handle has been created.
FullText = System.InvalidOperationException: Invoke or BeginInvoke cannot be called on a control until the window handle has been created.
   at System.Windows.Forms.Control.MarshaledInvoke(Control caller, Delegate method, Object[] args, Boolean synchronous)
   at System.Windows.Forms.Control.Invoke(Delegate method, Object[] args)
   at MySQL.GUI.Workbench.Program.SingleInstanceCallback(Object sender, InstanceCallbackEventArgs args)
   at MySQL.Workbench.ApplicationInstanceManager.WaitOrTimerCallback(Object state, Boolean timedOut)
   at System.Threading._ThreadPoolWaitOrTimerCallback.WaitOrTimerCallback_Context(Object state, Boolean timedOut)
   at System.Threading._ThreadPoolWaitOrTimerCallback.WaitOrTimerCallback_Context_f(Object state)
   at System.Threading.ExecutionContext.runTryCode(Object userData)
   at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)
   at System.Threading._ThreadPoolWaitOrTimerCallback.PerformWaitOrTimerCallback(Object state, Boolean timedOut)

How to repeat:
create a database, use that database, and souce a sql file, leave the screen for an hour.
[15 Aug 2012 20:55] Rafael Antonio Bedoy Torres
Hello Sarah,

Can you please add the details of your database?, in order to reproduce.

Thanks in advance
[18 Aug 2012 0:21] Sarah Lin
I sourced a SQL file for about 167m using MySQL server 5.5.27 command to my newly created bat abase. I watched it run for 5 minutes, and went to lunch.  After I camelback, the screen shows error.
[18 Aug 2012 0:21] Sarah Lin
I sourced a SQL file for about 167m using MySQL server 5.5.27 command to my newly created bat abase. I watched it run for 5 minutes, and went to lunch.  After I camelback, the screen shows error.
[22 Aug 2012 16:08] Alfredo Kojima
Duplicate of bug #66130