Bug #66629 On opening benchmark after installation
Submitted: 31 Aug 2012 6:01 Modified: 31 Aug 2012 9:59
Reporter: Alex Ben Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.42 OS:Microsoft Windows (Microsoft (build 8250), 32-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[31 Aug 2012 6:01] Alex Ben
Description:
see bug report

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.42  revision 9752
Configuration Directory: C:\Users\alex\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files\MySQL\MySQL Workbench CE 5.2.42
Cairo Version: 1.8.8
OS: Microsoft  (build 8250), 32-bit
CPU: 2x Intel(R) Core(TM)2 Duo CPU     E7400  @ 2.80GHz, 2.0 GiB RAM
Active video adapter (1): Intel(R) G33/G31 Express Chipset Family (Microsoft Corporation - WDDM 1.0)
Installed video RAM: 256 MB
Current video mode: 1440 x 900 x 4294967296 colors
Used bit depth: 32
Driver version: 8.15.10.2548
Installed display drivers: igdumd32.dll
Current user language: English (United States)

Exception = System.InvalidOperationException
Message = Invoke or BeginInvoke cannot be called on a control until the window handle has been created.
FullText = System.InvalidOperationException: Invoke or BeginInvoke cannot be called on a control until the window handle has been created.
   at System.Windows.Forms.Control.MarshaledInvoke(Control caller, Delegate method, Object[] args, Boolean synchronous)
   at System.Windows.Forms.Control.Invoke(Delegate method, Object[] args)
   at MySQL.GUI.Workbench.Program.SingleInstanceCallback(Object sender, InstanceCallbackEventArgs args)
   at MySQL.Workbench.ApplicationInstanceManager.WaitOrTimerCallback(Object state, Boolean timedOut)
   at System.Threading._ThreadPoolWaitOrTimerCallback.WaitOrTimerCallback_Context(Object state, Boolean timedOut)
   at System.Threading._ThreadPoolWaitOrTimerCallback.WaitOrTimerCallback_Context_f(Object state)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading._ThreadPoolWaitOrTimerCallback.PerformWaitOrTimerCallback(Object state, Boolean timedOut)

How to repeat:
its first time after installation
[31 Aug 2012 9:59] Valeriy Kravchuk
This is a duplicate of Bug #66130.