Bug #66447 crashed openning model
Submitted: 18 Aug 2012 15:28 Modified: 22 Aug 2012 18:31
Reporter: andrius zilenas Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.42 OS:Microsoft Windows (Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[18 Aug 2012 15:28] andrius zilenas
Description:
error occured first time openning model after model was crated by SQL script but nothing appearerd , saved and closed and tried to reopen

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.42  revision 9752
Configuration Directory: C:\Users\AndriuZ\AppData\Roaming\MySQL\Workbench
Data Directory: G:\PA\PortableApps\MySQL Workbench 5.2.42 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit
CPU: 2x AMD Turion(tm) 64 X2 Mobile Technology TL-60, 3.8 GiB RAM
Active video adapter (0): ATI Radeon X1270   
Installed video RAM: 288 MB
Current video mode: 1920 x 1080 x 4294967296 colors
Used bit depth: 32
Driver version: 8.423.0.0
Installed display drivers: atiumdag,atiumdva,atiumd64.dll,atiumd6a.cap,atitmm64.dll
Current user language: Lithuanian (Lithuania)

Exception = System.InvalidOperationException
Message = Invoke or BeginInvoke cannot be called on a control until the window handle has been created.
FullText = System.InvalidOperationException: Invoke or BeginInvoke cannot be called on a control until the window handle has been created.
   at System.Windows.Forms.Control.MarshaledInvoke(Control caller, Delegate method, Object[] args, Boolean synchronous)
   at System.Windows.Forms.Control.Invoke(Delegate method, Object[] args)
   at MySQL.GUI.Workbench.Program.SingleInstanceCallback(Object sender, InstanceCallbackEventArgs args)
   at MySQL.Workbench.ApplicationInstanceManager.WaitOrTimerCallback(Object state, Boolean timedOut)
   at System.Threading._ThreadPoolWaitOrTimerCallback.WaitOrTimerCallback_Context(Object state, Boolean timedOut)
   at System.Threading._ThreadPoolWaitOrTimerCallback.WaitOrTimerCallback_Context_f(Object state)
   at System.Threading.ExecutionContext.runTryCode(Object userData)
   at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)
   at System.Threading._ThreadPoolWaitOrTimerCallback.PerformWaitOrTimerCallback(Object state, Boolean timedOut)

How to repeat:
error occured first time openning model after model was crated by SQL script but nothing appearerd , saved and closed and tried to reopen
[18 Aug 2012 17:48] Miguel Solorzano
Thank you for the bug report. The crash happens every time or just once?. If the crash is repeatable please provide the project model file (private if you wish). Thanks.
[22 Aug 2012 16:08] Alfredo Kojima
Duplicate of bug #66130
[22 Aug 2012 18:29] andrius zilenas
sorry had not much time to investigate
strange behaviuor
no more crashes on that file, but another problem - with rendering - EER diagram workspace is blue, not showing ER model graphics

but crashe occured while trying openning sample file provided in last version
...\MySQL Workbench 5.0.30 OSS\samples\models
sakila_full.wb50.mwb

I'm using portable version on 64-bit Dell D53
[22 Aug 2012 18:31] andrius zilenas
I'm using portable version on 64-bit Dell D531 so maybe the problem is mashine configuration or drivers?