Bug #66424 Forced Shutdown may have caused this error
Submitted: 16 Aug 2012 21:01 Modified: 22 Aug 2012 16:00
Reporter: Brad Torrey Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.42 OS:Microsoft Windows (Microsoft Windows Server 2008 Standard Edition Service Pack 2 (build 6002), 32-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[16 Aug 2012 21:01] Brad Torrey
Description:
While starting the server and loading MySQL Workbench, this error appeared.

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.42  revision 9752
Configuration Directory: C:\Users\Brad\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files\MySQL\MySQL Workbench CE 5.2.42
Cairo Version: 1.8.8
OS: Microsoft Windows Server 2008 Standard Edition Service Pack 2 (build 6002), 32-bit
CPU: Pentium(R) Dual-Core  CPU      E5200  @ 2.50GHz, 511 MiB RAM
Active video adapter (0): VMware SVGA 3D (Microsoft Corporation - WDDM)
Installed video RAM: 32 MB
Current video mode: 1280 x 800 x 4294967296 colors
Used bit depth: 32
Driver version: 7.14.01.1134 - build-527627
Installed display drivers: vm3dum.dll,vm3dgl.dll
Current user language: English (United States)

Exception = System.InvalidOperationException
Message = Invoke or BeginInvoke cannot be called on a control until the window handle has been created.
FullText = System.InvalidOperationException: Invoke or BeginInvoke cannot be called on a control until the window handle has been created.
   at System.Windows.Forms.Control.MarshaledInvoke(Control caller, Delegate method, Object[] args, Boolean synchronous)
   at System.Windows.Forms.Control.Invoke(Delegate method, Object[] args)
   at MySQL.GUI.Workbench.Program.SingleInstanceCallback(Object sender, InstanceCallbackEventArgs args)
   at MySQL.Workbench.ApplicationInstanceManager.WaitOrTimerCallback(Object state, Boolean timedOut)
   at System.Threading._ThreadPoolWaitOrTimerCallback.WaitOrTimerCallback_Context(Object state, Boolean timedOut)
   at System.Threading._ThreadPoolWaitOrTimerCallback.WaitOrTimerCallback_Context_f(Object state)
   at System.Threading.ExecutionContext.runTryCode(Object userData)
   at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)
   at System.Threading._ThreadPoolWaitOrTimerCallback.PerformWaitOrTimerCallback(Object state, Boolean timedOut)

How to repeat:
This server is running on a VM. The host had been set to install Windows Updates automatically, so when the host restarted, the VM was forceably shut down.
[22 Aug 2012 16:00] Alfredo Kojima
Duplicate of bug #66130