Bug #85079 Subset of grants for only one schema
Submitted: 20 Feb 2017 10:43 Modified: 19 Sep 2018 20:47
Reporter: Luca Zammarchi Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S2 (Serious)
Version:6.3.9, 8.0.11 OS:Mac OS X (OS X 10.11.x El Capitan x86_64)
Assigned to: CPU Architecture:Any
Tags: Administration - Users and Privileges

[20 Feb 2017 10:43] Luca Zammarchi
Description:
Dear All,
in this new MySQL Workbench version there isn't the tab to set specific privileges for a user.

I can only click on "select all" or "unselect all", missing the section with "object rights" "DDL Rights" and "Other Rights".

Thanks
Best Regards
Luca

How to repeat:
Open a MySQL new connection.

Click on menu "Server -> Users and Privileges".

Select an user.

Go to "Schema Privileges"

See there aren't "object rights" "DDL Rights" and "Other Rights" sections.
[20 Feb 2017 15:13] Miguel Solorzano
Thank you for the bug report.
[25 Feb 2017 16:09] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=85182 marked as duplicate of this one.
[10 Mar 2017 17:26] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=85407 marked as duplicate of this one>
[20 Mar 2017 10:09] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=85535 marked as duplicate of this one.
[6 Apr 2017 18:35] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=85840 marked as duplicate of this one.
[7 Apr 2017 22:10] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=85863 marked as duplicate of this one.
[15 Apr 2017 0:09] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=85955 duplicate of this one.
[15 Apr 2017 0:21] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=85956 duplicate of this one.
[26 Apr 2017 21:14] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=86097 marked as duplicate of this one.
[27 Apr 2017 20:17] Garrett Lister
Based on the amount of duplicate reports of this issue, this seems to be a fairly common occurrence. User and privilege administration is a really important aspect of database management, so I would hope this issue is high on the priority list.

Are there any plans to get this issue fixed?
[4 May 2017 5:15] Eric Tiffany
How long does it take before a S2 bug gets fixed?
[9 May 2017 16:07] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=86242 marked as duplicate of this one.
[10 May 2017 5:03] William Pham
Find a solution to this problem. Just ended up changing the size of the text,apps and other items to 100%. This can be located on 'Customize your display'. This is achievable using Windows 10.
[5 Jun 2017 15:39] m pa
This  bug showed its head at the time the major OSX bugs (those which rendered Workbench completely unusable for most of a year) were squashed earlier this year.  I've not had the problem on Ubuntu or Windows 10, only on OSX (Late 2015 MacBook Pro, fully updated.)   

Workbench works fine in a VM running ubuntu on the same machine, though I had to update it to Ubuntu 16 at some point when Workbench stopped supporting 14.04.
[6 Jun 2017 0:26] Eric Tiffany
Actually, this is not a bug.  It's a UX fail.

On the Schema Privileges tab, move your mouse down to near the bottom (under the text "before wildcarded ones.")  Eventually, the mouse cursor will turn into a _^_ arrow; drag that up (farther than you might think) and the lower pane will suddenly appear.

I'd send a screen shot, but I don't see how to do that within this interface.
[7 Jun 2017 17:58] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=86611 marked as duplicate of this one.
[30 Jun 2017 0:03] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=86876 marked as duplicate of this one.
[17 Jul 2017 19:33] Georgios Vlachakis
Confirming the workaround, thank you!

"Actually, this is not a bug.  It's a UX fail.

On the Schema Privileges tab, move your mouse down to near the bottom (under the text "before wildcarded ones.")  Eventually, the mouse cursor will turn into a _^_ arrow; drag that up (farther than you might think) and the lower pane will suddenly appear.

I'd send a screen shot, but I don't see how to do that within this interface."
[20 Jul 2017 2:59] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=87128 marked as duplicate of this one.
[25 Jul 2017 16:50] Garrett Lister
It's been 6 months since this bug was reported and it's still not fixed.
[26 Jul 2017 7:50] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=87193  marked as duplicate of this one.
[5 Aug 2017 14:29] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=87328 marked as duplicate of this one.
[9 Aug 2017 0:31] Miguel Koscianski Vidal
I have the same problem here on Windows 10 Pro x64.

When I move the Workbench from my laptop monitor (resolution 1366 x 768) to another one (resolution 1600 x 900) and then maximize the window, the problem is gone.

Can someone verifiy if it solves the problem on another platforms too?
And also verify if it solves in other Windows machines.

Best regards,
[17 Aug 2017 0:39] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=87447 marked as duplicate of this one.https://bugs.mysql.com/bug.php?id=87447
[17 Aug 2017 19:09] Swaraj Banerjee
Thank you Eric! That works perfectly. Here is a quick video for anyone else who runs into this:
http://imgur.com/a/veRfG
[5 Nov 2017 13:57] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=88364 marked as duplicate of this one.
[26 Jan 2018 21:01] Ben Fulton
Miguel Koscianski Vidal
>When I move the Workbench from my laptop monitor (resolution 1366 x 768) to >another one (resolution 1600 x 900) and then maximize the window, the problem >is gone.

Thanks for that! This solution worked for me on my Windows 10 laptop.
[23 Mar 2018 5:28] Umesh Shastry
Bug #90186 marked as duplicate of this one
[25 May 2018 5:38] Umesh Shastry
Bug #91018 marked as duplicate of this one
[6 Sep 2018 7:17] Umesh Shastry
Bug #92305 marked as duplicate of this one
[19 Sep 2018 20:47] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.13 release, and here's the changelog entry:

Schema privileges in the Administration – Users and Privileges tab
(Object Rights, DDL Rights, and Other Rights) were not visible with all
screen resolutions.

Thank you for the bug report.
[21 Sep 2018 7:06] Umesh Shastry
Bug #92518 marked as duplicate of this one