Bug #83658 Sierra OS incompatibility
Submitted: 2 Nov 2016 19:59 Modified: 31 Jan 23:56
Reporter: Rixon Reed Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S1 (Critical)
Version:6.3.8 OS:Mac OS X (macOS 10.12.x Sierra)
Assigned to:
Tags: WBBugReporter

[2 Nov 2016 19:59] Rixon Reed
Description:
This version doesn't retrieve data. Entire program freezes and must be rebooted. Previous version works fine. 

How to repeat:
Just open and try it.
[2 Nov 2016 20:19] Miguel Solorzano
Thank you for the bug report. Sometimes works for me when I open a second or third query tab.
[3 Nov 2016 21:06] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=83625 marked as duplicate of this one.
[10 Nov 2016 9:30] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=83766 marked as duplicate of this one.
[11 Nov 2016 11:40] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=83782 marked as duplicate of this one.
[12 Nov 2016 8:41] Serafino Melloni
It is not possible to install the MYSQL utilities and the odbc driver under osx sierra (12)
[15 Nov 2016 14:58] Marco van de Water
Is there a work-around available?
[15 Nov 2016 16:27] Miguel Solorzano
@Marco

http://bugs.mysql.com/bug.php?id=83769 showed that the issue is when the MySQL server is started at boot . If I stop and re-start the server at command line as workaround worked for me:

Last login: Tue Nov 15 12:26:28 on console
miguel:~ miguel$ sudo launchctl unload -F /Library/LaunchDaemons/com.oracle.oss.mysql.mysqld.plist
Password:
miguel:~ miguel$ sudo launchctl load -F /Library/LaunchDaemons/com.oracle.oss.mysql.mysqld.plist
miguel:~ miguel$

Then launch WorkBench.
[18 Nov 2016 15:28] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=83886 marked as duplicate of this one.
[18 Nov 2016 15:49] Georgios Vlachakis
Using MAMP in this side. Stopping and restarting there has no effect on issue. Only clearing temp folders (cache and the like) fixes the issue until next application launch
[19 Nov 2016 19:25] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=83890 marked as duplicate of this one.
[22 Nov 2016 20:43] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=83919 marked as duplicate of this one.
[24 Nov 2016 15:48] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=83956  marked as duplicate of this one.
[6 Dec 2016 11:16] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84066 marked as duplicate of this one.
[8 Dec 2016 8:56] Marco van de Water
Hi, 

Stopping/starting MySQL (via MAMP) does not seem to fix the problem. When I clear the cache (~/Library/Caches/com.oracle.mysql.workbench) before starting MySqlWB it works for a while but then hangs again until I force quite and clear the cache again. 

When I only use the data modeller (does not need a DB connection) MySqlWB works fine without hanging. The problem only seems to occur when a connection with a DB is made.

Is there any sign of a solution yet?
[8 Dec 2016 9:49] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84097 marked as duplicate of this one.
[8 Dec 2016 13:30] Marco van de Water
Found a possible work around. Removing the Quarantine ACL seemed to fix it for me:

xattr -dr com.apple.quarantine "/Applications/MySQLWorkbench.app"
[8 Dec 2016 19:17] Steven Waldren
Marco van de Water’s work around seems to work for me as well. (OS X Sierra)
[8 Dec 2016 20:56] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84125 marked as duplicate of this one.
[9 Dec 2016 9:08] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84140 marked as duplicate of this one.
[9 Dec 2016 9:20] Marco van de Water
BTW. This problem has to do with a new feature introduced in macOS Sierra: GateKeeper Path Randomisation. See https://weblog.rogueamoeba.com/2016/06/29/sierra-and-gatekeeper-path-randomization/

Although the removal of the Quarantine ACL via "xattr -r -d com.apple.quarantine "/Applications/MySQLWorkbench.app"" works (also for other App's with this problem), the real fix needs to be done in the app itself (or actually the packaging of the app).
[9 Dec 2016 14:36] Steven Waldren
xattr -dr com.apple.quarantine "/Applications/MySQLWorkbench.app” no longer works for me. It worked the first time I tried. Now it will not.
[14 Dec 2016 8:17] Marco van de Water
@Steven Waldren Yes, doesn't work for me either anymore unfortunately.
[14 Dec 2016 9:53] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84203 marked as duplicate of this one.
[17 Dec 2016 1:21] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84239 marked as duplicate of this one.
[18 Dec 2016 22:58] Don Kramer
Bug seems to be even more pronounced for me since macOS Sierra Version 10.12.2.
[19 Dec 2016 11:39] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84262 marked as duplicate of this one.
[19 Dec 2016 13:57] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84265 marked as duplicate of this one.
[19 Dec 2016 14:16] Steven Waldren
Potential work around:

I noticed that if I use the built-in SSH connection in Workbench, I do not see this bug and query works just fine.

This work around works for me as I was already SSH'ing into my mysql server just was using terminal instead of Workbench.

Best,
Steven
OSX 10.12.1
[20 Dec 2016 16:06] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84280 marked as duplicate of this one.
[26 Dec 2016 9:19] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84333 marked as duplicate of this one.
[28 Dec 2016 12:06] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84357 marked as duplicate of this one.
[28 Dec 2016 14:08] Kane McConnell
None of the above work arounds are working for me. We use the built-in SSH setup.

We use WorkBench to connect to MySQL running within a Vagrant Box on the following environment:

MacOS 10.12.2
VirtualBox 5.1.8 r111374 (Qt5.5.1)
Vagrant 1.8.7

Within Vagrant:
Ubuntu 16.04.1 LTS (GNU/Linux 4.4.0-57-generic x86_64)
MySQL Ver 14.14 Distrib 5.7.16, for Linux (x86_64) using EditLine wrapper
[30 Dec 2016 23:37] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84377 marked as duplicate of this one.
[2 Jan 16:37] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84386 marked as duplicate of this one.
[4 Jan 15:47] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84405 marked as duplicate of this one.
[4 Jan 15:50] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84404 marked as duplicate of this one.
[4 Jan 15:53] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84407 marked as duplicate of this one.
[4 Jan 15:56] Jason Rose
Is there an ETA on when this bug might be fixed?
[4 Jan 16:23] Jonathan Shyman
As a workaround, painful but a workaround, version 6.1.7 of Workbench doesn't seem to have any issues with Sierra
[7 Jan 15:21] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84438 marked as duplicate of this one.
[9 Jan 12:10] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84446 marked as duplicate of this one.
[9 Jan 16:54] Steve Fatula
I have this same issue. Previous versions do not work all the way back to 6.1 where it does work. Can post any log you might want, though, wb.log not very useful as it shows no error, just hangs. I also find that closing a connection hangs the app. Generally, if I open a connection, don't use it, and, open the connection again in a second tab, I can use the second tab and that often works. If I ever click x to close it, hangs. It still hangs now and then with this trick, but, at least not every time.
[11 Jan 0:19] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84461 marked as duplicate of this one.
[11 Jan 12:11] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84462 marked as duplicate of this one.
[12 Jan 13:55] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84483 marked as duplicate of this one.
[17 Jan 19:20] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=84543 marked as duplicate of this one.
[17 Jan 21:37] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=84544 marked as duplicate of this one.
[18 Jan 19:43] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84553 marked as duplicate of this one.
[18 Jan 22:53] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=84560 marked as duplicate of this one.
[19 Jan 13:29] austin woz
I found version 6.3.4 worked better than 6.3.8 but has other bugs making it non usable, so using 6.3.3. It doesnt work all the time, but works better than 6.3.8. 
I have had to resort to a different editor and that works without any issue confirming this is not a connection issue. I had no issues like this prior to Sierra, so conclude it is a workbench on sierra issue as discussed
[19 Jan 13:30] austin woz
none of the workarounds work for me. I am on 10.12.2
[19 Jan 23:06] David Wilkins
Reverted to 6.1.7 - not ideal, but this is an effective workaround until the problem is resolved.
[20 Jan 8:37] Pete Thorne
Experiencing the same bug here. macOS Sierra and 6.3.8

Ironically I only upgraded Workbench to see if you had fixed some of the less critical bugs, only to find that now it's totally unusable. Given the severity of the issue might I suggest that you pull this version or at least mention this on the download page and give a link to the latest working version?
[20 Jan 12:19] Paul Connolley
For anyone who is desperate to reinstall an older 6.3.* I found the archives here: https://downloads.mysql.com/archives/workbench/
[20 Jan 12:25] Pete Thorne
Thanks Paul, I'm using 6.2.5 as it seems pretty stable, if anyone can vouch for a solid version 6.3.x please let me know!
[20 Jan 18:47] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84589 marked as duplicate of this one.
[25 Jan 23:39] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84675 marked as duplicate of this one.
[26 Jan 14:02] J Yu
The workbench crash much more frequent than before and make it impossible to us. I'm now using workbench 6.3.8 on MacOS Sierra. It happened randomly, such as closing a tab, sending query to remote server, exiting workbench app, etc. There's nothing I can do except use force quit.
[26 Jan 15:18] Mike Lischke
We are very sorry for this inconvenience. There will be a new release soon with this problem fixed.
[26 Jan 20:12] Matt Silverman
In case it helps in debugging, this problem affects multiple machines at my office too on OSX 10.12.2 using Workbench 6.3.8 to connect to a remote MySQL server while using VPN.

The issue does not happen predictably.  In our case, all of a sudden this week, after no specific version updates or OS updates, when we connect to the remote database it successfully connects, but as soon as you try to make a query it hangs workbench and only solution is to force quit.  Tried restarting computer, all sorts of other workarounds.  

Oddly, if I try logging into the database from a username that I do not normally log into from workbench, it started working for a little while.

Happy to provide any additional details, as we really want to help get this fixed.  Feel free to reach out to me directly.
[27 Jan 9:58] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84691 marked as duplicate of this one.
[31 Jan 23:23] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=84759 marked as duplicate of this one.
[31 Jan 23:56] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 6.3.9 release, and here's the changelog entry:

In some cases, executing a query caused MySQL Workbench to become
unresponsive when the host was macOS Sierra.

Thank you for the bug report.
[7 Feb 9:09] J Yu
Is there a scheduled date for the version 6.3.9?
[7 Feb 11:02] Georgios Vlachakis
Same here. Any scheduled release date? Can we have access to pre-release binaries?
[7 Feb 11:08] Marco van de Water
Yes, a release date or a link to a beta would be really appreciated!
[7 Feb 11:48] Milosz Bodzek
A little patience - release is just out of the corner.
[9 Feb 12:53] J Yu
Brilliant job. All fixed by version 6.3.9.
[9 Feb 14:17] Steven Waldren
Awesome. Thanks for the hard work to fix this bug. Have a new appreciation for the greatness of Workbench when I could not use it!.
[9 Feb 14:29] austin woz
So far very good, appears this might be the first version I have used in a very long time that is not buggy. A great tool if that is the case, big thank you to the developers that turned this around
[9 Feb 15:50] Donald Langhorne
I wanted to add that I downloaded the most recent version 6.3.9 which not only fixed this bug but has been 100% problem free for me so far and I have spent probably a good 8-10 solid hours using it (in the middle of a couple of database conversions).

thank you SO much for the efforts here, I can't stress how nice it is to be able to use this tool again!!!!
[9 Feb 16:12] Matt Silverman
6.3.9 fixed my issues on OSX sierra as well, and overall this version seems to be very stable.  Great work!
[10 Feb 10:12] Samuel Rohaut
Works for me ! Thanks :)
[10 Feb 10:49] Paul Connolley
Well, this has been one of the most fun-to-follow bug reports ever and also the one that has made me the happiest to see resolved.

Good work fixing this folks!
[10 Feb 17:20] Federico Fioriti
Great job! Problem fixed, now I've just come back to the new release, with all amazing features! Thank you so much
[25 Sep 15:55] Tim Bradshaw
This problem is recurring again for me macOS High Sierra 10.13
[3 Oct 19:20] Beau Shirdavani
I have version 6.3.9, on the new High Sierra v10.13 OS for Mac, and this problem still exists.
[4 Oct 7:24] Massimiliano Chiusso
I confirm, on Mac OS High Sierra the problem still exists in MySQL WB 6.3.9
[4 Oct 15:47] Rick Hubbard
Confirmed. Spinning Beachball of Despair has returned in MSW6.3.9 running on macOS High Sierra 10.13.

If it helps: Trying to connect to an AWS RDS-MySQL instance. DataGrip works just fine.
[4 Oct 15:47] Rick Hubbard
Confirmed. Spinning Beachball of Despair has returned in MSW6.3.9 running on macOS High Sierra 10.13.

If it helps: Trying to connect to an AWS RDS-MySQL instance. DataGrip works just fine.
[4 Oct 15:51] Ian Rutson
Same here, also connecting to MySQL RDS AWS.

Please fix quickly! Happy to beta test...
[5 Oct 17:01] John Vargo
Confirmed on High Sierra running 6.3.9. Connecting to AWS RDB instance through SSH tunnel.
[5 Oct 20:17] austin woz
This bug is closed, no one reads closed bugs. 
Post your interest and subscribe to new bug ticket 
https://bugs.mysql.com/bug.php?id=87862
[9 Oct 2:13] mike coutinho
Bob Davenport complied a version of workbench that works.  Check out this bug report...  

https://bugs.mysql.com/bug.php?id=87714
[10 Oct 10:23] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=88044 marked as duplicate of this one.