Bug #84543 Workbench crashes when closing a query tab
Submitted: 17 Jan 19:10 Modified: 17 Jan 19:20
Reporter: Benjamin Perry Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S5 (Performance)
Version:6.3.6 OS:Mac OS X (10.12.2 (16C67))
Assigned to:
Tags: WBBugReporter

[17 Jan 19:10] Benjamin Perry
Description:

13:07:55 [INF][      WBContext]: Parsing application arguments.
13:07:55 [INF][      WBContext]:     /Applications/MySQLWorkbench.app/Contents/MacOS/MySQLWorkbench
13:07:55 [INF][      Workbench]: Starting up Workbench
13:07:55 [INF][      Workbench]: Loading main window
13:07:55 [INF][   WBContext UI]: Initializing workbench context UI with these values:
        base dir: /Applications/MySQLWorkbench.app/Contents/Resources
        plugin path: /Applications/MySQLWorkbench.app/Contents/PlugIns
        struct path: /Applications/MySQLWorkbench.app/Contents/Resources/grt
        module path: /Applications/MySQLWorkbench.app/Contents/PlugIns:/Applications/MySQLWorkbench.app/Contents/Resources/plugins
        library path: /Applications/MySQLWorkbench.app/Contents/Resources/libraries
        user data dir: /Users/ben/Library/Application Support/MySQL/Workbench
        open at start:
        open type:
        run at startup:
        run type:
        Force SW rendering: No
        Force OpenGL: No
        quit when done: No
13:07:55 [INF][      WBContext]: WbContext::init
13:07:55 [INF][            WBA]: Looking for extension modules for WBA...
13:07:55 [INF][            WBA]: 0 extension modules found
13:07:55 [WRN][            grt]: /Applications/MySQLWorkbench.app/Contents/Resources/data/table_templates.xml:21: link 'com.mysql.rdbms.mysql.datatype.timestamp' <object db.SimpleDatatype> key=simpleType could not be resolved
13:07:55 [WRN][            grt]: /Applications/MySQLWorkbench.app/Contents/Resources/data/table_templates.xml:106: link 'com.mysql.rdbms.mysql.datatype.varchar' <object db.SimpleDatatype> key=simpleType could not be resolved
13:07:55 [WRN][            grt]: /Applications/MySQLWorkbench.app/Contents/Resources/data/table_templates.xml:229: link 'com.mysql.rdbms.mysql.datatype.int' <object db.SimpleDatatype> key=simpleType could not be resolved
13:07:55 [WRN][            grt]: /Users/ben/Library/Application Support/MySQL/Workbench/connections.xml:26: link '8FBF7EF2-D344-44AF-A9CB-0C14DE23585D' <object GrtObject> key=owner could not be resolved
13:07:55 [INF][      WBContext]: System info:
        MySQL Workbench Community (GPL) for Mac OS X version 6.3.6 CE build 511 (32 bit)
        Configuration Directory: /Users/ben/Library/Application Support/MySQL/Workbench
        Data Directory: /Applications/MySQLWorkbench.app/Contents/Resources
        Cairo Version: 1.10.2
        OS: unknown
        CPU: 8x Intel(R) Core(TM) i7-4980HQ CPU @ 2.80GHz - 16.00GiB RAM

13:07:55 [INF][    WQE backend]: Found auto-save workspace /Users/ben/Library/Application Support/MySQL/Workbench/sql_workspaces/Purplewire_RDS_(appserver_user)-1.autosave
13:07:55 [INF][    WQE backend]: Found auto-save workspace /Users/ben/Library/Application Support/MySQL/Workbench/sql_workspaces/staging_dev-1.autosave
13:07:57 [INF][      SqlEditor]: Opened connection 'Local' to MySQL Community Server (GPL) version 5.7.17
13:07:57 [INF][     AutoCCache]: Initializing autocompletion cache for Local

How to repeat:
Open a database, and open any query tab. Upon closing the tab, workbench crashes.
[17 Jan 19:11] Benjamin Perry
Adding OS X version
[17 Jan 19:20] Miguel Solorzano
Thank you for the feedback. Duplicate of http://bugs.mysql.com/bug.php?id=83658.