Bug #84544 Crashes After Closing Connection Tab
Submitted: 17 Jan 20:43 Modified: 17 Jan 21:36
Reporter: NOT_FOUND NOT_FOUND Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:6.3.3.0 OS:Mac OS X (10.12.3)
Assigned to:

[17 Jan 20:43] NOT_FOUND NOT_FOUND
Description:
Closing a connection tab in MySQL Workbench causes the workbench to crash on Mac OS X with a segfault of type EXC_BAD_ACCESS with code KERN_INVALID_ADDRESS

Process:               MySQLWorkbench [3613]
Path:                  /Users/USER/*/MySQLWorkbench.app/Contents/MacOS/MySQLWorkbench
Identifier:            com.oracle.mysql.workbench
Version:               6.3.3 (1)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           MySQLWorkbench [3613]
User ID:               502

Date/Time:             2017-01-17 12:42:10.849 -0800
OS Version:            Mac OS X 10.12.3 (16D25a)
Report Version:        12
Anonymous UUID:        5CED7DB6-C6B4-B0B9-B238-3797C3F72519

Time Awake Since Boot: 9700 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x000005dd8160bec0
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [0]

VM Regions Near 0x5dd8160bec0:
    mapped file            000000011a10a000-000000011b991000 [ 24.5M] r--/r-x SM=ALI  pl;
--> 
    JS JIT generated code  0000322757c00000-0000322757c01000 [    4K] ---/rwx SM=NUL  

Application Specific Information:
objc_msgSend() selector name: respondsToSelector:

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libobjc.A.dylib               	0x00007fff9c8f6b5d objc_msgSend + 29
1   com.apple.AppKit              	0x00007fff85e0d050 -[NSRulerView dealloc] + 55
2   com.sun.Scintilla             	0x0000000106ceaa80 -[SCIMarginView dealloc] + 68
3   libobjc.A.dylib               	0x00007fff9c8fec49 objc_object::sidetable_release(bool) + 285
4   libobjc.A.dylib               	0x00007fff9c8f9e60 (anonymous namespace)::AutoreleasePoolPage::pop(void*) + 808
5   com.apple.CoreFoundation      	0x00007fff87bae106 _CFAutoreleasePoolPop + 22
6   com.apple.Foundation          	0x00007fff89613f13 -[NSAutoreleasePool drain] + 146
7   com.apple.AppKit              	0x00007fff85713464 -[NSApplication run] + 1093
8   com.apple.AppKit              	0x00007fff856ddcd8 NSApplicationMain + 1237
9   com.oracle.mysql.workbench    	0x0000000106a9cce4 start + 52

How to repeat:
1. Create a new Connection
2. Close the connection tab by clicking on the "x"
[17 Jan 21:36] Miguel Solorzano
Thank you for the feedback. Duplicate of http://bugs.mysql.com/bug.php?id=83658.