Bug #66013 MySQL Data Modeling doesn't allow edit table
Submitted: 25 Jul 2012 19:03 Modified: 9 Aug 2012 20:12
Reporter: John Tester Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S2 (Serious)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit)
Assigned to: Mike Lischke CPU Architecture:Any
Tags: WBBugReporter

[25 Jul 2012 19:03] John Tester
Description:
MySQL Data Modelingl doesn't allow to edit table.

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9727
Configuration Directory: C:\Users\Win7User\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Distr\MySQL Workbench 5.2.41 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit
CPU: 2x Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz, 4.0 GiB RAM
Current user language: English (United States)

Exception = System.InvalidCastException
Message = Unable to cast object of type 'OverviewUIForm' to type 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
FullText = System.InvalidCastException: Unable to cast object of type 'OverviewUIForm' to type 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
   at MySQL.GUI.Workbench.Plugins.DockablePlugin.GetFromFixedPtr(IntPtr ptr)
   at MySQL.GUI.Workbench.MainForm.ShowPlugin(IntPtr ptr)
   at MySQL.Forms.AppImpl.show_editor_wrapper(UInt32 native_handle)
   at boost.detail.function.void_function_invoker1<void (__cdecl*)(unsigned int),void,unsigned int>.invoke(function_buffer* function_ptr, UInt32 a0)
   at wb.WBContext.flush_idle_tasks(WBContext* )
   at MySQL.Workbench.WbContext.flush_idle_tasks()
   at MySQL.GUI.Workbench.Program.timer_Tick(Object sender, EventArgs e)

How to repeat:
1. In MySQL Model UI create two tables:
TABLE Items1 ( ItemID int NOT NULL, Name varchar(45), PRIMARY KEY (ItemID) )
TABLE Items2 ( ItemID int NOT NULL, Name varchar(45), PRIMARY KEY (ItemID) )
2. Save the project to test.mwb
3. Close the project.
4. Open test.mwb
5. Try to edit Items1 or Item2 table
[26 Jul 2012 3:06] Alfredo Kojima
bug #66014 is a duplicate
[26 Jul 2012 14:59] Alfredo Kojima
bug #66012 is a duplicate
[26 Jul 2012 14:59] Alfredo Kojima
bug #66024 is a duplicate
[27 Jul 2012 4:08] Valeriy Kravchuk
Bug #66026 is a duplicate.
[27 Jul 2012 13:43] Alfredo Kojima
bug #66046 is a duplicate
[27 Jul 2012 13:43] Alfredo Kojima
bug #66047 is a duplicate
[27 Jul 2012 19:06] Alfredo Kojima
bug #66055 is a duplicate
bug #66054 is a duplicate
bug #66053 is a duplicate
[27 Jul 2012 21:43] Fotis Kokkoras
A quick fix for this bug will be greatly appreciated. It renders the modeling part of the app useless!
[28 Jul 2012 9:05] Valeriy Kravchuk
Bug #66061 was marked as a duplicate of this one.
[30 Jul 2012 3:28] Dragon Chuang
a quick workaround is close the edit panel then edit (double-click) other one.
once you edit other one directly, you have to restart WB.
[1 Aug 2012 8:53] Jonas Macheret
Error message related to this issue

Attachment: MySQL Workbench_2012-08-01_10-50-37.png (image/png, text), 63.44 KiB.

[1 Aug 2012 8:57] Jonas Macheret
Quote:
"a quick workaround is close the edit panel then edit (double-click) other one.
once you edit other one directly, you have to restart WB."

Really? I mean come on, who wants to restart WB everytime you need to edit a table? :)

This bug seems pretty critical since it really makes the EER diagram editor useless. People like me will turn to other solutions. Sorry guys.
[1 Aug 2012 11:52] Fotis Kokkoras
"once you edit other one directly, you have to restart WB"
Jonas, that was an evidence. No one told that this is the way it is supposed to work. I am sure they will fix it. It's not a feature! It's a bug.
[1 Aug 2012 12:24] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=66133 marked as duplicate of this one.
[2 Aug 2012 7:50] Jonas Macheret
Well, I guess a possible workaround would be to use an older version of WB OSS only for diagrams http://dev.mysql.com/downloads/workbench/5.0.html. It can be installed in parallel with the latest version of WB.

Of course you'll miss the synch functions but you can still work with it.
[2 Aug 2012 12:53] kris adidarma
this bug is very annoying and needs to be fixed pronto
[2 Aug 2012 14:58] Wilfried Grabbe
In version 5.2.33 there is/was no such bug. Deinstallation of 5.2.41 and reinstalling 5.2.33 solved the problem.
[2 Aug 2012 16:12] Alfredo Kojima
bug #66123 is a duplicate
[4 Aug 2012 15:08] Alfredo Kojima
Bug #66168 is a duplicate
[7 Aug 2012 1:19] Alfredo Kojima
Bug #66233 and Bug #66231 are duplicates
[9 Aug 2012 20:12] Philip Olson
Fixed as of the upcoming 5.2.42, and here's the changelog entry:

Data modeling would not allow table edits, and repeated attempts
to do so would crash MySQL Workbench.
[10 Aug 2012 0:54] Alfredo Kojima
Bug #66291 is a duplicate
[10 Aug 2012 1:00] Alfredo Kojima
Bug #66289 is a dup
[10 Aug 2012 1:00] Alfredo Kojima
Bug #66292 is a duplicate
[10 Aug 2012 22:53] Alfredo Kojima
Bug #66313
Bug #66314
Bug #66316
are duplicates
[11 Aug 2012 0:17] Alfredo Kojima
Bug #66320
Bug #66319
Bug #66318
are dups
[12 Aug 2012 5:12] Alfredo Kojima
Bug #66331 Bug #66332 are dups
[12 Aug 2012 5:13] Alfredo Kojima
Bug #66334 = dup
[12 Aug 2012 5:14] Alfredo Kojima
Bug #66333 is dup
[13 Aug 2012 3:22] Alfredo Kojima
Bug #66341 is another dup
[16 Jan 2013 14:56] Chris Hanson
I'm still having this problem in 5.2.45