Bug #66231 Exception when trying to edit a table
Submitted: 6 Aug 2012 21:41 Modified: 7 Aug 2012 1:19
Reporter: Matthieu Haméon Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[6 Aug 2012 21:41] Matthieu Haméon
Description:
An exception raise when editing a table

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9727
Configuration Directory: C:\Users\Matt\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit
CPU: 8x Intel(R) Core(TM) i7 CPU         860  @ 2.80GHz, 4.0 GiB RAM
Active video adapter (0): ATI Radeon HD 5800 Series
Installed video RAM: 1024 MB
Current video mode: 1920 x 1080 x 4294967296 couleurs
Used bit depth: 32
Driver version: 8.980.0.0
Installed display drivers: aticfx64.dll,aticfx64.dll,aticfx64.dll,aticfx32,aticfx32,aticfx32,atiumd64.dll,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a.cap,atitmm64.dll
Current user language: Français (France)

Exception = System.InvalidCastException
Message = Impossible d'effectuer un cast d'un objet de type 'MySQL.Forms.ToolBarItemImpl' en type 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
FullText = System.InvalidCastException: Impossible d'effectuer un cast d'un objet de type 'MySQL.Forms.ToolBarItemImpl' en type 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
   à MySQL.GUI.Workbench.Plugins.DockablePlugin.GetFromFixedPtr(IntPtr ptr)
   à MySQL.GUI.Workbench.MainForm.ShowPlugin(IntPtr ptr)
   à MySQL.Forms.AppImpl.show_editor_wrapper(UInt32 native_handle)
   à boost.detail.function.void_function_invoker1<void (__cdecl*)(unsigned int),void,unsigned int>.invoke(function_buffer* function_ptr, UInt32 a0)
   à wb.ModelDiagramForm.handle_mouse_double_click(ModelDiagramForm* , MouseButton , Int32 , Int32 , EventState )
   à MySQL.Workbench.ModelDiagramFormWrapper.OnMouseDoubleClick(MouseEventArgs e, Int32 X, Int32 Y, Keys keystate, MouseButtons buttons)
   à MySQL.GUI.Workbench.ModelDiagramForm.CanvasPanel_MouseDoubleClick(Object sender, MouseEventArgs e)
   à System.Windows.Forms.Control.OnMouseDoubleClick(MouseEventArgs e)
   à MySQL.Utilities.WindowsCanvasViewerPanel.OnMouseDoubleClick(MouseEventArgs e)
   à System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   à System.Windows.Forms.Control.WndProc(Message& m)
   à System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   à System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   à System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   à System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Appears randomly.
Double click on table to edit.
[7 Aug 2012 1:19] Alfredo Kojima
Duplicate of bug #66013