Bug #66233 Cannot convert object
Submitted: 6 Aug 2012 23:25 Modified: 7 Aug 2012 1:18
Reporter: David Lopez Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows 7 Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[6 Aug 2012 23:25] David Lopez
Description:
When modifying some data in the 'Insert' tab, tried to double click another table to check their 'Insert' values.
NOTE: Had a previous key constraint problem with the first table.

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9727
Configuration Directory: C:\Users\David A López\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7  Service Pack 1 (build 7601), 64-bit
CPU: 8x Intel(R) Core(TM) i7-2670QM CPU @ 2.20GHz, 3.9 GiB RAM
Active video adapter (0): Radeon HD 6490M   
Installed video RAM: 1024 MB
Current video mode: 1366 x 768 x 4294967296 colores
Used bit depth: 32
Driver version: 8.910.0.0
Installed display drivers: aticfx64.dll,aticfx64.dll,aticfx64.dll,aticfx32,aticfx32,aticfx32,atiumd64.dll,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a.cap,atitmm64.dll
Current user language: Español (México)

Exception = System.InvalidCastException
Message = No se puede convertir un objeto de tipo 'MySQL.Forms.MenuItemImpl' al tipo 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
FullText = System.InvalidCastException: No se puede convertir un objeto de tipo 'MySQL.Forms.MenuItemImpl' al tipo 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
   en MySQL.GUI.Workbench.Plugins.DockablePlugin.GetFromFixedPtr(IntPtr ptr)
   en MySQL.GUI.Workbench.MainForm.ShowPlugin(IntPtr ptr)
   en MySQL.Forms.AppImpl.show_editor_wrapper(UInt32 native_handle)
   en boost.detail.function.void_function_invoker1<void (__cdecl*)(unsigned int),void,unsigned int>.invoke(function_buffer* function_ptr, UInt32 a0)
   en wb.ModelDiagramForm.handle_mouse_double_click(ModelDiagramForm* , MouseButton , Int32 , Int32 , EventState )
   en MySQL.Workbench.ModelDiagramFormWrapper.OnMouseDoubleClick(MouseEventArgs e, Int32 X, Int32 Y, Keys keystate, MouseButtons buttons)
   en MySQL.GUI.Workbench.ModelDiagramForm.CanvasPanel_MouseDoubleClick(Object sender, MouseEventArgs e)
   en System.Windows.Forms.Control.OnMouseDoubleClick(MouseEventArgs e)
   en MySQL.Utilities.WindowsCanvasViewerPanel.OnMouseDoubleClick(MouseEventArgs e)
   en System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   en System.Windows.Forms.Control.WndProc(Message& m)
   en System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   en System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   en System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   en System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Have table A with a 1:N relation to table B. Type wrong values at B's fk column. Try to Fwd engineer and get a constraint error. Change the values at B's fk column. Try to double click A table.
[7 Aug 2012 1:18] Alfredo Kojima
Duplicate of bug #66013