Bug #66292 Can't edit tables on ER Diagram
Submitted: 9 Aug 2012 22:27 Modified: 10 Aug 2012 1:00
Reporter: André Martins Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S1 (Critical)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[9 Aug 2012 22:27] André Martins
Description:
Sometimes when editing an EER Diagram, it's not possible to edit the table fields, either by clicking on the table or selecting "Edit Table" or "Edit in New Windows" on pop-up menu.

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9727
Configuration Directory: C:\Users\André Martins\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit
CPU: 8x Intel(R) Core(TM) i7-2675QM CPU @ 2.20GHz, 7.9 GiB RAM
Active video adapter (0): Mobile Intel(R) HD Graphics
Installed video RAM: -235 MB
Current video mode: 1600 x 900 x 4294967296 colors
Used bit depth: 32
Driver version: 8.863.1.2000
Installed display drivers: igdumd64.dll,igd10umd64.dll,igd10umd64.dll,igdumdx32,igd10umd32,igd10umd32
Active video adapter (1): AMD Radeon HD 6490M
Installed video RAM: 512 MB
Current video mode: 1920 x 1080 x 4294967296 colors
Used bit depth: 32
Driver version: 8.863.1.2000
Installed display drivers: aticfx64.dll,aticfx64.dll,aticfx64.dll,aticfx32,aticfx32,aticfx32,atiumd64.dll,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a.cap,atitmm64.dll
Current user language: Português (Brasil)

Exception = System.InvalidCastException
Message = Unable to cast object of type 'MySQL.Forms.MenuItemImpl' to type 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
FullText = System.InvalidCastException: Unable to cast object of type 'MySQL.Forms.MenuItemImpl' to type 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
   at MySQL.GUI.Workbench.Plugins.DockablePlugin.GetFromFixedPtr(IntPtr ptr)
   at MySQL.GUI.Workbench.MainForm.ShowPlugin(IntPtr ptr)
   at MySQL.Forms.AppImpl.show_editor_wrapper(UInt32 native_handle)
   at boost.detail.function.void_function_invoker1<void (__cdecl*)(unsigned int),void,unsigned int>.invoke(function_buffer* function_ptr, UInt32 a0)
   at wb.ModelDiagramForm.handle_mouse_double_click(ModelDiagramForm* , MouseButton , Int32 , Int32 , EventState )
   at MySQL.Workbench.ModelDiagramFormWrapper.OnMouseDoubleClick(MouseEventArgs e, Int32 X, Int32 Y, Keys keystate, MouseButtons buttons)
   at MySQL.GUI.Workbench.ModelDiagramForm.CanvasPanel_MouseDoubleClick(Object sender, MouseEventArgs e)
   at System.Windows.Forms.Control.OnMouseDoubleClick(MouseEventArgs e)
   at MySQL.Utilities.WindowsCanvasViewerPanel.OnMouseDoubleClick(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Most of times is random; however, when you create a new table and try to edit an existing table, the error occurs.
[10 Aug 2012 1:00] Alfredo Kojima
Duplicate of bug #66013