Bug #66291 Sometimes can't edit table
Submitted: 9 Aug 2012 21:18 Modified: 10 Aug 2012 0:54
Reporter: Fred GODZILEY Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S1 (Critical)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[9 Aug 2012 21:18] Fred GODZILEY
Description:
Impossible d'effectuer un cast d'un objet de type 'MySQL.FOrms.MenuItemImpl' en type 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
In that case i must close workbench to reopen it. Very anoying

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9727
On Windows Seven 64
Configuration Directory: C:\Users\RomTitaTed\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit
CPU: 3x AMD Phenom(tm) II N830 Triple-Core Processor, 4.0 GiB RAM
Active video adapter (0): ATI Mobility Radeon HD 5000 Series
Installed video RAM: 1024 MB
Current video mode: 1366 x 768 x 4294967296 couleurs
Used bit depth: 32
Driver version: 8.980.0.0
Installed display drivers: aticfx64.dll,aticfx64.dll,aticfx64.dll,aticfx32,aticfx32,aticfx32,atiumd64.dll,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a.cap,atitmm64.dll
Current user language: Français (France)

Exception = System.InvalidCastException
Message = Impossible d'effectuer un cast d'un objet de type 'MySQL.Forms.MenuItemImpl' en type 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
FullText = System.InvalidCastException: Impossible d'effectuer un cast d'un objet de type 'MySQL.Forms.MenuItemImpl' en type 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
   à MySQL.GUI.Workbench.Plugins.DockablePlugin.GetFromFixedPtr(IntPtr ptr)
   à MySQL.GUI.Workbench.MainForm.ShowPlugin(IntPtr ptr)
   à MySQL.Forms.AppImpl.show_editor_wrapper(UInt32 native_handle)
   à boost.detail.function.void_function_invoker1<void (__cdecl*)(unsigned int),void,unsigned int>.invoke(function_buffer* function_ptr, UInt32 a0)
   à wb.ModelDiagramForm.handle_mouse_double_click(ModelDiagramForm* , MouseButton , Int32 , Int32 , EventState )
   à MySQL.Workbench.ModelDiagramFormWrapper.OnMouseDoubleClick(MouseEventArgs e, Int32 X, Int32 Y, Keys keystate, MouseButtons buttons)
   à MySQL.GUI.Workbench.ModelDiagramForm.CanvasPanel_MouseDoubleClick(Object sender, MouseEventArgs e)
   à System.Windows.Forms.Control.OnMouseDoubleClick(MouseEventArgs e)
   à MySQL.Utilities.WindowsCanvasViewerPanel.OnMouseDoubleClick(MouseEventArgs e)
   à System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   à System.Windows.Forms.Control.WndProc(Message& m)
   à System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   à System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   à System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   à System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Edit a table then double click to an other until you can't open it to edit it
[10 Aug 2012 0:54] Alfredo Kojima
Duplicate of bug #66013