Bug #66061 tried to edit a table design
Submitted: 28 Jul 2012 0:06 Modified: 28 Jul 2012 9:03
Reporter: Martyn Bristow Email Updates:
Status: Duplicate Impact on me:
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.41 OS:Windows (Microsoft Windows 7 Service Pack 1 (build 7601), 32-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[28 Jul 2012 0:06] Martyn Bristow
Tried to edit a defined tabe

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9727
Configuration Directory: C:\Users\Martyn\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7  Service Pack 1 (build 7601), 32-bit
CPU: 2x Genuine Intel(R) CPU            2140  @ 1.60GHz, 2.0 GiB RAM
Active video adapter (0): Intel(R)  Q965/Q963 Express Chipset Family
Installed video RAM: 384 MB
Current video mode: 1280 x 1024 x 4294967296 colors
Used bit depth: 32
Driver version:
Installed display drivers: igdumdx32.dll
Current user language: English (United Kingdom)

Exception = System.InvalidCastException
Message = Unable to cast object of type 'MySQL.GUI.Mdc.WindowsGDICanvasView' to type 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
FullText = System.InvalidCastException: Unable to cast object of type 'MySQL.GUI.Mdc.WindowsGDICanvasView' to type 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
   at MySQL.GUI.Workbench.Plugins.DockablePlugin.GetFromFixedPtr(IntPtr ptr)
   at MySQL.GUI.Workbench.MainForm.ShowPlugin(IntPtr ptr)
   at MySQL.Forms.AppImpl.show_editor_wrapper(UInt32 native_handle)
   at boost.detail.function.void_function_invoker1<void (__cdecl*)(unsigned int),void,unsigned int>.invoke(function_buffer* function_ptr, UInt32 a0)
   at wb.WBContext.flush_idle_tasks(WBContext* )
   at MySQL.Workbench.WbContext.flush_idle_tasks()
   at MySQL.GUI.Workbench.Program.timer_Tick(Object sender, EventArgs e)

How to repeat:
After setting up a database schema containing seveal tables, relationships try to edit an existing table.
I had about 20 tables and 20 relationships
[28 Jul 2012 9:03] Valeriy Kravchuk
This is a duplicate of bug #66013.