Bug #66053 trava o sistema quando tento selecionar uma tabela no EER Diagram
Submitted: 27 Jul 2012 17:52 Modified: 27 Jul 2012 19:05
Reporter: Leandro Spricigo Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S2 (Serious)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[27 Jul 2012 17:52] Leandro Spricigo
Description:
Trava o sistema quando tento alterar uma tabela no diagrama

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9727
Configuration Directory: C:\Users\Admin\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit
CPU: 4x Intel(R) Core(TM)2 Quad CPU    Q8400  @ 2.66GHz, 4.0 GiB RAM
Active video adapter (0): NVIDIA GeForce 7300 SE/7200 GS (Microsoft Corporation - WDDM)
Installed video RAM: 256 MB
Current video mode: 1280 x 1024 x 4294967296 colors
Used bit depth: 32
Driver version: 8.15.11.8593
Installed display drivers: nvd3dumx.dll,nvd3dum,nvwgf2umx.dll, nvwgf2um
Current user language: Português (Brasil)

Exception = System.InvalidCastException
Message = Não é possível converter um objeto do tipo 'MySQL.Forms.MenuItemImpl' no tipo 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
FullText = System.InvalidCastException: Não é possível converter um objeto do tipo 'MySQL.Forms.MenuItemImpl' no tipo 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
   em MySQL.GUI.Workbench.Plugins.DockablePlugin.GetFromFixedPtr(IntPtr ptr)
   em MySQL.GUI.Workbench.MainForm.ShowPlugin(IntPtr ptr)
   em MySQL.Forms.AppImpl.show_editor_wrapper(UInt32 native_handle)
   em boost.detail.function.void_function_invoker1<void (__cdecl*)(unsigned int),void,unsigned int>.invoke(function_buffer* function_ptr, UInt32 a0)
   em wb.ModelDiagramForm.handle_mouse_double_click(ModelDiagramForm* , MouseButton , Int32 , Int32 , EventState )
   em MySQL.Workbench.ModelDiagramFormWrapper.OnMouseDoubleClick(MouseEventArgs e, Int32 X, Int32 Y, Keys keystate, MouseButtons buttons)
   em MySQL.GUI.Workbench.ModelDiagramForm.CanvasPanel_MouseDoubleClick(Object sender, MouseEventArgs e)
   em System.Windows.Forms.Control.OnMouseDoubleClick(MouseEventArgs e)
   em MySQL.Utilities.WindowsCanvasViewerPanel.OnMouseDoubleClick(MouseEventArgs e)
   em System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   em System.Windows.Forms.Control.WndProc(Message& m)
   em System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   em System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   em System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   em System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Acontece seguidamente, nao consigo selecionar a tabela para alterar
[27 Jul 2012 19:05] Alfredo Kojima
duplicate of bug #66013