Bug #62703 Opening Model (mwb) Fle Failed
Submitted: 12 Oct 2011 17:27 Modified: 17 Nov 2011 18:22
Reporter: Darrell Thacher Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:5.2.35 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[12 Oct 2011 17:27] Darrell Thacher
Description:
Could not open a model file.

Error msg:  "Access to the path 'c:\program files\mysql\mysql workbench ce 5.2.35\db_utils.pyc' is denied."

How to repeat:
Happens every time I try to open a model file.
[12 Oct 2011 17:28] Darrell Thacher
screenshot of error

Attachment: MySQL Workbench Unexpected Error_2011-10-12_13-25-21.png (image/png, text), 44.93 KiB.

[12 Oct 2011 18:09] Alfredo Kojima
How did you install Workbench? If from the zip, did you delete the old installation first?
[12 Oct 2011 18:24] Darrell Thacher
I downloaded mysql-installer-5.5.16.0.msi and used the windows installer.
[13 Oct 2011 1:05] Miguel Solorzano
Looks related to the same issue of: http://bugs.mysql.com/bug.php?id=62709.
[13 Oct 2011 16:40] Armando Lopez Valencia
Hello Darrell.
Can you please try one he following work around:
- Run WB with admin privileges.
- Uninstall WB, delete all the WB remaining data (C:\Program Files (x86)\MySQL\MySQL Workbench CE 5.2.35) and install WB again.
Please let us know the outcome.
Thanks.
[17 Oct 2011 12:02] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=62771 marked as duplicate of this one.
[17 Oct 2011 16:11] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=62774 marked as duplicate of this one.
[17 Oct 2011 16:13] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=62773 marked as duplicate of this one.
[17 Oct 2011 16:30] Siddhesh Tengse
I've faced the same issue with Vista. Try running MySQL Workbench as an Administrator. (Run as administrator). It worked for me.
[17 Oct 2011 21:49] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=62777 marked as duplicate of this one.
[18 Oct 2011 12:32] Valeriy Kravchuk
Bug #62779 was marked as a duplicate of this one.
[18 Oct 2011 13:30] Valeriy Kravchuk
Bug #62785 was marked as a duplicate of this one.
[18 Oct 2011 14:53] Valeriy Kravchuk
Bug #62778 was marked as a duplicate of this one.
[18 Oct 2011 14:56] Darrell Thacher
Thanks for suggestions.  Deleting all workbench files and re-installing fixed my problem with opening a model under Windows Vista.
[18 Oct 2011 14:56] Darrell Thacher
Can close this bug now.
[19 Oct 2011 18:18] Valeriy Kravchuk
Bug #62824 was marked as a duplicate of this one.
[23 Oct 2011 9:54] Valeriy Kravchuk
Bug #62880 was marked as a duplicate of this one.
[23 Oct 2011 9:56] Valeriy Kravchuk
Bug #62881 was marked as a duplicate of this one.
[23 Oct 2011 10:04] Valeriy Kravchuk
Bug #62885 was marked as a duplicate of this one.
[23 Oct 2011 10:07] Valeriy Kravchuk
Bug #62888 was marked as a duplicate of this one.
[28 Oct 2011 12:59] Alfredo Kojima
Unable to repeat the bug in the same conditions, but was able to artificially recreate the crash.
As previously mentioned, starting WB as administrator or fully cleaning the install folder before
upgrade should be a workaround.
[1 Nov 2011 16:04] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=63059 marked as duplicate of this one.
[2 Nov 2011 0:32] Alfredo Kojima
Bug #62709 is a duplicate
[8 Nov 2011 0:03] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=63139 marked as duplicate of this one.
[16 Nov 2011 18:52] Tony Ducepec
Installation is fast and Easy.  The application works the first time.  Once you close it and open it another time, you will receive and error report. 

TRY THIS: RUN APPLICATION AS ADMINISTRATOR.

It worked for me.  Good luck.
[17 Nov 2011 18:22] Philip Olson
Fixed as of 5.2.36:
+        Opening model files while using a &workbench; version that was
+        installed over a previous &workbench; installation would
+        sometimes cause permission issues. The workarounds included
+        running &workbench; with administrator privileges, or removing
+        the installation folder before upgrading.
[4 Jan 2013 19:26] Shane Bester
bug #68028 is a duplicate
[5 Aug 2015 19:25] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=77950 marked as duplicate of this one.