Bug #30823 Error in manifest prevents MySQLInstanceConfig from running on Windows Vista
Submitted: 5 Sep 2007 9:26 Modified: 5 May 2008 18:46
Reporter: Tonci Grgin Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Config Wizard Severity:S3 (Non-critical)
Version:5.1.21, 5.0.51a OS:Microsoft Windows (Vista)
Assigned to: Iggy Galarza
Triage: D2 (Serious)

[5 Sep 2007 9:26] Tonci Grgin
Description:
Following on Bug#30744 I found out that MySQL Instance Config does not start from setup even if one specifically asked for that. Problem was repeated on Vista Ultimate x64 and Vista Business x32 with appropriate version (essentials) of MySQL server (MySQL server 5.1.21-beta-winx64.msi 28969KB and 32 bit).

How to repeat:
Download essentials .msi from our site, install on Vista with Complete option. Same .msi file works correctly on my WinXP Pro x64 SP1.

Suggested fix:
-
[5 Feb 2008 3:52] Adam Dixon
I believe this to be the same problem, (instance manager also not starting after install) 32bit Vista business.

Running the instance manager manually via cmdline or explorer also causes error (copied from error log);

Log Name:      Application
Source:        SideBySide
Date:          2/5/2008 2:04:16 PM
Event ID:      63
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      adixonlap
Description:
Activation context generation failed for "C:\Program Files\MySQL\MySQL Server 5.0\bin\MySQLInstanceConfig.exe".Error in manifest or policy file "C:\Program Files\MySQL\MySQL Server 5.0\bin\MySQLInstanceConfig.exe" on line 6. The value "asAdministrator" of attribute "level" in element "urn:schemas-microsoft-com:asm.v1^requestedPrivileges" is invalid.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="SideBySide" />
    <EventID Qualifiers="49409">63</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2008-02-05T03:34:16.000Z" />
    <EventRecordID>5864</EventRecordID>
    <Channel>Application</Channel>
    <Computer>adixonlap</Computer>
    <Security />
  </System>
  <EventData>
    <Data>urn:schemas-microsoft-com:asm.v1^requestedPrivileges</Data>
    <Data>level</Data>
    <Data>asAdministrator</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>C:\Program Files\MySQL\MySQL Server 5.0\bin\MySQLInstanceConfig.exe</Data>
    <Data>C:\Program Files\MySQL\MySQL Server 5.0\bin\MySQLInstanceConfig.exe</Data>
    <Data>6</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>
[10 Feb 2008 5:39] karine van kranenburg
Bug 30823 I have the exact same problem as Adam Dixon. What's the solution?

Karine
[10 Feb 2008 11:37] George Schizas
I think the correct value for the manifest is "requiresAdministrator", not "asAdministrator"

The only fix I found was installing a previous version of MySQL and upgrading to the latest one afterwards
[10 Feb 2008 11:44] George Schizas
Of course, there is the solutions of opening the file with a resource editor and deleting the manifest completely.
[11 Feb 2008 15:51] Iggy Galarza
Index: build/SignBinary.cmd
===================================================================
--- build/SignBinary.cmd	(revision 168)
+++ build/SignBinary.cmd	(working copy)
@@ -11,7 +11,7 @@
 cd ..\bin\windows
  
 echo Creating Manifest ...
-cscript /nologo ..\..\build\create_manifest.js name=MySQLInstanceConfig.exe arch=x86 exe_level=asAdministrator outfile=MySQLInstanceConfig.exe.manifest
+cscript /nologo ..\..\build\create_manifest.js name=MySQLInstanceConfig.exe arch=x86 exe_level=requireAdministrator outfile=MySQLInstanceConfig.exe.manifest
[11 Feb 2008 19:34] Patrick Crews
Ok to push

1)  Verified on 32bit Vista Ultimate - presence of existing bug with current Instance Config.exe as well as correction of bug with revised Instance Config wizard.

2)  Also tested on 32 bit XP to ensure nothing changed with existing functionality (no problems were present on XP - wanted to ensure nothing developed from changes.
[12 Feb 2008 13:46] Iggy Galarza
Marked bug# 34340 as a duplicate.
[19 Feb 2008 23:05] Iggy Galarza
Marked Bug#34559 as a duplicate.
[21 Feb 2008 10:12] Pedro Ibarreche
Hello,

as suggested in this thread, I tried modifying the exe(changed "asAdministrator" by "requireAdministrator"). Just used standard windows editor (I am not an expert, not sure this should work in an .exe file, but I tried).

Error changed, now indicates that release is not compatible with windows vista, so I should check x86 or x64. Not to say, I modified and tried with both versions, but I find the same error message. My questions:

- Is the way I modified the file proper?
- As it seems, is the x64 wizard version incorect?
- If trying to install an older version, exist a config wizard that works in Vista - 64 bits, that somebody has worked out

Thank you in advance. Best regards,

Pedro
[21 Feb 2008 15:00] Pedro Ibarreche
I found a piece of information that could help. It is a tutorial to install also mySQL5.1 and to workaround problems for 64 bits config wizard.

find it in:
http://blondr.blogspot.com/2006/11/set-up-iis-7-w-mysql-and-php-5.html

For your reference, I extract relevant:

"...
Once you downloaded the MySQL installer, 32bit users, all you have to do is go through the Installer steps (Click next,next next next) and you should be fine.

64bit users, you still got some little work, after installing the MySQL, i had a problem running the configuration wizard, in order to solve that problem, i used the following trick.

I downloaded the 32bit zip package (without installer), inside C:\Program Files\MySQL\MySQL Server 5.1\bin i renamed the file libmySQL.dll to libmySQL64.dll and copied the 32bit file into the directory instead. Then i ran the configuration wizard, and this time it worked.

After the configuration process was completed, delete the 32bit file from the directory and rename the file libmySQL64.dll back to libmySQL.dll.
..."

Regards,

Pedro
[21 Feb 2008 15:17] Tonci Grgin
Pedro, thanks for providing us with more info. As you can see, patch is pending and it will most probably be available in next release. I have already tested it and it works as expected.

Thanks for your interest in MySQL.
[26 Feb 2008 7:59] Tonci Grgin
Bug#34824 has been marked as duplicate of this one.
[26 Feb 2008 8:33] Sangeetha Manammal
Thanks Tonci,

I replaced "asAdministrator" to "requireAdministrator". But the problem still exists.
[26 Feb 2008 8:39] Sangeetha Manammal
And the error log looks like this:

Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="SideBySide" /> 
  <EventID Qualifiers="49409">63</EventID> 
  <Level>2</Level> 
  <Task>0</Task> 
  <Keywords>0x80000000000000</Keywords> 
  <TimeCreated SystemTime="2008-02-26T08:26:38.000Z" /> 
  <EventRecordID>4634</EventRecordID> 
  <Channel>Application</Channel> 
  <Computer>sangeetha-PC</Computer> 
  <Security /> 
  </System>
- <EventData>
  <Data>urn:schemas-microsoft-com:asm.v1^requestedPrivileges</Data> 
  <Data>level</Data> 
  <Data>requiresAdministrator</Data> 
  <Data /> 
  <Data /> 
  <Data /> 
  <Data /> 
  <Data /> 
  <Data /> 
  <Data /> 
  <Data>C:\MySQL\MySQL Server 5.0\bin\MySQLInstanceConfig.exe</Data> 
  <Data>C:\MySQL\MySQL Server 5.0\bin\MySQLInstanceConfig.exe</Data> 
  <Data>6</Data> 
  <Data /> 
  <Data /> 
  <Data /> 
  <Data /> 
  <Data /> 
  <Data /> 
  <Data /> 
  </EventData>
  </Event>
[26 Feb 2008 20:36] Gunnar Gudvardarson
To install MySQL Server 5.0.51a in Vista

1. Use mysql-essential-5.0.51a-win32.msi

2. Download and run Resource Hacker http://www.angusj.com/resourcehacker/
3. Open ...\MySQL Server 5.0\bin\MySQLInstanceConfig.exe with Resource Hacker
4. Navigate to 24\1\1033
5. Delete all text in the window
6. Press "Compile script"
7. Exit Resource Hacker and save the result (overwrite the initial MySQLInstanceConfig.exe)
8. Now MySQLInstanceConfig.exe should start normally.
[27 Feb 2008 8:17] Tonci Grgin
Gunnar, thanks for helping others and thanks for your interest in MySQL!
[1 Mar 2008 22:20] Sveta Smirnova
Bug #34974 was marked as duplicate of this one.
[17 Mar 2008 1:58] Ilan Ian
thanks Gunnar Gudvardarson 
I tried this steps and it works.
[26 Feb 21:36] Gunnar Gudvardarson
[17 Mar 2008 1:58] Ilan Ian
thanks Gunnar Gudvardarson 
I tried this steps and it works.
[26 Feb 21:36] Gunnar Gudvardarson
[17 Mar 2008 1:58] Ilan Ian
thanks Gunnar Gudvardarson 
I tried this steps and it works.
[26 Feb 21:36] Gunnar Gudvardarson
[31 Mar 2008 14:23] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=35686 was marked as duplicate of this
one.
[7 Apr 2008 21:43] Miguel Solorzano
Bug http://bugs.mysql.com/bug.php?id=35865 has been marked as duplicate
of this bug.
[12 Apr 2008 2:51] Paul Dubois
Noted in 5.1.24 changelog.

Manifest problems prevented MySQLInstanceConfig.exe from running on
Windows Vista.

Resetting report to Patch queued waiting for push into 6.0.x.
[22 Apr 2008 0:38] Jared S
Thanks! just download 5.1.24 and worked first time.
[5 May 2008 18:46] Paul Dubois
Noted in 6.0.5 changelog.
[14 Dec 2008 18:31] john schneider
Trying this fix tonight. Thanks for solution!