Bug #34559 MySQLInstanceConfig: side-by-side configuration is incorrect
Submitted: 14 Feb 2008 17:59 Modified: 19 Feb 2008 23:04
Reporter: Olaf van der Spek (Basic Quality Contributor) Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version: 5.1.23-rc OS:Microsoft Windows (Vista x64)
Assigned to: Assigned Account
Tags: qc
Triage: D2 (Serious)

[14 Feb 2008 17:59] Olaf van der Spek
Description:
Hi,

I installed MySQL 5.1.23 x64 on Vista x64. The installer didn't start the instance config and manually starting the instance config resulted in this error.

C:\Program Files\MySQL\MySQL Server 5.1\bin>MySQLInstanceConfig.exe
The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log for more detail.

How to repeat:
C:\Program Files\MySQL\MySQL Server 5.1\bin>MySQLInstanceConfig.exe
[14 Feb 2008 18:06] Olaf van der Spek
The x86 version is also affected:
C:\Program Files (x86)\MySQL\MySQL Server 5.1\bin>MySQLInstanceConfig.exe
The application has failed to start because its side-by-side configuration is in
correct. Please see the application event log for more detail.
[14 Feb 2008 19:40] Valerii Kravchuk
Thank you for a problem report. And what exactly does Event Log say? (I had installed 5.1.23 without any problems on XP SP2...)
[14 Feb 2008 20:05] Olaf van der Spek
It's quite helpful, I didn't expect that:
Activation context generation failed for "C:\Program Files (x86)\MySQL\MySQL Server 5.1\bin\MySQLInstanceConfig.exe".Error in manifest or policy file "C:\Program Files (x86)\MySQL\MySQL Server 5.1\bin\MySQLInstanceConfig.exe" on line 6. The value "asAdministrator" of attribute "level" in element "urn:schemas-microsoft-com:asm.v1^requestedPrivileges" is invalid.
[14 Feb 2008 20:46] Miguel Solorzano
Message Error on Vista 64-bit

Attachment: vista-config.png (image/png, text), 182.66 KiB.

[14 Feb 2008 20:48] Miguel Solorzano
Thank you for the bug report. Verified as described.
[15 Feb 2008 16:05] Sudarshan Thitte
Hi all,

I am a newcomer to this MySQL, and using Vista, I m having the same trouble. Can you help me solving it as I didn't understand the stuff written in this bug entry... Is there any solution to it as yet?
[15 Feb 2008 16:06] Sudarshan Thitte
Hi all,

I am a newcomer to this MySQL, and using Vista, I m having the same trouble. Can you help me solving it as I didn't understand the stuff written in this bug entry... Is there any solution to it as yet?

Thanks in advance!

Sudarshan
[15 Feb 2008 16:59] Chris Merrill
I have the same problem on 32bit Vista.  I installed MySQL 5.1 today.

Chris Merrill
[16 Feb 2008 21:21] Raj Grandhe
I have exact same problem. I am running 32-bit Vista. Any suggestions??
[17 Feb 2008 22:02] Dominic Oyeniran
Hi,

I am having the same problem with mysql-5.0.51a-win32 on windows vista business on a 32bit machine. I have opened up a port for mysql and also disabled the user access control. However, the side-by-side configuration error remains unresolved.

Has anyone cracked this or it's a bug in MySQL?

Cheers,
Dominic
[17 Feb 2008 23:08] Dominic Oyeniran
Hello everyone,

There is a posting on the install forum: http://forums.mysql.com/read.php?11,195569,195569#msg-195569 that solves the problem. It appears to be a small bug in the MySQLInstanceConfig executable.

It works for me.

Dominic
[19 Feb 2008 23:04] Iggy Galarza
Duplicate of Bug#30823
[3 Mar 2008 3:53] Russell Peltz
Are you kidding me?  I have to hack an executable to get the stupid thing to work?
[4 Mar 2008 2:27] Matthew Geise
FWIW - I did not run into this problem when I installed 5.0.37
[6 Mar 2008 14:35] Philip Parkin
Microsoft Windows Vista 32 - MySQL Server 5.0 - error MySQLInstanceConfig.exe - application failed to start because side-by-side configuration is incorrect :
[11 Mar 2008 21:03] Anas Rababah
the reshack soulution worked well for me
[17 Mar 2008 18:03] Alexander Proscurshim
reshack works...im just curious if the same can be done with 64x considering that reshack only works with 32bit
[21 Apr 2008 0:50] Luke ab
reshack method worked on Vista Business SP1
[21 Apr 2008 0:51] Luke ab
reshack method worked on Vista Business SP1 [ammend] forgot to mention this is vista business x64 (core 2 duo machine)[/ammend]