Bug #46865 Installation kit fails when installing on a PC an Amd CPU (Windows XP 64)
Submitted: 22 Aug 2009 16:03 Modified: 24 Aug 2009 6:32
Reporter: Antonis Lambrou Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S1 (Critical)
Version:6.0.4 OS:Microsoft Windows (XP64)
Assigned to: CPU Architecture:Any
Tags: Amd, XP64

[22 Aug 2009 16:03] Antonis Lambrou
Description:
Installation is failing when trying to be installed on a pc with AMD cpu (windows xp 64bit).

Error description on screen: 
Failed to open XML file c:\programs files(x86)\MySQL Connector Net 6.0.4\svctag.xml 
system error: -2147024786

Although the XML file exist, due to some "special characters" (non ASCII) inside, can not be opened (see below the tag with the non-ascii chars
<cpuManufacturer>⟘thenticAMDAuthenticAMD,AuthenticAMD,AuthenticAMD</cpuManufacturer>

Please note that version 6.1x is not failing, and this tag in xml is correct.

Somehow the cpuManufactarer is not returned correctly in this version...

How to repeat:
Run mysql.data.msi on a pc with an AMD CPU

An error screen will appear and the installation will be terminated
[22 Aug 2009 16:08] Antonis Lambrou
Error screenshot

Attachment: Bug46865.gif (image/gif, text), 18.20 KiB.

[24 Aug 2009 6:32] Tonci Grgin
Please do not submit the same bug more than once. An existing bug report already describes this very problem. Even if you feel that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments to the original bug instead.

Thank you for your interest in MySQL.

Explanation: Hi Antonis. Your report is a duplicate of Bug#45474, Bug#45477, Bug#46257, Bug#46831 and so on...