Bug #45474 Connector NET 6.0.4 installer fails
Submitted: 12 Jun 2009 16:34 Modified: 4 Aug 2009 10:12
Reporter: Kendrick Hang Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / NET Severity:S3 (Non-critical)
Version:6.0.4 OS:Microsoft Windows (XP SP2)
Assigned to: Reggie Burnett CPU Architecture:Any

[12 Jun 2009 16:34] Kendrick Hang
Description:
Running the installer on MySQL Connector Net 6.0.4, I get a failure. Error dialog message reads, "There is a problem with this Windows Installer package. A DLL is required for this install to complete could not be run. Contact your support personnel or package vendor." Clicked OK to acknowledge the error, installer then exits.

How to repeat:
Re-run installer. I re-ran the installer and the same error occurred again. Difficult to tell which dll is missing.
[12 Jun 2009 16:47] Kendrick Hang
I just tried installing Connector NET 6.0.3 -- luckily had a copy because I wasn't able to find 6.0.3 on the website any more. I ran the installer for 6.0.3 on the same computer and it ran without any errors.

I suspect something has changed between 6.0.3 and 6.0.4, either in the installer, or in one of the dependencies to cause this error.
[12 Jun 2009 17:38] Reggie Burnett
What else is installed on that box that failed?  Any version of VS?  .NET 2.0?
[12 Jun 2009 17:57] Kendrick Hang
Great question -- I should have included that info earlier. The workstation has both of the following installed:

- Visual Studio 2005 version 8.0.50727.42 with .NET version 2.0.50727 SP2
- Visual Studio 2008 version 9.0.30729.1 SP with .NET version 3.5 SP1

Both Visual Studio versions are Professional Edition, installed with the Typical options selected from their respective installers.
[12 Jun 2009 19:27] Reggie Burnett
DOes the install get to the last page (the finish page)?  If so, can you retry and clear the registration checkbox on the last page?
[12 Jun 2009 19:46] Reggie Burnett
Kendrick

I can't reproduce it here.  Can you try the install again and send me the log?  You would do this from a command prompt and try the install with this command

msiexec /l* setup.log /i mysql.data.msi

and then attach the setup.log to this bug report
[12 Jun 2009 20:17] Kendrick Hang
Just attached the log from the installer. To answer your previous question, when I encounter the error, the installer does not allow me to go any further. It exits right there and I do not make it to the finish page.
[15 Jun 2009 6:42] Tonci Grgin
Hi Kendrick. Can you please try updating MSI installer to, at least, version 3.1 v2 and retest. Currently, you're using 3.01: Property(S): VersionMsi = 3.01. Also, do check MD5 of c/NET msi to be sure download was not corrupted.

Downloads:
3.1(v2): http://www.microsoft.com/downloads/details.aspx?familyid=889482FC-5F56-4A38-B838-DE776FD41...
4.5: http://www.microsoft.com/downloads/details.aspx?familyid=5A58B56F-60B6-4412-95B9-54D056D6F...

Inform me of result.
[20 Jun 2009 9:26] Tonci Grgin
Kendrick, is this still a problem? I just installed c/NET 6.0.4 on a very similar box, only mine is W2K8SE server x64.
[1 Jul 2009 17:46] Mike Leonard
I guess comments and files don't work together.

I don't think #45477 is a duplicate, unless both errors are being caused by the same thing.

I've upgraded, as recommended, to v4.5 of the installer and still get the svctab.xml error.

The setup.log is above.
[1 Jul 2009 18:05] Kendrick Hang
Hi Tonci,

Apologies for not being able to get back to you on this sooner. I'm not going to be able to update my Windows Installer version here -- I need to keep this baseline version of Windows Installer on my machine.

I'm thinking this just could be a problem with something in my local configuration here. I was able to find an older installer for the previous version, 6.0.3 and that installs perfectly on my machine. On another similarly configured box here, I was able to install 6.0.4 without issue, which leads me to think there is something wrong with my machine's configuration. I am comfortable using a workaround for now.

I appreciate your team looking into this. This seems like one of those minor, yet grudgingly difficult to find bugs to isolate. I'll stand by and I can work around it for now -- and I will downgrade the priority of this bug report.

Ken
[13 Jul 2009 19:32] MySQL Verification Team
http://forums.mysql.com/read.php?38,267731,267731#msg-267731
[29 Jul 2009 23:58] Leon de Almeida
I hope I can shed some light on someone who'll be able to finally end this issue :)

Platform: lenovo T61 notebook, Windows XP Pro SP2, 2Gb RAM, 120 Gb disk, Visual Studio
2008, .NET Framework 3.5 SP1, Microsoft Installer 4.5, no MySQL server on this machine. I
recommend Notepad++ installed. See steps below for reasoning.

The problem I had was the same described: svctag.xml can't be opened/found/whatever.

I today managed to run the install by performing the following steps:

1. Run the installation normally until you get to the svctag.xml issue screen.
2. DO NOT click OK. Leave the window open, go to the specified folder on the message -
there you'll find the svctag.xml file.
3. Open it with a text editor (I used Notepad++ which shows non-standard chars).
4. Find the <cpuManufacturer>(...)</cpuManufacturer> tag.
5. Probably, the text inside the tags will have two special characters (on my machine, one
Chinese character and another symbol I do not remember - note I was using Notepad++: if
you're using Notepad, you'll probably see two squares or two spaces)
6. Remove those characters. In my computer, I had (symbol)(symbol)nuineIntelGenuineIntel,
so replaced them with Ge (fixing the wording for Genuine Intel).
7. Save. Leave the file open on the editor (this is where things might get tricky -
Notepad++ can make a difference since it leaves the file open in memory but keeps track of
it on the HD, so when it was deleted by the second installer instance, it notified me)
8. Start another Connector installation instance. Proceed with the install. You'll get a
notification stating another instance of the installation is running and that it should be
finished first.
9. Go to the first instance and hit 'OK' now. It will roll back.
10. Go to the second instance.  Notepad++ will notify you that the file (1) was not on the
disk anymore - when you get that, answer YES to keep the file on the editor.
11. Go back to the installer. You'll probably get a message from the installer stating
there was some error while trying to update the XML configuration files. Click OK and the
installation should finish properly.

My guess is that when the installer reads the CPU Manufacturer from wherever it gets the
data from, it starts reading two (or more) bytes before the place it really should and
then it ends up overwriting the first two letters of the CPU Manufacturer name. There's
one post above that shows the syntax error found on Opera. This concurrs with the fix I
applied today. CPU Manufacturer line is #11.

My svctag.xml file, when the installation was finally successful has no data in it:

<?xml version="1.0" encoding="UTF-8"?>
<registration_data version="1.0">
  <environment>
    <hostname></hostname>
    <hostId />
    <osName></osName>
    <osVersion></osVersion>
    <osArchitecture></osArchitecture>
    <systemModel></systemModel>
    <systemManufacturer></systemManufacturer>
    <cpuManufacturer></cpuManufacturer>
    <serialNumber></serialNumber>
  </environment>
  <registry version="1.0">
    <service_tag>
      <instance_urn></instance_urn>
      <product_name></product_name>
      <product_version></product_version>
      <product_urn></product_urn>
      <product_parent_urn></product_parent_urn>
      <product_parent>N/A</product_parent>
      <product_defined_inst_id></product_defined_inst_id>
      <product_vendor></product_vendor>
      <platform_arch>Windows</platform_arch>
      <timestamp></timestamp>
      <container />
      <source></source>
      <installer_uid>-1</installer_uid>
    </service_tag>
  </registry>
</registration_data>

There. My 2 cents
[30 Jul 2009 7:36] Tonci Grgin
Thanks for workaround Leon.

Kendrick, I too think this is very machine-specific. I will consult once more today and, if none sees where the problem might be, I'll have to close the report as CRp.
[31 Jul 2009 11:12] Tonci Grgin
Seemingly, we've found an environment that exhibits this error. Problem is in process of fixing.
[3 Aug 2009 16:37] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/79913

736 Reggie Burnett	2009-08-03
      - fixed 'can't find svctag.xml' installer bug (thanks Iggy!)  (bug #45474)
[3 Aug 2009 16:52] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/79920

738 Reggie Burnett	2009-08-03
      fixed 'can't find svctag.xml' installer bug (thanks Iggy!)  (bug #45474)
[3 Aug 2009 17:28] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/79932

738 Reggie Burnett	2009-08-03
      fixed 'can't find svctag.xml' installer bug (thanks Iggy!)  (bug #45474)
[3 Aug 2009 17:41] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/79943

740 Reggie Burnett	2009-08-03
      fixed 'can't find svctag.xml' installer bug (thanks Iggy!)  (bug #45474)
[3 Aug 2009 17:43] Reggie Burnett
fixed in 6.0.5 and 6.1.1
[4 Aug 2009 10:12] Tony Bedford
An entry was added to the 6.0.5 and 6.1.1 changelogs:

The MySQL Connector/NET 6.0.4 installer failed with an error. The error message generated was:

There is a problem with this Windows Installer package. A DLL required for this
install to complete could not be run. Contact your support personnel or package vendor.
When OK was clicked to acknowledge the error the installer exited.
[24 Aug 2009 6:33] Tonci Grgin
Bug#46865 has been marked as duplicate of this report.