Bug #45477 .Net connector 6.0.4 installation fail
Submitted: 12 Jun 2009 17:54 Modified: 26 Jun 2009 7:22
Reporter: Thomas Almnes Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S1 (Critical)
Version:6.0.4 OS:Microsoft Windows (XP proff. SP3 on VMWare)
Assigned to: CPU Architecture:Any
Tags: connector, fail, intall

[12 Jun 2009 17:54] Thomas Almnes
Description:
Installation fails on version 6.0.4.
After selecting any install option, an error dialog says

"failed to open the XML file at C:\program files\mysql\mysql connector net 6.0.4\svctag.xml. system error -2147024786"

If I open the explorer I acctually find the svctag.xml in the metioned folder.

System:
XP proff. SP3 on VMWare
.Net 3.5 SP1
Visual studio 2008 SP1

How to repeat:
Fail occurs every time normal install procedure is executed
[12 Jun 2009 19:23] Reggie Burnett
This is a duplicate of bug #45474
[12 Jun 2009 19:26] Reggie Burnett
Thomas

Does the install get to the last dialog?  If so, retry the install and clear the registration checkbox on the last page.
[12 Jun 2009 19:46] Reggie Burnett
Thomas

I can't reproduce it here.  Can you try the install again and send me the log?  You would do this from a command prompt and try the install with this command

msiexec /l* setup.log /i mysql.data.msi

and then attach the setup.log to this bug report
[12 Jun 2009 21:09] Thomas Almnes
I get to the last dialog. It starts intalling. It seems like the last status on install is "registering...". Then the fail dialog and a rollback. I have attached the install log.
[12 Jun 2009 21:09] Thomas Almnes
setup.log

Attachment: setup.log (application/octet-stream, text), 81.74 KiB.

[13 Jun 2009 6:15] Mark Blackburn
I am having this exact same problem and it looks as though I have a similar setup as the original poster(both VS 2005 and VS 2008 SP1 (Trial version) installed) I seem to be getting to the exact same stage in the install as the the other person.  I have Mysql 5.1 installed.  I was able to install the 5.1.7 .NET connector but I have not gotten it to work in VS 2008.  So I uninstalled 5.1.7 and have tried to install 6.0.4 but it always fails with the exact error message reported in the original post.  
If you have any suggestions on how I can install 6.0.4 I would be grateful.  I would be willing to manually install the files and configure/register myself if I had some instructions on how to do this. 

Thank you in advance for any help you are able to provide.
[13 Jun 2009 6:45] Thomas Almnes
Just a remark to [13 Jun 8:15] Mark Blackburn

I successfully installed the 5.7. connector and got it to work in VS2008 SP1. However, I need the 6th version since I am using the ADO.NET entity framework.

If someone could directy me in installing the connector manually, I could try that.
[13 Jun 2009 7:02] Mark Blackburn
Wow thank you for the quick response, Thomas! =)

Yeah I would like use the ADO.Net framework as well so I need to solve this too.  

I would even be fine with a 6.0.3 or 6.0.2 install if I could get a hold of one of the install packages.
Again thank you for the input and I look forward to finding a solution or workaround to the 6.0.4 connector install.
[13 Jun 2009 16:48] Mark H.
Hi:

I'm experiencing the same error (can't open the XML file then it reverses). 

Connector 6.0.4 MSI
Windows XP Pro
MySQL 5.1
Visual Studio 2005
Visual Studio 2008

Thanks in advance!
[15 Jun 2009 2:16] Mark Blackburn
I have figured out a way to fix the problem on my system and was able to successfully complete the installation process for the 6.0.4 connector.  I am not exactly sure how I did it. However, I do know that it was related to one or more system updates I performed.  

Basically, in the course of trying to fix some internet explorer bugs I was experiencing, I decided to do some microsoft updates. As it turns out, I had been very remiss in updating this computer so I had to apply a number of patches to it.  The 1st one I applied was Service Pack 3 for XP. I had avoided applying SP3 a while ago because I was afraid of having another spat of problems with existing applications like I had when SP2 came out and seemed to break a lot of things. 

After realizing that since I had forgotten about SP3 I was probably also missing other updates so I went to the Microsoft windows updates website and let it do all the updates it recommended.  In the course of doing all this updating, I thought " hmmm. I wonder if this will affect that 6.0.4 connector install problem" so I decided to take a screen shot of the 2nd batch of updates I was applying in the event that one of them might fix the problem. 

So basically, here is the sequence of updates I performed which ultimately fixed the connector install problem

1) Windows XP, SP3
2) 7-8 security updates (Sorry but I dont know exactly which ones)
3) Microsoft .NET Framework 3.5 SP 1 and family update for versions 2.0 thru 3.5 ( KB 951847)
4) Internet Explorer 8 ( I previously had version 6 so I had been wayyy out of date) 
5) Security Update for Windows Xp ( KB938464)
6) Security Update for Windows Xp ( KB954459)
7) Update for Windows XP (KB951978)

So unfortunately I do not know exactly which one of these fixed my connector install problem but it definitely was one (or more of these). If I had to guess, the top suspects would be XP SP1, IE 8, or the .NET framework SP1
Basically, my assumption is that the MSI installer package for the 6.0.4. connector relies on one or more the system components that these updates provided.

After I installed the connector successfully, I loaded vs2008 and tested to make sure I had connectivity to MySQL and it worked perfectly. It was listed as a data source option and everything seems to be working like it should. 

Im sorry this post is so long but I was helping that my experience might help a few of you to solve this problem as well.  Probably the best place to start is to just go to http://windowsupdate.microsoft.com and check for updates.

I hope this helps =)
[15 Jun 2009 7:34] Thomas Almnes
Thanks Mark!
Better with long submission than none!

The only problem on my part is that I already have all that you say that you updated to. My XP install is fresh. I have no other things installed besides the developer environment (since I am setting this up to be a dev. appliance in vmware). The system went online about an hour earlier than when I submitted this bug..
[16 Jun 2009 2:06] Mark Blackburn
Well I'm sorry to hear that my post didnt help =(.  I am wondering if the problem on your test machine is that it is missing some component that I may have on mine but that was not listed in my earlier post.  I do have a lot of things installed on this machine so it would be difficult to tell.  However, since our problems seemed so similar, it might be worth trying to install a few other things on that machine to see if it changes the 6.0.4 installer outcome. I know this can be a pain though so I feel kind of bad even suggesting it.  All I know is one or more of the updates I performed definitely fixed the problem. 

I wish there was more I could say to help. Feel free to ask me any questions if you think it might help your debugging process.

Good luck,
Mark B
[17 Jun 2009 2:01] Lianto Lim
I have the same problem, and did the updates as Mr. Mark Blackburn said (XP SP3 and a few windows updates). Now the installation run smoothly. Thanks Mark.
[24 Jun 2009 17:35] Pavel Boček
I have the same problem with XP x86-64 (x64 according to MS) SP2 with all updates and Internet Explorer 6.0. Any sollution yet ?
[25 Jun 2009 13:39] Praveen Ladwani
Hi Everyone, 

A simpler approach to solve this problem would be to:

1. Go to Windows Task Manager
2. Switch to the Processes Tab
3. End the mysqld process
4. Try to install MySQL Connector/NET 6.0.4
5. Installation should complete without any problems

Let me know if this works for you.

Best Regards
Praveen Ladwani
http://www.mediaarcade.net
[25 Jun 2009 22:39] Mark Blackburn
To [24 Jun 19:35] Pavel Boček 

Pavel, perhaps it is IE 6.0 that is your problem. I was not able to install the connecter until I upgraded to 8.0 ( and upgraded other items as previously listed)  Can you upgrade to IE 8.0 then test the connector install?

Hope this helps,
Mark
[26 Jun 2009 7:22] Thomas Almnes
note to Praveen: I have no database server on this machine. MySQL is installed on a different machine, which I am trying to reach/use.

t.
[28 Jun 2009 9:08] Pavel Boček
Installation was fine on second computer (XP SP3, IE6)...I can try to install IE7/8, but I really don't like theese versions...
[28 Jun 2009 10:59] Pavel Boček
No change with IE8. The problem seems to be with that svctag.xml file. If i try to open it via Opera. i get syntactit error on line 11:

 8:     <osArchitecture>AMD64</osArchitecture>
  9:     <systemModel></systemModel>
 10:     <systemManufacturer></systemManufacturer>
 11:     <cpuManufacturer>⁠\19thenticAMDAuthenticAMD</cpuManufacturer>
 12:     <serialNumber>None</serialNumber>
 13:   </environment>
 14:   <registry version="1.0" urn="urn:st:uuid:b7a2a7f2-d465-49fd-b2e2-a4db6af3f153">

Notepad sees two characters "". On K7 system (XP SP3), it works fine, this is K8 XP x64 SP2, overlocked. May it be due to the overclocking which makes problems with recognizing CPU ?
[28 Jun 2009 12:22] Pavel Boček
Setting CPU to default did not help.
[30 Jun 2009 9:45] Michael Riggs
As mentioned on #45474, upgrading your Windows Installer to version 4.5 resolves this issue: http://www.microsoft.com/downloads/details.aspx?familyid=5A58B56F-60B6-4412-95B9-54D056D6F...
[1 Jul 2009 17:37] Mike Leonard
Installer 4.5 didn't change anything for me.
[3 Jul 2009 16:27] Søren S. Mikkelsen
No -- no improvement by installing the 4.5 version Installer for me eihter,
[6 Jul 2009 21:02] Pavel Boček
I've already tried it, but no change. Same error this time.
[12 Jul 2009 15:30] Søren S. Mikkelsen
Finally I think I cracked the nut.
Aparently when using VMware on a 2 core processor machine, installation will only work when the VMware image used is set to use only one virtual processor.
So... the workaround to make the installation succeed on a 2 core processor is to shut down the vmware image, enter settings in vmware for the given vmware image, and temporarely switching the image to "1 Virtual Processor". 

Worked 4 me on my macbook pro. Hope the same is the case for the rest of you.
[24 Jul 2009 13:31] Leon de Almeida
I hope I can shed some light on someone who'll be able to finally end this issue :)

Platform: lenovo T61 notebook, Windows XP Pro SP2, 2Gb RAM, 120 Gb disk, Visual Studio 2008, .NET Framework 3.5 SP1, Microsoft Installer 4.5, no MySQL server on this machine. I recommend Notepad++ installed. See steps below for reasoning.

The problem I had was the same described: svctag.xml can't be opened/found/whatever.

I today managed to run the install by performing the following steps:

1. Run the installation normally until you get to the svctag.xml issue screen.
2. DO NOT click OK. Leave the window open, go to the specified folder on the message - there you'll find the svctag.xml file.
3. Open it with a text editor (I used Notepad++ which shows non-standard chars).
4. Find the <cpuManufacturer>(...)</cpuManufacturer> tag.
5. Probably, the text inside the tags will have two special characters (on my machine, one Chinese character and another symbol I do not remember - note I was using Notepad++: if you're using Notepad, you'll probably see two squares or two spaces)
6. Remove those characters. In my computer, I had (symbol)(symbol)nuineIntelGenuineIntel, so replaced them with Ge (fixing the wording for Genuine Intel).
7. Save. Leave the file open on the editor (this is where things might get tricky - Notepad++ can make a difference since it leaves the file open in memory but keeps track of it on the HD, so when it was deleted by the second installer instance, it notified me)
8. Start another Connector installation instance. Proceed with the install. You'll get a notification stating another instance of the installation is running and that it should be finished first.
9. Go to the first instance and hit 'OK' now. It will roll back.
10. Go to the second instance.  Notepad++ will notify you that the file (1) was not on the disk anymore - when you get that, answer YES to keep the file on the editor.
11. Go back to the installer. You'll probably get a message from the installer stating there was some error while trying to update the XML configuration files. Click OK and the installation should finish properly.

My guess is that when the installer reads the CPU Manufacturer from wherever it gets the data from, it starts reading two (or more) bytes before the place it really should and then it ends up overwriting the first two letters of the CPU Manufacturer name. There's one post above that shows the syntax error found on Opera. This concurrs with the fix I applied today. CPU Manufacturer line is #11.

My svctag.xml file, when the installation was finally successful has no data in it:

<?xml version="1.0" encoding="UTF-8"?>
<registration_data version="1.0">
  <environment>
    <hostname></hostname>
    <hostId />
    <osName></osName>
    <osVersion></osVersion>
    <osArchitecture></osArchitecture>
    <systemModel></systemModel>
    <systemManufacturer></systemManufacturer>
    <cpuManufacturer></cpuManufacturer>
    <serialNumber></serialNumber>
  </environment>
  <registry version="1.0">
    <service_tag>
      <instance_urn></instance_urn>
      <product_name></product_name>
      <product_version></product_version>
      <product_urn></product_urn>
      <product_parent_urn></product_parent_urn>
      <product_parent>N/A</product_parent>
      <product_defined_inst_id></product_defined_inst_id>
      <product_vendor></product_vendor>
      <platform_arch>Windows</platform_arch>
      <timestamp></timestamp>
      <container />
      <source></source>
      <installer_uid>-1</installer_uid>
    </service_tag>
  </registry>
</registration_data>

There. My 2 cents.
[8 Oct 2009 9:21] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/86105

3096 jack andrews	2009-10-08
      bug #45477 port cpcd to windows.
       . rename cpcd to ndb_cpcd in CMakeLists.txt
[8 Oct 2009 9:35] Bugs System
Pushed into 5.1.39-ndb-7.0.9 (revid:jack@asus-20091008092953-q708k20ztt4ojymm) (version source revid:jack@asus-20091008092953-q708k20ztt4ojymm) (merge vers: 5.1.39-ndb-7.0.9) (pib:11)
[8 Oct 2009 12:39] Bugs System
Pushed into 5.1.39-ndb-7.1.0 (revid:frazer@mysql.com-20091008123055-04p00c7sltllb92o) (version source revid:frazer@mysql.com-20091008123055-04p00c7sltllb92o) (merge vers: 5.1.39-ndb-7.1.0) (pib:11)