Bug #46010 main.ctype_gbk_binlog fails sporadically : Table 't2' already exists
Submitted: 7 Jul 2009 14:03 Modified: 15 Sep 2009 7:19
Reporter: Georgi Kodinov Email Updates:
Status: Duplicate Impact on me:
None 
Category:Tests: Replication Severity:S3 (Non-critical)
Version:5.1-bugteam OS:Solaris (sol10-x86_64)
Assigned to: Assigned Account CPU Architecture:Any
Tags: experimental, pb2, sporadic, test failure, tf54

[7 Jul 2009 14:03] Georgi Kodinov
Description:
main.ctype_gbk_binlog                    w6 [ fail ]
        Test ended at 2009-07-07 12:35:56

CURRENT_TEST: main.ctype_gbk_binlog
ERROR 1050 (42S01) at line 18: Table 't2' already exists
mysqltest: At line 30: command "$MYSQL_BINLOG --force-if-open --short-form $MYSQLD_DATADIR/master-bin.000001 | $MYSQL" failed

Output from before failure:
exec of '/export/home/pb2/test/sb_7-629352-1246959866.93/mysql-5.1.37-solaris10-i386-test/bin/mysqlbinlog --defaults-file=/export/home/pb2/test/sb_7-629352-1246959866.93/mysql-5.1.37-solaris10-i386-test/mysql-test/var/6/my.cnf --force-if-open --short-form /export/home/pb2/test/sb_7-629352-1246959866.93/mysql-5.1.37-solaris10-i386-test/mysql-test/var/6/mysqld.1/data//master-bin.000001 | /export/home/pb2/test/sb_7-629352-1246959866.93/mysql-5.1.37-solaris10-i386-test/bin/mysql --defaults-file=/export/home/pb2/test/sb_7-629352-1246959866.93/mysql-5.1.37-solaris10-i386-test/mysql-test/var/6/my.cnf' failed, error: 256, status: 1, errno: 29

How to repeat:
run test on solaris enough times.

Suggested fix:
n/a. see related bug #45578
[7 Jul 2009 14:11] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/78139

3008 Georgi Kodinov	2009-07-07
      Bug #45578, Bug #46010, Bug #45576 : made the failing tests experimental
[2 Sep 2009 11:10] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/82202

3084 Li-Bing.Song@sun.com	2009-09-02
      Bug#46010  main.ctype_gbk_binlog fails sporadically : Table 't2' already exists
      
      This test case uses mysqlbinlog to dump the content of master-bin.000001,
      but the content of master-bin.000001 is not that this test needs.
      
      MTR runs a lot of test cases on one server, so the postion of this test's binlog
      is not sure if some tests has wrote binlog before it.
      So 'RESET MASTER' comand must be called at the begin, it ensures that binlog of this test
      is wrote to master-bin.000001 correctly.  
      
      Three other tests have the same problem, They were fixed together.
      mysqlbinlog-cp932
      binlog_incident
      binlog_tmp_table
[7 Sep 2009 5:45] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/82544
[7 Sep 2009 8:51] Libing Song
Pushed to mysql-5.1-bug-team and mysql-pe
[14 Sep 2009 16:04] Bugs System
Pushed into 5.4.4-alpha (revid:alik@sun.com-20090914155317-m1g9wodmndzdj4l1) (version source revid:alik@sun.com-20090914155317-m1g9wodmndzdj4l1) (merge vers: 5.4.4-alpha) (pib:11)
[14 Sep 2009 20:30] Alfranio Tavares Correia Junior
Duplicate of BUG#46209.
[6 Oct 2009 9:00] Bugs System
Pushed into 5.1.40 (revid:joro@sun.com-20091006073316-lea2cpijh9r6on7c) (version source revid:mikael@mysql.com-20090907102257-fflwgm6rp5m5kmfw) (merge vers: 5.1.39) (pib:11)
[18 Dec 2009 10:32] Bugs System
Pushed into 5.1.41-ndb-7.1.0 (revid:jonas@mysql.com-20091218102229-64tk47xonu3dv6r6) (version source revid:jonas@mysql.com-20091218095730-26gwjidfsdw45dto) (merge vers: 5.1.41-ndb-7.1.0) (pib:15)
[18 Dec 2009 10:48] Bugs System
Pushed into 5.1.41-ndb-6.2.19 (revid:jonas@mysql.com-20091218100224-vtzr0fahhsuhjsmt) (version source revid:jonas@mysql.com-20091217101452-qwzyaig50w74xmye) (merge vers: 5.1.41-ndb-6.2.19) (pib:15)
[18 Dec 2009 11:03] Bugs System
Pushed into 5.1.41-ndb-6.3.31 (revid:jonas@mysql.com-20091218100616-75d9tek96o6ob6k0) (version source revid:jonas@mysql.com-20091217154335-290no45qdins5bwo) (merge vers: 5.1.41-ndb-6.3.31) (pib:15)
[18 Dec 2009 11:18] Bugs System
Pushed into 5.1.41-ndb-7.0.11 (revid:jonas@mysql.com-20091218101303-ga32mrnr15jsa606) (version source revid:jonas@mysql.com-20091218064304-ezreonykd9f4kelk) (merge vers: 5.1.41-ndb-7.0.11) (pib:15)
[10 Feb 2010 10:38] Luis Manuel Oliveira Soares
The test case is still listed in default.experimental in mysql-trunk
(revid:alik@sun.com-20100209101036-copgamva3qvs4cc8)

"main.ctype_gbk_binlog  @solaris          # Bug#46010: main.ctype_gbk_binlog fails sporadically : Table 't2' already exists"

Please fix this.