Bug #46209 binlog_tmp_table fails sporadically: missing rows in result
Submitted: 15 Jul 2009 16:25 Modified: 14 Sep 2009 21:08
Reporter: Sven Sandberg Email Updates:
Status: Duplicate Impact on me:
None 
Category:Tests: Replication Severity:S7 (Test Cases)
Version:5.1+ OS:Any
Assigned to: Alfranio Tavares Correia Junior CPU Architecture:Any
Tags: binlog_tmp_table, pushbuild, sporadic, test failure

[15 Jul 2009 16:25] Sven Sandberg
Description:
binlog_tmp_table fails sporadically with the following result mismatch in pb2:

test ended at 2009-07-14 23:07:48
current_test: binlog.binlog_tmp_table
--- /export/home/pb2/test/sb_6-643569-1247604121.34/mysql-5.1.38-linux-x86_64-test/mysql-test/suite/binlog/r/binlog_tmp_table.result 2009-07-14 23:37:33.000000000 +0300
+++ /export/home/pb2/test/sb_6-643569-1247604121.34/mysql-5.1.38-linux-x86_64-test/mysql-test/suite/binlog/r/binlog_tmp_table.reject 2009-07-15 00:07:48.000000000 +0300
create table foo (a int);
select * from foo;
a
-5
-7
-6
-8
drop table foo;
mysqltest: result length mismatch
- saving '/export/home/pb2/test/sb_6-643569-1247604121.34/mysql-5.1.38-linux-x86_64-test/mysql-test/var/7/log/binlog.binlog_tmp_table/' to '/export/home/pb2/test/sb_6-643569-1247604121.34/mysql-5.1.38-linux-x86_64-test/mysql-test/var/log/binlog.binlog_tmp_table/'
retrying test, attempt(2/3)...

How to repeat:
See http://tinyurl.com/n62jsr
[20 Aug 2009 9:43] Andrei Elkin
Bug #45578 can relate.
[7 Sep 2009 1:41] Alfranio Tavares Correia Junior
Apparently, it will be fixed after BUG#46010 and BUG#45578.
[14 Sep 2009 20:29] Alfranio Tavares Correia Junior
Duplicate of BUG#46010 and BUG#45578.