Bug #45578 Test binlog_tmp_table fails ramdonly on PB2: Unknown table 't2'
Submitted: 18 Jun 2009 5:58 Modified: 2 Mar 2010 15:31
Reporter: Zhenxing He Email Updates:
Status: Closed Impact on me:
None 
Category:Tests: Replication Severity:S3 (Non-critical)
Version:5.1,5.4 OS:Any
Assigned to: Libing Song
Tags: experimental, pb2, sporadic, test, test failure, tf54
Triage: Triaged: D3 (Medium)

[18 Jun 2009 5:58] Zhenxing He
Description:
Test binlog_tmp_table fails on PB2 with following error:

CURRENT_TEST: binlog.binlog_tmp_table
ERROR 1051 (42S02) at line 22: Unknown table 't2'
mysqltest: At line 79: command "$MYSQL_BINLOG $MYSQLD_DATADIR/master-bin.000002 | $MYSQL" failed

How to repeat:
check the following url:

http://pb2.norway.sun.com/web.py?action=archive_download&archive_id=589743&pretty=please

Suggested fix:
The test should call 'reset master' at the beginning of the test to make sure the binlog file is reset to master-bin.0000001.
[7 Jul 2009 14:11] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/78139

3008 Georgi Kodinov	2009-07-07
      Bug #45578, Bug #46010, Bug #45576 : made the failing tests experimental
[20 Aug 2009 9:43] Andrei Elkin
Bug #46209 can relate.
[24 Aug 2009 16:00] Andrei Elkin
A fresh occurrence:
http://pb2.norway.sun.com/web.py?template=mysql_show_test_failure&test_failure_id=2286325
[10 Sep 2009 3:55] Libing Song
This bug has been fixed by the patch for BUG#46010
[14 Sep 2009 20:29] Alfranio Correia
Duplicate of BUG#46209.
[15 Sep 2009 7:20] Jon Stephens
More correctly, BUG#46010 and BUG#46209 are duplicates of this bug. :)
[13 Oct 2009 2:27] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/86621

3162 Li-Bing.Song@sun.com	2009-10-13
      Bug#45578: Test binlog_tmp_table fails ramdonly on PB2: Unknown table 't2'
      
      The bug has been closed.
[14 Oct 2009 14:39] Bugs System
Pushed into 5.1.41 (revid:joro@sun.com-20091014143611-cphb0enjlx6lpat1) (version source revid:satya.bn@sun.com-20091013071829-zc4c3go44j6re592) (merge vers: 5.1.40) (pib:13)
[14 Oct 2009 17:23] Jon Stephens
Bug was already closed, and was a testing issue only.

Set status back to Closed.
[22 Oct 2009 6:35] Bugs System
Pushed into 6.0.14-alpha (revid:alik@sun.com-20091022063126-l0qzirh9xyhp0bpc) (version source revid:alik@sun.com-20091019135554-s1pvptt6i750lfhv) (merge vers: 6.0.14-alpha) (pib:13)
[22 Oct 2009 7:07] Bugs System
Pushed into 5.5.0-beta (revid:alik@sun.com-20091022060553-znkmxm0g0gm6ckvw) (version source revid:alik@sun.com-20091019131708-bc6pv55x6287a0wc) (merge vers: 5.5.0-beta) (pib:13)
[22 Oct 2009 15:11] Jon Stephens
Re-closed; see previous comments.
[18 Dec 2009 10:34] Bugs System
Pushed into 5.1.41-ndb-7.1.0 (revid:jonas@mysql.com-20091218102229-64tk47xonu3dv6r6) (version source revid:jonas@mysql.com-20091218095730-26gwjidfsdw45dto) (merge vers: 5.1.41-ndb-7.1.0) (pib:15)
[18 Dec 2009 10:50] Bugs System
Pushed into 5.1.41-ndb-6.2.19 (revid:jonas@mysql.com-20091218100224-vtzr0fahhsuhjsmt) (version source revid:jonas@mysql.com-20091217101452-qwzyaig50w74xmye) (merge vers: 5.1.41-ndb-6.2.19) (pib:15)
[18 Dec 2009 11:05] Bugs System
Pushed into 5.1.41-ndb-6.3.31 (revid:jonas@mysql.com-20091218100616-75d9tek96o6ob6k0) (version source revid:jonas@mysql.com-20091217154335-290no45qdins5bwo) (merge vers: 5.1.41-ndb-6.3.31) (pib:15)
[18 Dec 2009 11:19] Bugs System
Pushed into 5.1.41-ndb-7.0.11 (revid:jonas@mysql.com-20091218101303-ga32mrnr15jsa606) (version source revid:jonas@mysql.com-20091218064304-ezreonykd9f4kelk) (merge vers: 5.1.41-ndb-7.0.11) (pib:15)
[19 Dec 2009 10:14] Jon Stephens
Closed. See my previous comments.
[10 Feb 2010 10:33] Luis Soares
Reopening the bug. The test case is still listed in default.experimental in mysql-trunk (revid:alik@sun.com-20100209101036-copgamva3qvs4cc8).

"binlog.binlog_tmp_table*                 # Bug#45578:2009-07-10 alik Test binlog_tmp_table fails ramdonly on PB2: Unknown table 't2'"

Also, please remove the:

"main.ctype_gbk_binlog  @solaris          # Bug#46010: main.ctype_gbk_binlog fails sporadically : Table 't2' already exists"

BUG#46010 is marked as duplicate of this one, but the test case is still listed as experimental as well.

Please fix this and re-close the bug.
[10 Feb 2010 10:33] Luis Soares
Reopening the bug. The test case is still listed in default.experimental in mysql-trunk (revid:alik@sun.com-20100209101036-copgamva3qvs4cc8).

"binlog.binlog_tmp_table*                 # Bug#45578:2009-07-10 alik Test binlog_tmp_table fails ramdonly on PB2: Unknown table 't2'"

Also, please remove the:

"main.ctype_gbk_binlog  @solaris          # Bug#46010: main.ctype_gbk_binlog fails sporadically : Table 't2' already exists"

BUG#46010 is marked as duplicate of this one, but the test case is still listed as experimental as well.

Please fix this and re-close the bug.
[2 Mar 2010 15:31] Alexander Nozdrin
Removed from experimental.