Bug #99627 HtmlRenderer.Utils.FontsUtils - threw an exception
Submitted: 19 May 2020 9:14 Modified: 18 Jun 2020 13:10
Reporter: okechukwu eze Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:8.0.20 OS:Windows (10)
Assigned to: CPU Architecture:Other (i7)

[19 May 2020 9:14] okechukwu eze
Description:
Before today, ever was working 100%. I would connect to my AWS server and all. Suddenly I ran into this error now. "the type initializer for 'HtmlRenderer.Utils.FontsUtils' threw an exception".
Its clearly an issue with the FONT of the system/application. For me everything was working fine and BOOOM, all of a sudden i started getting this error. I can remeber installing several new fonts on my system b4 today.

I have even installed the latest version which is MysqlWorkbench8.0.20 and this error still persist.
What do u think is the cause or solution to this error

How to repeat:
I trully dont know how this Bug can be repeated.
[19 May 2020 9:21] okechukwu eze
After few research, i got the folution of the issue on the link bellow

https://codesport.io/debugging-2/mysql-workbench-and-windows-10/

FIX DETAIL BELOW

1. Close MySQL Workbench if open
2. Go here: C:\Program Files\MySQL\MySQL Workbench 6.3 CE
3. Change HTMLRenderer.dll to HTMLRenderer.BUSTED .. or just delete the file
4. Download patched DLL file from here: https://bugs.mysql.com/file.php?id=22868&bug_id=75673
5. Save patched file to here: C:\Program Files\MySQL\MySQL Workbench 6.3 CE

VIOLA! This fix just works!
[18 Jun 2020 13:10] MySQL Verification Team
Hello okechukwu eze,

Thank you for confirming that issue is no longer seen after following the above steps. Closing the bug.

Regards,
Ashwini Patil
[15 Jul 2020 12:13] MySQL Verification Team
Bug #100198 marked as duplicate of this one.
[30 Sep 2020 4:14] MySQL Verification Team
Bug #99541 marked as duplicate of this one.
[30 Sep 2020 9:33] MySQL Verification Team
Bug #99191 marked as duplicate of this one.
[10 Nov 2020 13:19] MySQL Verification Team
Bug #101528 marked as duplicate of this one.
[17 Feb 2021 11:05] MySQL Verification Team
Bug #102613 marked as duplicate of this one.
[31 Aug 2021 8:08] MySQL Verification Team
Bug #104757 marked as duplicate of this one.
[23 Feb 5:27] MySQL Verification Team
Bug #106538 marked as duplicate of this one.
[20 Apr 12:30] MySQL Verification Team
Bug #107063 marked as duplicate of this one.