Bug #92527 Cannot uninstall MYSQL for visual studio 1.2.7 WIN 10
Submitted: 21 Sep 2018 11:28 Modified: 8 Oct 2018 7:43
Reporter: Filippo Berardo Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Visual Studio Integration Severity:S1 (Critical)
Version:1.2.7 OS:Microsoft Windows (10 Pro)
Assigned to: JOSE RAMIREZ CPU Architecture:Other (Intel I5 6300U 2.4Ghz)
Tags: 1.2.7, mysql for visual studio

[21 Sep 2018 11:28] Filippo Berardo
Description:
I cannot uninstall mysql fVS 1.2.7. I want to upgrade to 1.2.8 but it's impossible. No way to uninstall from windows and no way from MYSQL installer.
No way to upgrade to 1.2.8.

How to repeat:
Uninstall MYSQL fVS 1.2.7. from win 10 pro with visual studio 2017 professional.
[21 Sep 2018 13:25] Miguel Solorzano
Thank you for the bug report. Are you tried the MySQL Installer for to do the upgrade?.
[21 Sep 2018 14:52] Filippo Berardo
Yes i did it. here is the log : see attached
[21 Sep 2018 14:52] Filippo Berardo
Log for bug upgrading to 1.2.8

Attachment: logBug.txt (text/plain), 43.80 KiB.

[21 Sep 2018 21:19] Miguel Solorzano
Thank you for the feedback. Please check comments from several users which similar/related issue some found a workaround maybe that could help you:

https://bugs.mysql.com/bug.php?id=88745
https://bugs.mysql.com/bug.php?id=85908
[24 Sep 2018 8:09] Filippo Berardo
Any of the workaround is not working.
Cannot uninstall 1.2.7
Cannot install 1.2.8
[24 Sep 2018 12:48] Filippo Berardo
i uninstalled VS2017, used ccleaner to clear registry, completly removed Mysql, no way.
MYSQL for visual studio 1.2.8 does not install, and i need connector in VS to Work.
Please work on this, i cannot use Mysql anymore.
[25 Sep 2018 6:07] Umesh Shastry
Our sincere apologies for the inconvenience caused to you, we've discussed this issue internally with Development team and here are the suggested workaround in your case:

(1) Please try to uninstall MySQL for Visual Studio 1.2.7 using the instructions provided in the "Installation/uninstallation of MySQL for Visual Studio 1.2.7 / 2.0.5 workaround" section of the following blog post: https://insidemysql.com/mysql-for-visual-studio-rollback-during-installation-uninstallatio...

(2) Next, you can attempt to install version 1.2.8. Note that for said operations the stand-alone MSI of MySQL for Visual Studio is required.

Hope that it helps!

regards,
Umesh
[25 Sep 2018 7:04] Filippo Berardo
I already tried to uninstall deleting the privateregistry.bin file without success.

I tried updating condifguration log manually from prompt. no way.
I deleted all entries in regedit abous visual studio 1.2.7 and deleted all folders in my pc. i reinstalled visual studio from 0.
Now visual studio 1.2.7 is not present but when i install 1.2.8 the installation rollback. I tried to use the standalone msi installer of 1.2.8 and even if the past installation was not finished, now he tells me the previous version of 1.2.8 cannot be uninstalled... i don't understand. see files attached
[25 Sep 2018 7:04] Filippo Berardo
can uninstall

Attachment: BUG.png (image/png, text), 78.56 KiB.

[25 Sep 2018 9:29] Filippo Berardo
Can you please tell me where the installer find that 1.2.8 is installed? is it a key in the registry? a file somwhere?
Can i delete it?
[25 Sep 2018 15:26] JOSE RAMIREZ
Hi Filippo,
can you provide the log that is generated for the most recent error? Said log should contain info on what is causing the installation of 1.2.8 to fail. 

Also, although you've used CCleaner probably using another tool such as Fix It can help to remove any missed remnants of your previous installation.

Regards.
[26 Sep 2018 6:15] Filippo Berardo
Log of Mysql Installer

Attachment: LogMysql.txt (text/plain), 36.62 KiB.

[26 Sep 2018 6:29] Filippo Berardo
it seems to me that the problem is in this line : 
Application: {63F92630-4546-4297-A0F5-761886A689EE}, Command line: UPGRADINGPRODUCTCODE={8FAF420D-7967-44AC-B8B1-F7067944F904} CLIENTPROCESSID=11628 CLIENTUILEVEL=3 MSICLIENTUSESEXTERNALUI=1 REMOVE=ALL

I think the condition REMOVE ALL is the problem.
[26 Sep 2018 17:08] JOSE RAMIREZ
Filippo,

the log generated by MySQL Installer misses detailed data. To get more details please generate the log by running the MySQL for Visual Studio stand-alone msi using the command "msiexec /i <msi_name>.msi /L*V <log_name>.log" in a command prompt.

In the log you provided, it looks like the "RemoveExistingProducts" action is failing to execute, probably because there are still some remnants of the previous installation. Hopefully the full log will include more details.
[26 Sep 2018 20:07] Filippo Berardo
Here is the Log as you asked

Attachment: msimysqlfvs.log (application/octet-stream, text), 1.67 MiB.

[27 Sep 2018 21:50] JOSE RAMIREZ
Thanks Filippo.

Reviewing the log it looks as though there are still some registry entries from the previous installation (see extract below). Note the mention that a missing or unexpected value was found for the "HKLM\Software\Classes\Installer\Products\03629F36645479240A5F6781686A98EE\SourceList" key. 

Making a quick search on the internet it is said that usually removing the affecting key will fix the issue. Probably you can search the registry using the product code to validate any other un-removed entries. Other users have solved the issue by running additional cleanup tools since CCleaner doesn't always remove everything.

RemoveExistingProducts: Application: {63F92630-4546-4297-A0F5-761886A689EE}, Command line: UPGRADINGPRODUCTCODE={8FAF420D-7967-44AC-B8B1-F7067944F904} CLIENTPROCESSID=1180 CLIENTUILEVEL=0 REMOVE=ALL
MSI (s) (E0:B0) [22:03:49:250]: Resetting cached policy values
MSI (s) (E0:B0) [22:03:49:250]: Machine policy value 'Debug' is 0
MSI (s) (E0:B0) [22:03:49:250]: ******* RunEngine:
           ******* Product: {63F92630-4546-4297-A0F5-761886A689EE}
           ******* Action: 
           ******* CommandLine: **********
MSI (s) (E0:B0) [22:03:49:251]: Valore mancante o imprevisto (nome: "PackageName", valore: "") nella chiave "HKLM\Software\Classes\Installer\Products\03629F36645479240A5F6781686A98EE\SourceList".

CustomAction  returned actual error code 1610 (note this may not be 100% accurate if translation happened inside sandbox)
MSI (s) (E0:D4) [22:03:49:253]: Note: 1: 1714 2: MySQL for Visual Studio 1.2.8 3: 1610 
Error 1714. The older version of MySQL for Visual Studio 1.2.8 cannot be removed.  Contact your technical support group.  System Error 1610.
MSI (s) (E0:D4) [22:03:51:471]: Product: MySQL for Visual Studio 1.2.8 -- Error 1714. The older version of MySQL for Visual Studio 1.2.8 cannot be removed.  Contact your technical support group.  System Error 1610.

Regards.
[28 Sep 2018 5:58] Filippo Berardo
But Jose, 

sorry but how can it be that MysqlIntsaller find a reg key of 1.2.8, when this version has never been installed on this machine?
And i tried to install MYSQL for Visual studio 2.0.5 and i got the same message, the installer fail because it cannot uninstall older version of 2.0.5 (!) never installed before!
Sorry but i think this key is created by the installer or something similar and it is not a problem of my pc.
[2 Oct 2018 8:39] Filippo Berardo
I re-installed windows from 0 and now i have to install Mysql, Mysql workbench, Mysql connecotr for .net and mysql for visual studio.
Do i have to follow any specific path?
thank you
[2 Oct 2018 17:01] JOSE RAMIREZ
Hello Filippo,
It's hard to determine what is causing the current behavior since the steps that led to it aren't completely clear. I'm thinking that the manual removal of M4VS 1.2.7 using CCleaner corrupted the installation since it may have missed to remove/update some items. The error message appears to be misleading since it appears to take the version of the product you are currently trying to install however it is still finding a registry key that belonged to the previous 1.2.7 installation.

Now that you have a clean slate I recommend first having Visual Studio installed. Then using MySQL Installer attempt to install the products you mention using a Custom Setup. A Custom Setup in MySQL Installer will allow you to select all the products that you want installed, including MySQL for Visual Studio 1.2.8. Be sure to copy the log in case of any failure.

Regards.
[3 Oct 2018 15:46] Filippo Berardo
OK.
I installed VS2017 and all new MYSQL products.
Everithing was installed, MYSQL, Connector, MYSQL for VS 1.2.8, notifier, workbench.

NOw i have opened a project that was connectd to mysql 5.7
and all dataset are broken.
The reference to MYSQL dll (mysqldata.dll) is broken and it is no more presente in references, even if i look for to add it.
[3 Oct 2018 15:49] Filippo Berardo
no mysql library or assembly

Attachment: 1.png (image/png, text), 71.22 KiB.

[3 Oct 2018 16:08] Filippo Berardo
no new datasource

Attachment: 2.png (image/png, text), 106.87 KiB.

[4 Oct 2018 17:54] JOSE RAMIREZ
Hello Filippo,

The feature of listing MySql.Data and similar assemblies in the Reference Manager is enabled when Connector/NET is installed. Note that Visual Studio needs to be restarted after installing Connector/NET in order for said assemblies to appear. Likely this was the issue, otherwise this has to be reported to the Connector/NET team.

As for your second issue, I've been able to reproduce it, since MySql for Visual Studio works in hand with Connector/NET, it is currently unclear which product is generating the failure. I'll investigate a bit further to check if there is a workaround and determine the root cause. Please raise a separate bug report and provide the bug number so we can follow up there.

Regards.
[5 Oct 2018 8:30] Filippo Berardo
OK Jose, 
thank you for your reply.

I don't want to bother you, so you don't need to reply me again, but

I have to say that i've tried to install MYSQL 8.xxx, with Mysql For Visual Studio 1.2.8. and connector (last version) in 3 laptop, 2 Surface pro and 1 MACBOOK wirh windows partition, and the MYSQL Connector never worked for any of this laptop.
We make C# prjects with datasource connected to some tables and it does not work.
I made even a new empty project, create new connection but nothing.

So i'm very surprised the MYSQL Team has no laptop to verify the MYSQL 8 family products does not work with VS2017?
Now i installed MYSQL 5.5, MYSQLFVS 1.2.7, Conncetor 6.9.8 and , thank god, it's working!

Actually i can say, after 3 laptop, with proof, that MYSQL CONNECTOR AND/OR MYSQL FOR VISUAL STUDIO last versions DOES NOT WORK WITH VISUAL STUDIO 2017.
It's strange that MYSQL team does not know this.

Have a nice day.
[5 Oct 2018 10:44] Miguel Solorzano
If you filed the bug https://bugs.mysql.com/bug.php?id=92681 I assume you was able to install 1.2.8 right?. Thanks.
[5 Oct 2018 10:54] Filippo Berardo
I was able to install it but now i'm using 1.2.7, just to be sure it works.
I will try again on my mac to make things working but now after i installed two instances of mysql db 5.7 and 8.0 now the db does not works anymore and the service does not starts. So i'm wondering how to erase mysql to make service start again when i instal mysql 8
[5 Oct 2018 13:11] Miguel Solorzano
Regarding to remove the server use the installer or if you wasn't used the installer then stop the service, remove it with mtsqld.exe --remove service_name and delete all the folders of such installation (if you don`t have data to preserve of course). Then use the installer to install the new 8.0.12.
I assume the issue you had with 1.2.7 and 1.2.8 is about your environment and isn't repeatable on our side, then I will close this bug report as can't repeat. Thanks.
[7 Oct 2018 23:01] JOSE RAMIREZ
Hello Filippo,

some of the features in MySQL for Visual Studio are failing due to incompatibilities with the most recent versions of Connector/NET, they are being worked on.

Regarding your issue with creating datasources, thank you for raising ticket https://bugs.mysql.com/bug.php?id=92681, you can use that bug report to keep track on the fix. In case you have any additional findings please post them there.

Miguel, this ticket can now be closed since the original issue of not being able to uninstall/upgrade MySQL for Visual Studio couldn't be reproduced as it appeared to be a special case where the previous installation had been corrupted.

Regards.
[8 Oct 2018 7:43] Miguel Solorzano
According prior comment from José. Thanks.