Bug #88745 Installation of MySQL for Visual Studio fails
Submitted: 4 Dec 2017 20:00 Modified: 7 Dec 2017 11:45
Reporter: Kai Neumann Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Visual Studio Integration Severity:S2 (Serious)
Version:v2.0.5 OS:Microsoft Windows (Win7 x64)
Assigned to: CPU Architecture:Any

[4 Dec 2017 20:00] Kai Neumann
Description:
I had installed MySql for Visual Studio (last 1.2.7) - first under VS2013 (about 3 years? ago), VS2015 and last under VS2017.
Due to actual problems accessing the database structure from Visual Studio, I wanted to update to v2.0.5. Unfortunately, the uninstalling of v1.2.7 didn't work: just before the uninstallation was finished, a rollback was executed again and again.
A direct installation of 2.0.5 was also confirmed with a rollback.

With the MS-Tool from the side 

https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being... 

I was finally able to uninstall version v1.2.7. Unfortunately, a rollback is still running during the installation of 2.0.5. I have attached a log which was created by 

MsiExec.exe /IC:\Users\USERNAME\Downloads\mysql-for-visualstudio-2.0.5.msi /L*V C:\temp\failed_205.txt

was created. Can you help me solve this problem and make me able to install v2.0.5 ?

How to repeat:
No idea, seems to be a badly reproducible behavior dependent on the system.

Suggested fix:
Make it possible to install .
[4 Dec 2017 20:01] Kai Neumann
log file from failed installation

Attachment: failed_205.txt (text/plain), 1.86 MiB.

[5 Dec 2017 11:52] Chiranjeevi Battula
Hello Kai Neumann,

Thank you for the bug report.
This is most likely duplicate of Bug #85908, please see Bug #85908

Thanks,
Chiranjeevi.
[5 Dec 2017 18:51] Kai Neumann
Hello, Chiranjeevi Battula,

I was looking at bug #85908 but found that this is a different problem than I have.

Bug #85908 is about not detecting an existing Visual Studio installation. In my case the installation will be detected . But during the installation, an error occurs later in the process, causing a rollback.

Bug #85908 contains no solution to this problem,
but I found a similar problem with a possible solution here:

https://forums.mysql.com/read.php?174,660549,661819#msg-661819

Here Jose Ramirez states that such a problem is caused by an error
during execution of "devenv /updateconfiguration /log".

I will try to take the solution suggested by Jose Ramirez.
[5 Dec 2017 20:21] Kai Neumann
Badly this didn't help.
But I've checked the file "failed_205.txt" and found following entries (beginning from line 4328):

*****************************************************************
MSI (s) (B4:E4) [20:31:26:575]: Executing op: CustomActionSchedule(Action=VS15_Pro_Setup_Custom,ActionType=3073,Source=BinaryData,Target=WixQuietExec,CustomActionData="C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\Common7\IDE\devenv" /updateconfiguration /log)
MSI (s) (B4:E0) [20:31:26:575]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI8152.tmp, Entrypoint: WixQuietExec
WixQuietExec:  Error 0xffffffff: Command line returned an error.
WixQuietExec:  Error 0xffffffff: QuietExec Failed
WixQuietExec:  Error 0xffffffff: Failed in ExecCommon method
CustomAction VS15_Pro_Setup_Custom returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 20:31:26: InstallFinalize. Return value 3.
*****************************************************************

This error code "1603" is the same code at the end of the file (line 5886):

*****************************************************************
MSI (s) (B4:E4) [20:31:27:901]: MainEngineThread is returning 1603
MSI (s) (B4:40) [20:31:27:901]: RESTART MANAGER: Session closed.
MSI (s) (B4:40) [20:31:27:901]: User policy value 'DisableRollback' is 0
MSI (s) (B4:40) [20:31:27:901]: Machine policy value 'DisableRollback' is 0
MSI (s) (B4:40) [20:31:27:901]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (s) (B4:40) [20:31:27:901]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2 
MSI (s) (B4:40) [20:31:27:901]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2 
MSI (s) (B4:40) [20:31:27:901]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
MSI (s) (B4:40) [20:31:27:901]: Restoring environment variables
MSI (s) (B4:40) [20:31:27:901]: Destroying RemoteAPI object.
MSI (s) (B4:40) [20:31:27:901]: Custom Action Manager thread ending.
MSI (c) (8C:54) [20:31:27:901]: Back from server. Return value: 1603
MSI (c) (8C:54) [20:31:27:901]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
MSI (c) (8C:54) [20:31:27:901]: PROPERTY CHANGE: Deleting SECONDSEQUENCE property. Its current value is '1'.
Action ended 20:31:27: ExecuteAction. Return value 3.
MSI (c) (8C:54) [20:31:27:901]: Doing action: FatalError
Action 20:31:27: FatalError. 
Action start 20:31:27: FatalError.
Action 20:31:27: FatalError. Dialog created
*****************************************************************

and here (line 6249):

*****************************************************************
=== Logging stopped: 04.12.2017  20:31:30 ===
MSI (c) (8C:54) [20:31:30:600]: Note: 1: 1708 
MSI (c) (8C:54) [20:31:30:600]: Product: MySQL for Visual Studio 2.0.5 -- Installation failed.

MSI (c) (8C:54) [20:31:30:600]: Windows Installer installed the product. Product Name: MySQL for Visual Studio 2.0.5. Product Version: 2.0.5. Product Language: 1033. Manufacturer: Oracle. Installation success or error status: 1603.

MSI (c) (8C:54) [20:31:30:600]: Grabbed execution mutex.
MSI (c) (8C:54) [20:31:30:600]: Cleaning up uninstalled install packages, if any exist
MSI (c) (8C:54) [20:31:30:600]: MainEngineThread is returning 1603
=== Verbose logging stopped: 04.12.2017  20:31:30 ===
*****************************************************************

So I assume, this is the critical moment .
Any suggestions ?
[5 Dec 2017 20:33] Kai Neumann
If I check the log with Jose Ramirez variant the error lines looks this way:

***********************************************************
MSI (s) (B0:D4) [21:26:14:753]: Executing op: CustomActionSchedule(Action=VS15_Pro_Setup_Custom,ActionType=3073,Source=BinaryData,Target=WixQuietExec,)
MSI (s) (B0:DC) [21:26:14:769]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI6732.tmp, Entrypoint: WixQuietExec
WixQuietExec:  Error 0x80070057: Failed to get command line data
WixQuietExec:  Error 0x80070057: Failed to get Command Line
WixQuietExec:  Error 0x80070057: Failed in ExecCommon method
CustomAction VS15_Pro_Setup_Custom returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 21:26:14: InstallFinalize. Return value 3.
***********************************************************

So it looks like the problem is not the command 

           devenv" /updateconfiguration /log

suggested by Jose Ramirez, but the following line 

           MSI (s) (B0:DC) [21:26:14:769]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI6732.tmp, Entrypoint: WixQuietExec

looks critical.

Ideas ? I already have uninstalled all .Net-packages and un- and reinstalled VS2017,
but nothing has changed. A new installation of the whole system is no option.
[5 Dec 2017 21:34] Kai Neumann
Ok, last thing for today:

First of all, I think it's not that does not recognize the Visual Studio. 
I checked the suggested registry entries from bug #85908 and adjusted the keys for non-existent VS-versions:

Visual Studio 2010 removed (no longer installed)
-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\10.0\Setup\VS

Visual Studio 2015 removed (no longer installed)
-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\14.0\Setup\VS

Visual Studio 2017 added (don't exist despite installation)
+HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\15.0\Setup\VS

However, this did not bring any changes. Earlier during custom installation, VS 2017
can be selected and when installing via the MySQL-Installer 
there has never been a lack of precondition criticized. However, I've tried to
explicitly enable the integration for VS2017 in the custom installation.
The integration for VS 2012/2013 and 2015 were selected by default and so I deselected them explicitly.
I also deselected the EF integration for all versions.

The resulting InstallFinalize section now looks like this:

*********************************************************
Action 22:01:12: InstallFinalize. 
Action start 22:01:12: InstallFinalize.
MSI (s) (B0:A8) [22:01:12:224]: Running Script: C:\Windows\Installer\MSI6865.tmp
MSI (s) (B0:A8) [22:01:12:224]: User policy value 'DisableRollback' is 0
MSI (s) (B0:A8) [22:01:12:224]: Machine policy value 'DisableRollback' is 0
MSI (s) (B0:A8) [22:01:12:224]: Executing op: Header(Signature=1397708873,Version=500,Timestamp=1267052583,LangId=1033,Platform=0,ScriptType=1,ScriptMajorVersion=21,ScriptMinorVersion=4,ScriptAttributes=1)
MSI (s) (B0:A8) [22:01:12:224]: Executing op: ProductInfo(ProductKey={38BFA49E-A797-4D4B-9183-89B2DBEA95D1},ProductName=MySQL for Visual Studio 2.0.5,PackageName=mysql-for-visualstudio-2.0.5.msi,Language=1033,Version=33554437,Assignment=1,ObsoleteArg=0,,,PackageCode={75271C82-CF76-4359-B0C1-F15F402A6233},,,InstanceType=0,LUASetting=0,RemoteURTInstalls=0,ProductDeploymentFlags=3)
MSI (s) (B0:A8) [22:01:12:224]: Executing op: DialogInfo(Type=0,Argument=1033)
MSI (s) (B0:A8) [22:01:12:224]: Executing op: DialogInfo(Type=1,Argument=MySQL for Visual Studio 2.0.5)
MSI (s) (B0:A8) [22:01:12:224]: Executing op: RollbackInfo(,RollbackAction=Rollback,RollbackDescription=Rolling back action:,RollbackTemplate=[1],CleanupAction=RollbackCleanup,CleanupDescription=Removing backup files,CleanupTemplate=File: [1])
MSI (s) (B0:A8) [22:01:12:224]: Executing op: SetBaseline(Baseline=0,)
MSI (s) (B0:A8) [22:01:12:224]: Executing op: SetBaseline(Baseline=1,)
MSI (s) (B0:A8) [22:01:12:224]: Executing op: ActionStart(Name=DeleteRegKeyAndExtensionsFile_VS2017,,)
Action 22:01:12: DeleteRegKeyAndExtensionsFile_VS2017. 
MSI (s) (B0:A8) [22:01:12:224]: Executing op: CustomActionSchedule(Action=DeleteRegKeyAndExtensionsFile_VS2017,ActionType=3073,Source=BinaryData,Target=DeleteRegKeyAndExtensionsFile,CustomActionData=VSVersion=VS2017Community)
MSI (s) (B0:A8) [22:01:12:224]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI6877.tmp, Entrypoint: DeleteRegKeyAndExtensionsFile
SFXCA: Extracting custom action to temporary directory: C:\Windows\Installer\MSI6877.tmp-\
SFXCA: Binding to CLR version v4.0.30319
Calling custom action MySql.VisualStudio.CustomAction!MySql.VisualStudio.CustomAction.CustomActions.DeleteRegKeyAndExtensionsFile
Deleting Registry key. keyPath = 'Software\Wow6432Node\Microsoft\VisualStudio\15.0'. keyName='ShellFolder'
Deleted Registry key. keyPath = 'Software\Wow6432Node\Microsoft\VisualStudio\15.0'. keyName='ShellFolder'
File deleted for Vs2017Community_EXTENSIONSFILE_CREATED.
MSI (s) (B0:A8) [22:01:12:318]: Executing op: ActionStart(Name=DeleteRegKeyAndExtensionsFile_VS2017_Ent,,)
Action 22:01:12: DeleteRegKeyAndExtensionsFile_VS2017_Ent. 
MSI (s) (B0:A8) [22:01:12:318]: Executing op: CustomActionSchedule(Action=DeleteRegKeyAndExtensionsFile_VS2017_Ent,ActionType=3073,Source=BinaryData,Target=DeleteRegKeyAndExtensionsFile,CustomActionData=VSVersion=VS2017Enterprise)
MSI (s) (B0:74) [22:01:12:318]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI68D5.tmp, Entrypoint: DeleteRegKeyAndExtensionsFile
SFXCA: Extracting custom action to temporary directory: C:\Windows\Installer\MSI68D5.tmp-\
SFXCA: Binding to CLR version v4.0.30319
Calling custom action MySql.VisualStudio.CustomAction!MySql.VisualStudio.CustomAction.CustomActions.DeleteRegKeyAndExtensionsFile
Deleting Registry key. keyPath = 'Software\Wow6432Node\Microsoft\VisualStudio\15.0'. keyName='ShellFolder'
File deleted for Vs2017Enterprise_EXTENSIONSFILE_CREATED.
MSI (s) (B0:A8) [22:01:12:443]: Executing op: ActionStart(Name=VS15_Pro_UpdatePackageFile,,)
Action 22:01:12: VS15_Pro_UpdatePackageFile. 
MSI (s) (B0:A8) [22:01:12:443]: Executing op: CustomActionSchedule(Action=VS15_Pro_UpdatePackageFile,ActionType=3073,Source=BinaryData,Target=UpdateFlagPackagesFileForVs2017Professional,CustomActionData=VS2017_Pro_PathProp=C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\)
MSI (s) (B0:30) [22:01:12:443]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI6953.tmp, Entrypoint: UpdateFlagPackagesFileForVs2017Professional
SFXCA: Extracting custom action to temporary directory: C:\Windows\Installer\MSI6953.tmp-\
SFXCA: Binding to CLR version v4.0.30319
Calling custom action MySql.VisualStudio.CustomAction!MySql.VisualStudio.CustomAction.CustomActions.UpdateFlagPackagesFileForVs2017Professional
MSI (s) (B0:A8) [22:01:12:536]: Executing op: ActionStart(Name=VS15_Pro_Setup_Custom,,)
Action 22:01:12: VS15_Pro_Setup_Custom. 
MSI (s) (B0:A8) [22:01:12:536]: Executing op: CustomActionSchedule(Action=VS15_Pro_Setup_Custom,ActionType=3073,Source=BinaryData,Target=WixQuietExec,CustomActionData="C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\Common7\IDE\devenv" /updateconfiguration /log)
MSI (s) (B0:64) [22:01:12:536]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI69B2.tmp, Entrypoint: WixQuietExec
WixQuietExec:  Error 0xffffffff: Command line returned an error.
WixQuietExec:  Error 0xffffffff: QuietExec Failed
WixQuietExec:  Error 0xffffffff: Failed in ExecCommon method
CustomAction VS15_Pro_Setup_Custom returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 22:01:12: InstallFinalize. Return value 3.
*********************************************************
[5 Dec 2017 21:39] Kai Neumann
ActivityLog from "devenv /updateconfiguration /log"

Attachment: ActivityLog.xml (text/xml), 30.69 KiB.

[5 Dec 2017 21:40] Kai Neumann
Maybe the log from VS helps (see above)
[6 Dec 2017 16:53] Kai Neumann
Hi,

I think I've solved the problem. The decisive tip came from here:

https://developercommunity.visualstudio.com/content/problem/40627/vs2017-version-151-26403...

As described there, I removed the file 

    privateregistry.bin 

from the folder

    C:\Users\myuser\AppData\Local\Microsoft\VisualStudio\15.0_ffae6936\

After that I could at least install "MySQL for Visual Studio".
[7 Dec 2017 11:45] Chiranjeevi Battula
Hello Kai Neumann,

Thank you for the feedback.
I'm glad that you found a solution for your problem and let us know if you are still having the issue with complete repeatable steps.

Thanks,
Chiranjeevi.
[18 Apr 2018 10:51] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=90491 marked as duplicate of this one.