Bug #92681 CONNECTOR 8 does not work with c# VS2017
Submitted: 5 Oct 2018 8:36 Modified: 1 Apr 16:27
Reporter: Filippo Berardo Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Visual Studio Integration Severity:S2 (Serious)
Version:8.0.12 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[5 Oct 2018 8:36] Filippo Berardo
Description:
I tried to install Connector in VS 2017 on 3 laptops, 2 surface pro 4 and 1 macbook with windows partion. 

There is no way that connector (or Mysql for visual studio 1.2.8) works for a c# project with datasource connected to datatables.

This connector does not works.

I rolled back to connector 6.9.8 and MYSQLFVS 1.2.7 to make it work.

How to repeat:
INstall VS2017 PRO or Community and MYSQL 8 family 
try to create a datasource in a project connected to tables or views
[5 Oct 2018 8:36] Filippo Berardo
dll

Attachment: 1.png (image/png, text), 71.22 KiB.

[5 Oct 2018 8:36] Filippo Berardo
not connected

Attachment: 2.png (image/png, text), 106.87 KiB.

[5 Oct 2018 10:11] MySQL Verification Team
Error dialog

Attachment: 92681.png (image/png, text), 70.45 KiB.

[5 Oct 2018 10:12] MySQL Verification Team
Thank you for the bug report.
[5 Oct 2018 17:52] MySQL Verification Team
https://bugs.mysql.com/bug.php?id=92695 marked as duplicate of this one.
[11 Oct 2018 13:52] MySQL Verification Team
Bug #92751 is marked as duplicate of this one
[12 Oct 2018 5:34] Mariusz Blautzik
I made a post and they marked it as a duplicate of this one.  So how can I fix this problem?

I'm stranded for like 2 days now without any progress.  Any fix??  
Because I only see people comment with "I Have the same problem" and no one gives any solution. 

Maybe it's a development problem and MySQL needs to fix this because so many people have this problem.!!!
[6 Nov 2018 9:49] Filippo Berardo
I'd like to know if something has been fixed about this bug.
We are facing problem with older version of mysql and we need it to work, or we willbe forced to change.
[6 Nov 2018 14:05] Filippo Berardo
I warn that is impossible to download and install previous version from MYSQL Site.
Every time you are directed to installer that installs the new version...
So even the possibility to go back is not available...
[7 Nov 2018 6:48] Mariusz Blautzik
Seems like nothing will happen in near future. I don't think this will be fixed soon. 

I'm glad that I switched to MSSQL. Because if I had to wait for a month. I would not be able to finish my internship assignment. 

I'm just sad they are doing nothing with this bug :( 

@Fillipo, I think you can switch as well to another database. 

Greetings,

Mariusz
[6 Jan 2019 17:44] Ted Lawhorn
January 2019 and still not fixed.
[7 Jan 2019 14:10] Filippo Berardo
I really would like to know if it's a very difficult bug to solve, or
if Oracle has decided not to upgrade MYSQL for VS.
If so, someone should tell us that this DB is no more usable for business.
[29 Aug 2019 7:38] Azzam Makki
Anyone got a solution for this?
[18 Sep 2019 8:31] Filippo Berardo
Does anyone have a solution??
i'm gonna switch to MS SQL!
[20 Sep 2019 9:36] Filippo Berardo
OK, if i have to try by myself if the connector now works, i have to destroy all the configuration on my PC or i have to create a virtual environment to install everything and try it, maybe just to know that i doesn't work.
So My decision is that MYSQL, that now i'm using for my work, is not enough a professional product and i switch from today to MSSQL.

GoodBye and i think this is forever.
[11 Mar 2020 7:54] Filippo Berardo
I made a trial on new MYSQL installer and connector to last version and now the problem seems to be solved.
It has taken only some years..
[1 Apr 16:27] Christine Cole
Fixed as of the upcoming MySQL for Visual Studio 1.2.10 release, and here's the proposed changelog entry from the documentation team:

An attempt to generate an entity framework model produced several errors,
rather than creating a data source with a valid connection to the
database.

Thank you for the bug report.