Bug #87077 mysql .net connector 6.9.9 fails setup every time
Submitted: 14 Jul 2017 19:59 Modified: 18 Jul 2017 12:25
Reporter: george hardy Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S2 (Serious)
Version:6.9.9 OS:Microsoft Windows (10pro)
Assigned to: CPU Architecture:Any

[14 Jul 2017 19:59] george hardy
Description:
1: Download of product 'connector-net' started from http://cdn.mysql.com/Downloads/Connector-Net/mysql-connector-net-6.9.9.msi
1: Download of package 'Connector/NET 6.9.9' succeeded
1: Action 14:47:36: INSTALL. 
1: 1: MySQL Connector Net 6.9.9 2: {E09F82E9-3EB3-4725-BDC8-3C77F83E262C} 
1: Action 14:47:36: FindRelatedProducts. Searching for related applications Found application: [1]
1: Action 14:47:36: AppSearch. Searching for installed applications Property: [1], Signature: [2]
1: Action 14:47:36: LaunchConditions. Evaluating launch conditions
1: Action 14:47:36: ValidateProductID. 
1: Action 14:47:36: CostInitialize. Computing space requirements
1: Action 14:47:36: FileCost. Computing space requirements
1: Action 14:47:36: CostFinalize. Computing space requirements
1: Action 14:47:36: InstallValidate. Validating install
1: Action 14:47:36: Setv4InstallUtil. 
1: Action 14:47:36: InstallInitialize. 
1: Action 14:47:36: RemoveExistingProducts. Removing applications Application: [1], Command line: [2]
1: Action 14:47:36: ProcessComponents. Updating component registration
1: Action 14:47:36: GenerateScript. Generating script operations for action: [1]
1: 
1: Action 14:47:36: MsiUnpublishAssemblies. Unpublishing assembly information Application Context:[1], Assembly Name:[2]
1: Action 14:47:36: UnpublishFeatures. Unpublishing Product Features Feature: [1]
1: Action 14:47:36: UninstallPerfCounterData. 
1: Action 14:47:36: RemoveRegistryValues. Removing system registry values Key: [1], Name: [2]
1: Action 14:47:36: RemoveShortcuts. Removing shortcuts Shortcut: [1]
1: Action 14:47:36: RemoveFiles. Removing files File: [1], Directory: [9]
1: Action 14:47:36: RemoveFolders. Removing folders Folder: [1]
1: Action 14:47:36: CreateFolders. Creating folders Folder: [1]
1: 
1: Action 14:47:36: InstallFiles. Copying new files File: [1],  Directory: [9],  Size: [6]
1: 
1: Action 14:47:37: ManagedDataInstallSetup. 
1: Action 14:47:37: ManagedDataInstall. Registering data provider in machine.config
1: Action 14:47:37: ManagedWebInstallSetup. 
1: Action 14:47:37: ManagedWebInstall. Registering web providers in machine.config
1: Action 14:47:37: CreateShortcuts. Creating shortcuts Shortcut: [1]
1: 
1: Action 14:47:37: WriteRegistryValues. Writing system registry values Key: [1], Name: [2], Value: [3]
1: 
1: Action 14:47:37: InstallPerfCounterData. 
1: Action 14:47:37: RollbackRegisterPerfCounterData. 
1: 
1: Action 14:47:37: RegisterPerfCounterData. 
1: 
1: Action 14:47:37: RegisterUser. Registering user [1]
1: Action 14:47:37: RegisterProduct. Registering product [1]
1: 
1: Action 14:47:37: MsiPublishAssemblies. Publishing assembly information Application Context:[1], Assembly Name:[2]
1: 
1: Action 14:47:37: PublishFeatures. Publishing Product Features Feature: [1]
1: 
1: Action 14:47:37: PublishProduct. Publishing product information
1: 
1: Action 14:47:38: InstallFinalize. 
1: Action 14:47:38: ProcessComponents. Updating component registration
1: Action 14:47:38: CreateFolders. Creating folders Folder: [1]
1: Action 14:47:38: InstallFiles. Copying new files File: [1],  Directory: [9],  Size: [6]
1: Action 14:47:38: ManagedDataInstall. Registering data provider in machine.config
1: Action 14:47:38: ManagedWebInstall. Registering web providers in machine.config
1: Action 14:47:38: Rollback. Rolling back action: [1]
1: 1: MySQL Connector Net 6.9.9 2: {E09F82E9-3EB3-4725-BDC8-3C77F83E262C} 3: 3 
1: The action 'Install' for product 'Connector/NET 6.9.9' failed.

How to repeat:
just install once and uninstall it.   now, I cannot uninstall it or install it again.  the setup program sucks.  it seems to always fail modifying the machine.config.
[14 Jul 2017 20:05] george hardy
I have tried deleting the directories and everything.  this is all about machine.config I think.
[18 Jul 2017 12:25] Chiranjeevi Battula
Hello george hardy,

Thank you for the bug report.
This is most likely duplicate of Bug #76155, please see Bug #76155.
Please see to uninstall Bug #71329.

Thanks,
Chiranjeevi.