Bug #76155 Cannot Uninstall MySQL Connector .Net 6.9.3
Submitted: 4 Mar 2015 21:45 Modified: 18 Mar 2015 3:32
Reporter: Sarah Weinberger Email Updates:
Status: Closed Impact on me:
Category:Connector / NET Severity:S1 (Critical)
Version:6.9.3 OS:Windows (Win7/64, Win81/64)
Assigned to: Gabriela Martinez Sanchez CPU Architecture:Any
Tags: mysql connector.net, uninstall, windows

[4 Mar 2015 21:45] Sarah Weinberger
I have installed/uninstalled the MySQL Connector .Net (MCN, here on out) software on my Windows boxes numerous times previously. I always follow the same protocol, namely reboot | uninstall old software | install new software.

Windows 7/64-bit
I tried to uninstall the MCN 6.9.3 software and at removal continues for a time until midway, when the progress bar starts going backwards (backing out of the uninstall for whatever reason) and then the progress bar closes leaving the software.

I tried looking in the C:\ProgramData folder, but there is no MySQL folder, so the uninstall routine obviously exists elsewhere. I was hoping to get a verbose uninstall report.

The 6.9.3 software is still installed.

Windows 8.1/64-bit
My W81 box was the first that I tried to uninstall the MCN software on. I met the same fate. Sadly, I tried following suggestions on Stack Overflow for an earlier version and that made the situation worse.

The suggestion said to use the Microsoft FixIt software to uninstall. That removed the application from the Programs and Features control panel applet, however left the files. The other suggestion said to remove all registry entries with "MySQL connector .Net", which I did and then removed the folder in "C:\Program Files", however that left me unable to install the new version.

How do I recover this machine, so that I can install/uninstall like before

The same thing happened on two different computers and after a reboot, which means that there is some sort of bug in the installer.

I would like to recover both machines.

How to repeat:
On my Windows 7 box, I just go to Control Panel | Programs and Features | and uninstall MySQL Connector .Net.
[5 Mar 2015 11:41] Chiranjeevi Battula
Hello Sarah Weinberger,

Thank you for the bug report.
Similar issue has been reported(Bug #64443) in the past and it is explained by dev's [6 Mar 2012 21:01] Gabriela Martinez Sanchez <mailto:gabry.martinez@oracle.com>
Please check if the workaround suggested by dev's work and feel free to open the bug if it doesn't work with details to reproduce the issue at our end.

[5 Mar 2015 13:17] Sarah Weinberger
I do not have multiple user accounts on either computer. I installed and tried multiple uninstalls using the same user account.

Windows 7 Box
* How can I get a verbose log of the uninstall process?

Windows 8.1 Box
* How can I install/repair the 6.9.3, which I do not have, or remove completely so that I can install 6.9.5?
[5 Mar 2015 21:06] Gabriela Martinez Sanchez
Hi Sarah,

Could you please try to generate a log in your machine, so we can troubleshoot this issue?
In order to generate a log we can take a look of, you would need to run the following command:

Open a command prompt window with Administrative rights:

Go to the path where the msi of Connector/Net 6.9.3 is saved.

type this:

msiexec -x mysql-connector-net-6.9.3.msi /lvx* c:\log.txt

A verbose log will be generated in the specified path.

Either if you want to install or uninstall any of this log would be useful so we can find out what the problem is.

Please upload the log file to this bug.

Looking forward to your feedback.

Thanks in advance.
[5 Mar 2015 21:51] Sarah Weinberger
Thank you for the prompt response.

I issued the requested line, however I receive the error message, "This installation package could not be opened. Verify that the package exists and..."

If I go through P&F in Control Panel, then the system can find the MSI file and it appears to be the same name, as shown, when the system asks me to allow changes (asks me admin access).

msiexec -x mysql-connector-net-6.9.3.msi

I will attempt to upload a couple of screenshots, see Files if successful.

We talked of my Windows 7 box up until now, but there is a similar problem, as discussed on my Windows 8.1 box.
[5 Mar 2015 21:52] Sarah Weinberger
Windows 7: Programs and Files Entry

Attachment: MySql-Uninstall-1.png (image/png, text), 85.11 KiB.

[5 Mar 2015 21:53] Sarah Weinberger
Windows 7: Error message when trying to uninstall from the command line, per directive on 3/5/2015

Attachment: MySql-Uninstall-2.png (image/png, text), 24.47 KiB.

[5 Mar 2015 21:54] Sarah Weinberger
first add did not take, so now comments are swapped: #1 should be the Windows 7 Programs and Files view showing the connector

Attachment: MySql-Uninstall-2.png (image/png, text), 24.47 KiB.

[5 Mar 2015 22:31] Gabriela Martinez Sanchez
Thanks for your response,
Could you please try to download again the msi from :


This msi has a new fix to address these kind of issues. Could you please try with this one?

Thanks in advance.
[5 Mar 2015 22:51] Sarah Weinberger
Thank you for the prompt response.

I assume the download is for my Win8.1 box, which has nothing on it, sadly. I will try on the Win81 box this evening.

I await your response on the Win7 box, which still has 6.9.3 installed. We will need to uninstall 6.9.3 before I can install 6.9.6 on that. We left off that I cannot for whatever reason use the command line as directly stated.
[5 Mar 2015 22:53] Sarah Weinberger
here is the log file from my last attempt

Attachment: mysql-connector-net.log (application/octet-stream, text), 5.61 KiB.

[5 Mar 2015 22:53] Sarah Weinberger
I just attached the log file from that unsuccessful uninstall from the command line. I did not realize that the utility created a log file. See attached to this ticket.
[5 Mar 2015 23:12] Sarah Weinberger
I looked at the log file and see that the system tried to use the current path for the MSI file, which obviously was not a valid path, hence the error.

Interesting is that I did a search on my Win7 box for the file, which I know to exist, because P&F uninstall works (by a different name?).

Here is the result:

C:\>dir mysql-connector-net-6.9.3.msi /s
 Volume in drive C is Windows7_OS
 Volume Serial Number is F009-84BA
File Not Found

Would it be faster to get the real log output if you sent me (or attached) "mysql_connector-net-6.9.3.msi" to this ticket? I did not see this particular build under older files.
[6 Mar 2015 4:01] Sarah Weinberger
Win81 6.9.6 Failed installation log

Attachment: mysql-connector-net-6.9.6.log (application/octet-stream, text), 829.82 KiB.

[6 Mar 2015 15:32] Sarah Weinberger
Win7: 6.9.3 uninstall failure log, see attached

Attachment: mysql-connector-net-6.9.3.log (application/octet-stream, text), 335.26 KiB.

[6 Mar 2015 15:36] Sarah Weinberger
Windows changes the name of the MSI package during install, as a protection mechanism against user deletion is my guess. Thankfully, I realized how to find the MSI that Windows uses. I searched the registry for "6.9.3" until I found an MSI file. Here is the right uninstall command line:

msiexec -x C:\Windows\Installer\b950ec4e.msi /lvx* .\mysql-connector-net-6.9.3.log

I attached the log just above this comment.

You now have:
1. The failure log for the failed install of 6.9.6 on Windows 8.1 x64
2. The failure log for the failed uninstall of 6.9.3 on Windows 7 x64

What is the causes of each?
What is the cure/solution of each?
Will there be a fix added to the installer to prevent further occurrences?
[6 Mar 2015 17:35] Gabriela Martinez Sanchez
Hi Sarah, 

Thanks for the log. 

The problem is due to some dependencies that exists in MySql.Web.dll that requires to have Web.Matrix. In other to fix it you would need to copy a file. 

Please do the following:

- Get the assembly MySql.Web from the v2.0 folder where Connector/net is installed.
- Copy this assembly to the C:\Windows\Microsoft.NET\assembly\GAC_MSIL folder (you will need administrative rights).

- It should ask you to overwrite an existing file. Click yes.

After this you can run the uninstall process without any issue.

Please repeat the uninstall creating a log in case there is any error, so we can troubleshoot it.

Looking forward to your answer.
[6 Mar 2015 17:51] Sarah Weinberger
Thank you for the comment, but we are dealing with two different computers with two related but different problems.

1. Did you look at both W7 and W81 logs?

2. Which computer, W7 or W81, does your procedure relate, basically the uninstall or the install?
[6 Mar 2015 18:17] Sarah Weinberger
Assuming that you meant the W7 machine, the uninstall did not work.

The "C:\Windows\Microsoft.NET\assembly\GAC_MSIL" folder contains sub-folders. There is a "MySql.Web" folder, which as you can see, already has that file, though that seems to indicate v4.0, not v2.0.


I do not think that I can just copy to the root, like I did. It must have a sub-folder like above.

Please advise on W7 and let me know about W81.
[6 Mar 2015 18:26] Gabriela Martinez Sanchez
Sorry I missed to specify. Yeah you need to copy to the subfolder of the assembly:


Please removed it from the root and paste it in the subfolder from the above.

Looking forward to your answer.
[6 Mar 2015 18:46] Sarah Weinberger
That file was already there, however I renamed the original one in that folder, copied the one that you indicated, and tried uninstalling again on W7. Same problem!
[6 Mar 2015 20:38] Gabriela Martinez Sanchez
It should be working.. Could you please run the command to get the log again?

msiexec -x C:\Windows\Installer\b950ec4e.msi /lvx* .\mysql-connector-net-6.9.3.log

[6 Mar 2015 21:07] Sarah Weinberger
W7 6.9.3 uninstall log: retry with 2.0 MySql.Web file

Attachment: mysql-connector-net-6.9.3.log (application/octet-stream, text), 335.47 KiB.

[6 Mar 2015 21:08] Sarah Weinberger
W7 6.9.3 GAC folder

Attachment: MySqlGac.png (image/png, text), 141.29 KiB.

[8 Mar 2015 6:06] Sarah Weinberger
I searched for "Error" on the W81 log and interestingly enough, I see the EXACT same error, when trying to install 6.9.6 on my Win81 machine then I do on the uninstall of my Win7 machine of 6.9.3. Obviously, one problem prevented the other.

Here is the failure line from my Win81 machine:

Action 18:55:06: ManagedWebInstall. Registering web providers in machine.config
MSI (s) (D4:B0) [18:55:06:183]: Executing op: CustomActionSchedule(Action=ManagedWebInstall,ActionType=3073,Source=BinaryData,Target=CAQuietExec,CustomActionData="C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\installUtil.exe" /LogToConsole=false /LogFile=  "C:\Program Files (x86)\Development\Database\MySQL\MySQL Connector Net 6.9.6\Assemblies\v2.0\MySql.Web.v20.dll")

Unlike on my Win7 machine, which has files inside it, my Win81 machine has this folder empty:


Cure on both?
[10 Mar 2015 12:13] Sarah Weinberger
What is the status? I submitted the requested logs.
[10 Mar 2015 14:57] Sarah Weinberger
Here is the contents of the log file, when trying to execute the uninstall of MySql.Web.20.dll. The error occurs in the custom installer, which throws a "object not set to an instance of an object," a null reference. The uninstall completed successfully, but the 6.9.3 installer/uninstaller does not realize that. The MySQL installer should have continued, not roll back.

Uninstalling assembly 'C:\Program Files (x86)\Development\Database\MySQL\MySQL Connector Net 6.9.3\Assemblies\v2.0\MySql.Web.v20.dll'.
Affected parameters are:
   logtoconsole = 
   logfile = C:\Program Files (x86)\Development\Database\MySQL\MySQL Connector Net 6.9.3\Assemblies\v2.0\MySql.Web.v20.InstallLog
   assemblypath = C:\Program Files (x86)\Development\Database\MySQL\MySQL Connector Net 6.9.3\Assemblies\v2.0\MySql.Web.v20.dll
An exception occurred during the uninstallation of the MySql.Web.Security.CustomInstaller installer.
System.NullReferenceException: Object reference not set to an instance of an object.
An exception occurred while uninstalling. This exception will be ignored and the uninstall will continue. However, the application might not be fully uninstalled after the uninstall is complete.
Uninstalling assembly 'C:\Program Files (x86)\Development\Database\MySQL\MySQL Connector Net 6.9.3\Assemblies\v2.0\MySql.Web.v20.dll'.
Affected parameters are:
   logtoconsole = 
   logfile = C:\Program Files (x86)\Development\Database\MySQL\MySQL Connector Net 6.9.3\Assemblies\v2.0\MySql.Web.v20.InstallLog
   assemblypath = C:\Program Files (x86)\Development\Database\MySQL\MySQL Connector Net 6.9.3\Assemblies\v2.0\MySql.Web.v20.dll
An exception occurred during the uninstallation of the MySql.Web.Security.CustomInstaller installer.
System.NullReferenceException: Object reference not set to an instance of an object.
An exception occurred while uninstalling. This exception will be ignored and the uninstall will continue. However, the application might not be fully uninstalled after the uninstall is complete.
[10 Mar 2015 22:17] Gabriela Martinez Sanchez
Hi Sarah,
It is clearly the same problem with the MySql.Web assembly. Could you please delete all the MySql.Web*.dll files from:


That way the Connector/Net installer will use it's own version and not the one from the GAC.
[10 Mar 2015 22:36] Sarah Weinberger
For anyone wishing a summary of this issue along with steps, I added one at Stack Overflow:


Note: Repair followed by uninstall does NOT do the trick.
[10 Mar 2015 22:39] Sarah Weinberger
I deleted all files, tried the uninstall again (W7), and same exact problem. I am attaching the detailed log from this action.
[10 Mar 2015 22:41] Sarah Weinberger
Sadly, deleting all the files did not cause the installer to use its on versions. Note, I tried to repair the installation first

Attachment: mysql-connector-net-6.9.3-uninstall.log (application/octet-stream, text), 346.78 KiB.

[16 Mar 2015 2:56] Sarah Weinberger
Manual install of MySQL.web20.dll

Attachment: mysql-web20-install.log (application/octet-stream, text), 1.99 KiB.

[16 Mar 2015 3:02] Sarah Weinberger
Wrong file uploaded before, here is the verbose install of MySql.Web.v20.dll.

Attachment: mysql-web20-install.log (application/octet-stream, text), 1.50 KiB.

[16 Mar 2015 3:06] Sarah Weinberger
1. I performed a manual install of the MySql.Web.v20.dll file with verbose logging, see previously attached. Sadly, all I got was:

An exception occurred during the Install phase.
System.NullReferenceException: Object reference not set to an instance of an object.

Please tell me the exact steps that installUtil.exe does?

2. I do not know if you ignore my issue, do not care about my issue, swept it under the rug, are busy, or just do not communicate with me, but Oracle caused my problem on multiple machines and I am down. What would you like me to do? Reformatting the machines is not really an option. We need positive resolution on this issue. I am doing my share of the effort.
[16 Mar 2015 15:48] Sarah Weinberger
From admin-cmd prompt with repair of MSI done first, no change, issue with custom installer

Attachment: InstallUtil-Uninstall-FromAdmin-MySql_Web_v20_dll.log (application/octet-stream, text), 1.71 KiB.

[17 Mar 2015 18:38] Gabriela Martinez Sanchez
Hi Sarah,
If you correctly deleted the dll from the GAC folders then that would've been enough for the Connector/Net installer to run with no errors. 
There is a different issue that could possibly be the problem if the dll is not. 
Could you please check your machine config file and post it here. We can check if there is anything out of the expected that could possibly be the issue.

You can see this link so you can have a better idea:


Thanks in advance for you patience.
[17 Mar 2015 19:42] Sarah Weinberger
How do I correctly delete the files in that folder?
[17 Mar 2015 20:15] Sarah Weinberger
W7 machine.config

Attachment: machine.config (application/xml, text), 36.74 KiB.

[18 Mar 2015 2:50] Sarah Weinberger
W81 machine.config file

Attachment: machine.config (application/xml, text), 37.34 KiB.

[18 Mar 2015 3:31] Sarah Weinberger
At long last, success!

The problem was the machine.config file on both local machines. The file did not have the proper entries or whatever it had confused the installer.

I compared the machine.config file from a machine, where I could install/uninstall to the failed machines and set the lines that were different with respect to MySql, and then proceeded to try the uninstall (or install/uninstall on W81) again. Success!

This problem really threw me for a loop. The installer should not be so sensitive to that file. The error message was a bit faulty, as the failure was not the DLL but rather the machine.config.

You can close this ticket.
[18 Mar 2015 3:32] Sarah Weinberger
As I stated in my answer, the problem was the machine.config file. See my answer for how I fixed the problem.
[3 May 2016 14:47] Aditya Raj
mysql connector

Attachment: log.txt (text/plain), 375.12 KiB.

[3 May 2016 14:48] Aditya Raj
mysql connector

Attachment: log.txt (text/plain), 375.12 KiB.

[3 May 2016 14:49] Aditya Raj
I am running win 10.1 and could not uninstall mysql-connector-net-6.9.8 but it stop with fatal error.

I tried various ways but could succeed. 

So i have attach verbose log file with following commands.
msiexec -x mysql-connector-net-6.9.3.msi /lvx* c:\log.txt

Waiting for your suggestions.
[4 Jun 2016 16:07] Sophia Bramwell
I have had Problems for several days now, with trying to uninstall the MySQL Connector.Net 6.9.8 on Microsoft Windows 10 with no joy. However, I have found a solution that I would like to pass on, which will make someone elses life much easier. You can go to this website and download the trial or free version of this uninstaller.  http://www.revouninstaller.com/revo_uninstaller_free_download.html

I Hope all will be ok from here on out.


[8 Jun 2016 5:52] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=81764 marked as duplicate of this one.
[15 Jun 2017 10:31] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=86703 marked as duplicate of this one.
[18 Jul 2017 12:25] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=87077 marked as duplicate of this one.
[23 Sep 2020 18:18] safala Kolaventi

I'm unable to uninstall my connector file 'mysql-connector-net-8.0.21' which is halting me from MySql installation, i try to delete it/uninstall multiple times but it says failed with some error log and doesn't get deleted. Tried with installing new connector file to repair/delete the existing connector but it fails too. Please help.