Bug #57654 .net connector 6.3.5 Installer fails
Submitted: 22 Oct 2010 10:38 Modified: 11 Nov 2010 17:39
Reporter: Mario Karagiorgas Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / NET Severity:S1 (Critical)
Version:6.3.5 OS:Microsoft Windows (XP x64)
Assigned to: Reggie Burnett CPU Architecture:Any
Tags: .net Connector, 6.3.5, installer fails

[22 Oct 2010 10:38] Mario Karagiorgas
Description:
When trying to install the 6.3.5 .net connector it will progress normally through the install process till the end when it rolls back and says 

"MySQL Connector Net 6.3.5 Setup Wizard ended 
prematurely because of an error. Your system has not been modified..."

I have attached a detailed Setup Log.

Environment:
Windows XP x64 with visual studio 2008, .net framework 2.0, 3.0, 3.5, 4.0

How to repeat:
Install mysql.data.msi using typical --or-- custom settings.

msiexec /lvx* mysqlcn.log /i mysql.data.msi
[22 Oct 2010 10:48] Mario Karagiorgas
Installation log using msiexec /lvx* mysqlcn.log /i mysql.data.msi

Attachment: bug-data-57654.zip (application/octet-stream, text), 42.40 KiB.

[23 Oct 2010 20:39] Barry Baruch
I have the same problem with windows 7 professional 64 bit...
[25 Oct 2010 6:28] Tonci Grgin
Bug#57699 was marked as duplicate of this report.
[27 Oct 2010 1:55] Michael Minetti
I have the same issue on Windows XP x86, so this is clearly not a x64 issue.
.NET Framework 3.5 and Visual Studio 2008 installed.
[28 Oct 2010 8:24] ANDRE PETERS
Same problem here with Windows 7 32 bit and Visual Studio 2008.
[28 Oct 2010 9:00] ANDRE PETERS
Installation log using msiexec /lvx* mysqlcn.log /i mysql.data.msi

Attachment: bug_data_57654_win7_32bit.zip (application/x-zip-compressed, text), 39.35 KiB.

[28 Oct 2010 11:31] Valeriy Kravchuk
Bug #57797 was marked as a duplicate of this one.
[1 Nov 2010 3:06] Richard Corbishley
Turn off web components as a custom install to let it work
[2 Nov 2010 15:31] Barry Baruch
Hi Richard Corbishley,

Thank you very much for your tip, I managed to finish the installation successfully

I’m mew to MySQl and now I have another problem:
MySQL is installed on iMac with IP 192.168.200.16 and with the help of http://doc.us.extensis.com/Installing-MySQL-on-OSX.pdf I managed to configure a database name MAppeal with a new user named Barry. On the iMac > terminal windows I can get the status information (connection id, database name, user name, ect.).
With VS2008 on windows 7 x64 system, I configured the connection as follows: Data Source: MySQL Database, Server Name: 192.168.200.16 (or the iMac network name), providing my correct user name and password (which are the same as my windows 7 login credentials) the database combobox opens empty with the error message: Unable to retrieve the list of databases. When I type the database name and press on Test Connection I get the following error message: Access denied for user ‘Barry’@’192.168.200.10’ (using password=YES). What confuses me is that the ip address 192.168.200.10 is of my windows 7 computer…

Why can’t I connect to the database?

Thanks, Barry
[2 Nov 2010 15:54] Tonci Grgin
I checked W7x64Ultimate, with VS2010Premium and .NET FW 2.0 & 4.0 today. Complete install of c/NET 6.3.5 msi goes as expected (Bug#57501).
[2 Nov 2010 21:55] paul smietan
Tonci,

I'm trying to install on a Windows 7 x64 running VS 2008 and get this error.  Was it ever resolved or a work around published?

thank you!
[2 Nov 2010 22:08] paul smietan
You guys will like this: all I had to do was install .NET 4.0 (even though I'm still on VS 2008 FW3.5SP1) and the install went without errors.

-Paul
[2 Nov 2010 22:55] ANDRE PETERS
Paul: thank you SO much!! Installing .NET 4.0 works for me too (Windows 7 Prof. 32-bit + Visual Studio 2005 and 2008).
[3 Nov 2010 0:34] Richard Corbishley
Barry Baruch

Probably not the best place to ask - you can mail me directly at hotmail using rcorbish
[4 Nov 2010 10:29] Tonci Grgin
Mario, looking into the log you attached I see 6 errors. Here are shortened descriptions:
  1) CAQuietExec:  Error 0xffffffff: CAQuietExec Failed
This is an account privilege issue: Running product '{5FD88490-011C-4DF1-B886-F298D955171B}' with user privileges: It's not assigned.

  2) MSI (s) (A4:34) [13:31:30:398]: MsiProvideAssembly is returning: 1607
Basically the same as 1) + MSI (s) (A4:34) [13:29:53:988]: Product {5FD88490-011C-4DF1-B886-F298D955171B} is not managed.

  3) MSI (c) (D4:0C) [13:31:32:945]: Back from server. Return value: 1603
Same as 2)

  4) MSI (c) (D4:0C) [13:31:32:945]: Doing action: FatalError
Same as 2) & 3)

  5) MSI (c) (D4:0C) [13:31:32:945]: Doing action: FatalError - Same

  6) MSI (c) (D4:0C) [13:31:41:101]: MainEngineThread is returning 1603 - Same

So, I'd say you need an elevated account on the box you're installing c/NET on.
[4 Nov 2010 12:14] Vladislav Vaintroub
According to log, this action 

C:\WINDOWS\\Microsoft.NET\Framework\v4.0.30319\installUtil.exe" /LogToConsole=false /LogFile=  "D:\Program Files (x86)\MySQL\MySQL Connector Net 6.3.5\Assemblies\v2.0\MySql.Web.dll"

has failed. Unfortunately the custom action is silent, logs are written, and it is not possible to tell exactly why it failed.

Perhaps, running process monitor during installation with filter set to installUtil.exe can give some insights.
[4 Nov 2010 12:16] Vladislav Vaintroub
in previous entry 
"Unfortunately the custom action is silent, logs are written," I meant to write "NO logs are written"..
[5 Nov 2010 7:20] Mario Karagiorgas
Hi Tonci,

Regarding your comment. I ran everything as a local administrator.

----
[4 Nov 11:29] Tonci Grgin

So, I'd say you need an elevated account on the box you're installing c/NET on.
----
[5 Nov 2010 7:40] Tonci Grgin
Yes, so it seems thus I asked Vladislav to take another look.
[5 Nov 2010 10:44] Mario Karagiorgas
Hi Vladislav,

To your comment, I uploaded bug-data-57654.zip containing the process monitor events log, readme and a new msiexec log.

----------
Perhaps, running process monitor during installation with filter set to installUtil.exe
can give some insights.
[10 Nov 2010 23:16] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/123506

943 Reggie Burnett	2010-11-10
      - fixed the installer to require .net 2.0 or .net 4.0 "full" profile since system.web is only supplied with
        the full profile (bug #57654)
[10 Nov 2010 23:18] Reggie Burnett
Fixed in 6.3.6
[11 Nov 2010 7:18] Tonci Grgin
Bug#58100 was marked as duplicate of this report.
[11 Nov 2010 17:39] Tony Bedford
An entry has been added to the 6.3.6 changelog:

Installation of MySQL Connector/NET 6.3.5 failed. The error reported was:

MySQL Connector Net 6.3.5 Setup Wizard ended 
prematurely because of an error. Your system has not been modified.
[4 Jan 2011 3:46] Scott Roberts
I'm trying to install 6.3.6 on Vista (32-bit) with VS 2010 Ultimate. I still can't install the Web Providers for the connector, but other items install fine.
[5 Jan 2011 17:41] Reggie Burnett
Scott

Can you give me some details on your system?
OS?
Versions of .NET?
Versions of Visual Studio?
[6 Jan 2011 21:53] Andy Westrate
I am still getting this error with installer version 6.3.6.  Here are the details of my system:

OS:
Windows Server 2003 Standard Edition, service pack 2

Versions of .NET?
v1.0.3705, v1.1.4322, v2.0.50727, v3.0, v3.5

Versions of Visual Studio?
This is a development web server, so it has no full installs of VS, but it does have a debugger from VS2005 installed.  It also has a ASP.TLB file in a \Program Files\Microsoft Visual Studio\COMMON\IDE\IDE98 directory, and a couple of .hx* files in a \Program Files\Microsoft Visual Studio .NET 2003\COMMON7\IDE directory.
[6 Jan 2011 21:54] Andy Westrate
Installation log using msiexec /l* setup.log /i mysql.data.msi

Attachment: setup.log (application/octet-stream, text), 75.98 KiB.

[6 Jan 2011 22:12] Andy Westrate
Install succeeded with framework v4
[26 Feb 2011 10:21] Jorge Oyhenard
This is a recurring problem since mysql net connector 5.x and 6.x

Many users say rename the folder C: \ WINDOWS \ Microsoft.NET \ Framework \ v2.0.50727 \ config to configxx: http://forums.mysql.com/read.php?38,354259,368805

Others suggest not to install the data provider web, with custom instalation, avoid write a dataprovider in web.config, another common mistake: http://forums.mysql.com/read.php?38,405697,407618#msg-407618

Others propose to install Framework 4
http://forums.mysql.com/read.php?11,401732,403548#msg-403548
installing the latest framework 4, sometimes solves the problem of framework 2

But the original problem is an error in Frameworks 2 + fw 4 + Windows Installer, the best in this case is to remove and install framewors again.

1) go to ftp://ftp.microsoft.com.ar/so/NETFrameworkPackages/
2) download cleanup_tool.exe
3) download framework 2.0 ftp://ftp.microsoft.com.ar/so/NETFrameworkPackages/2.0/dotnetfx.exe
4) download framework 4.0 ftp://ftp.microsoft.com.ar/so/NETFrameworkPackages/4.0/dotNetFx40_Full_x86_x64.exe
... and others frameworks, if desired ...
5) execute cleanup_tool.exe and clean = remove all frameworks installed
6) reset your computer
7) install framework 2.0 => dotnetfx.exe
8) install framework 4.0 => dotNetFx40_Full_x86_x64.exe
... and others frameworks, if desired ...
9) reset your computer
10) install MySql Connector Net 6.3.6 or 5.x or 6.x

Enjoy !

(sorry for my english :P)