Bug #54129 Missing the execute bit for scripts
Submitted: 1 Jun 2010 8:06 Modified: 14 Oct 2010 15:40
Reporter: Horst Hunger Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:trunk, next-mr OS:Linux
Assigned to: Alexey Botchkov CPU Architecture:Any
Tags: disabled, regression
Triage: Triaged: D3 (Medium)

[1 Jun 2010 8:06] Horst Hunger
Description:
In 5.1 and next-mr the scripts like mysqlhotcopy are executable, means the execute bit is set. This is NOT the case in trunk-bugfixing. 

How to repeat:
Look into the scripts directory after having made all.

Suggested fix:
Set the execute bit as in 5.1
[1 Jun 2010 9:48] Sveta Smirnova
Thank you for the report.

Verified as described, although in my case same problem exists in mysql-next-mr

Also after `make install` mysql-test-run.pl in the installation directory has no execution bit. This is very annoying.
[4 Jun 2010 8:52] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/110205

3415 Horst.Hunger	2010-06-04
      Patch for bug#52913: Inserted check if mysqlhotcopy script is existing as requested by review. DIsabled the test until bug#54129 will befixed.
[4 Jun 2010 9:45] Horst Hunger
Please, enable mysqlhotcopy_myisam and mysqlhotcopy_archive after having fixed this bug.
[4 Jun 2010 9:47] Horst Hunger
The state was set due to a patch for bug52913. I set it back.
[17 Jun 2010 6:14] Bugs System
Pushed into 5.5.5-m3 (revid:alexey.kopytov@sun.com-20100615145247-8bj0vmuqlotbqsn9) (version source revid:georgi.kodinov@oracle.com-20100604160950-usx33mwczmow3i5e) (merge vers: 5.5.5-m3) (pib:16)
[17 Jun 2010 6:17] Bugs System
Pushed into mysql-next-mr (revid:alik@sun.com-20100615150216-cubqoyn1fj9b6a2p) (version source revid:alik@sun.com-20100607075151-xjus8wzgjv3g9ok0) (pib:16)
[28 Jun 2010 22:21] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/112391

3280 Alexey Botchkov	2010-06-28
      Bug#54129      Missing the execute bit for scripts
          files for cmake had some minor bugs causing this.
[28 Jun 2010 22:25] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/112392

3280 Alexey Botchkov	2010-06-28
      Bug#54129      Missing the execute bit for scripts
          files for cmake had some minor bugs causing this.
      
      per-file comments:
        mysql-test/CMakeLists.txt
      Bug#54129      Missing the execute bit for scripts
          use same permissions as in the source folder
      
        mysql-test/t/disabled.def
      Bug#54129      Missing the execute bit for scripts
            mysqlhotcopy tests enabled
      
        scripts/CMakeLists.txt
      Bug#54129      Missing the execute bit for scripts
          chmod +x for the script files
[19 Jul 2010 14:36] Bugs System
Pushed into 5.1.49 (revid:build@mysql.com-20100719143034-omcma40sblwmay3x) (version source revid:horst.hunger@sun.com-20100604085318-455z5sppq1hzwmu7) (merge vers: 5.1.48) (pib:16)
[11 Aug 2010 9:32] Alexander Nozdrin
The patch still hasn't reached even mysql-5.1.
What was pushed is the folowing:
"Patch for bug#52913: Inserted check if mysqlhotcopy script is existing as requested by review. DIsabled the test until bug#54129 will befixed."
[20 Aug 2010 12:53] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/116394

3195 Alexey Botchkov	2010-08-19
      Bug#54129      Missing the execute bit for scripts
          files for cmake had some minor bugs causing this.
            
      per-file comments:
        mysql-test/CMakeLists.txt
      Bug#54129      Missing the execute bit for scripts
          use same permissions as in the source folder
      
        mysql-test/t/disabled.def
      Bug#54129      Missing the execute bit for scripts
            mysqlhotcopy tests enabled
      
        scripts/CMakeLists.txt
      Bug#54129      Missing the execute bit for scripts
          chmod +x for the script files
[20 Aug 2010 13:18] Alexey Botchkov
pushed into 5.5-bugfixing.
[25 Aug 2010 9:23] Bugs System
Pushed into mysql-5.5 5.5.6-m3 (revid:alik@ibmvm-20100825092002-2yvkb3iwu43ycpnm) (version source revid:alik@ibmvm-20100825092002-2yvkb3iwu43ycpnm) (merge vers: 5.5.6-m3) (pib:20)
[26 Aug 2010 2:15] Paul Dubois
Noted in 5.5.6 changelog.

For distributions built with cmake rather than the GNU autotools,
some scripts were built without the execute bit set.

Setting report to Need Merge pending push to 5.6.x.
[30 Aug 2010 8:31] Bugs System
Pushed into mysql-trunk 5.6.1-m4 (revid:alik@sun.com-20100830082732-n2eyijnv86exc5ci) (version source revid:alik@sun.com-20100830082732-n2eyijnv86exc5ci) (merge vers: 5.6.1-m4) (pib:21)
[30 Aug 2010 8:35] Bugs System
Pushed into mysql-next-mr (revid:alik@sun.com-20100830082745-n6sh01wlwh3itasv) (version source revid:alik@sun.com-20100830082745-n6sh01wlwh3itasv) (pib:21)
[30 Aug 2010 18:27] Paul Dubois
Noted in 5.6.1 changelog.
[31 Aug 2010 14:02] Alexander Nozdrin
mysqlhotcopy* still fails.

Disabled due to this test.
[8 Sep 2010 14:26] John Embretsen
mysqlhotcopy is a Perl script requiring the DBD::mysql and DBI Perl modules. These Perl modules are not necessarily installed (or a very old version is installed) on the Pushbuild hosts, as indicated by the following failure from mysql-trunk-bugfixing:

CURRENT_TEST: main.mysqlhotcopy_archive
install_driver(mysql) failed: Can't locate DBD/mysql.pm in @INC (@INC contains: /net/astra04/export/home2/bteam/perl/lib/site_perl/5.8.4/sun4-solaris-64int /net/astra04/export/home2/bteam/perl/lib/site_perl/5.8.4 /net/astra04/export/home2/bteam/perl/lib/site_perl /usr/perl5/5.8.4/lib/sun4-solaris-64int /usr/perl5/5.8.4/lib /usr/perl5/site_perl/5.8.4/sun4-solaris-64int /usr/perl5/site_perl/5.8.4 /usr/perl5/site_perl /usr/perl5/vendor_perl/5.8.4/sun4-solaris-64int /usr/perl5/vendor_perl/5.8.4 /usr/perl5/vendor_perl .) at (eval 6) line 3.
Perhaps the DBD::mysql perl module hasn't been fully installed,

There are other kinds of symptoms relating to Perl modules as well.
Ideally such a test should be skipped automatically if the required Perl modules are not found.

In addition, it is impossible to run the mysqlhotbackup tests properly on systems with Perl (and required modules) installed in other locations than /usr/bin/perl. The --exec commands in the tests may be tweaked to allow for this.

I suggest opening up another bug report for these issues, if the issues with missing execute bits are fixed.
[16 Sep 2010 8:21] Konstantin Osipov
John,
please don't reopen a patched bug.
Alexey is telling me that he tried to address your request, but was unable to come up with anything quick.
Please file this request as a separate bug.
[16 Sep 2010 12:13] John Embretsen
For the record, I did not re-open this bug, someone else did.

I have opened Bug#56817 for the remaining issue of the test failing due to missing perl modules.

Note that the mysqlhotcopy tests are disabled and/or listed as experimental in most branches listing this bug as a reason. The real reason is most likely Bug#56817.
[14 Oct 2010 8:28] Bugs System
Pushed into mysql-5.1-telco-7.0 5.1.51-ndb-7.0.20 (revid:martin.skold@mysql.com-20101014082627-jrmy9xbfbtrebw3c) (version source revid:vasil.dimov@oracle.com-20100531152341-x2d4hma644icamh1) (merge vers: 5.5.5-m3) (pib:21)
[14 Oct 2010 8:43] Bugs System
Pushed into mysql-5.1-telco-6.3 5.1.51-ndb-6.3.39 (revid:martin.skold@mysql.com-20101014083757-5qo48b86d69zjvzj) (version source revid:vasil.dimov@oracle.com-20100531152341-x2d4hma644icamh1) (merge vers: 5.5.5-m3) (pib:21)
[14 Oct 2010 8:58] Bugs System
Pushed into mysql-5.1-telco-6.2 5.1.51-ndb-6.2.19 (revid:martin.skold@mysql.com-20101014084420-y54ecj85j5we27oa) (version source revid:vasil.dimov@oracle.com-20100531152341-x2d4hma644icamh1) (merge vers: 5.5.5-m3) (pib:21)
[14 Oct 2010 15:40] Jon Stephens
Re-closing; see comments above.