Bug #49303 Export as CSV produces tab-delimited output
Submitted: 1 Dec 2009 21:41 Modified: 10 Feb 2010 13:54
Reporter: Todd Farmer (OCA) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.10 r4680 OS:Microsoft Windows (XP)
Assigned to: Alfredo Kojima CPU Architecture:Any

[1 Dec 2009 21:41] Todd Farmer
Description:
In the live editor, I choose "Export as CSV".  This results in tab-delimited data:

a	b	c	
1	1	1	
2	2	2	
3	3	0	
4	4	4	

How to repeat:
Export as CSV

Suggested fix:
Either call it tab-delimited, or produce CSV data.
[4 Feb 2010 23:20] Alfredo Kojima
CSV template was fixed to output values separated by ,
Additionally, CSV files separated by tabs and ; are also supported now.
[5 Feb 2010 17:55] Johannes Taxacher
fix confirmed
[10 Feb 2010 13:54] Tony Bedford
An entry has been added to the 5.2.16 changelog:

In the SQL Editor, when using the live editor, if Query, Export Results was selected from the main menu and a CSV output format chosen, then the exported data was found to be in tab delimited format, rather than CSV format.
[11 Feb 2010 16:30] Johannes Taxacher
Bug #51101 has been marked as duplicate of this one
[12 Feb 2010 4:19] Valeriy Kravchuk
Bug #51130 is a duplicate of this one.