Bug #51130 MySQL Workbench Export Results as CSV results in Tab delmited file instead
Submitted: 12 Feb 2010 2:23 Modified: 12 Feb 2010 4:17
Reporter: Terry Bailey Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.15 OSS Beta Revision 5053 OS:Microsoft Windows (Windows 7)
Assigned to: CPU Architecture:Any
Tags: csv, export, export results, Tab Delimited

[12 Feb 2010 2:23] Terry Bailey
Description:
Using the Export Results menu item from MySQL Wokbench to export a CSV file does not produce the same file format as the same functionality in the older MySQL Query Browser.  

In my configuration at least it is resulting in what appears to be a tab delimited file instead.  

How to repeat:
1. Connect to a MySQL instance using the Query Editor to execute some queries.
2. Run a simple select statement
3. Select "Export Results" from the Query menu
4. Select a recordset to Export (probably Result(1))
5. Chose the CSV File Format.
6. Provide a File path (c:\export.csv in windows)
7. Click the Export button

8. Use notepad or your preferred text editor to open c:\export.csv.
9. Note that it is in fact not a Comma Separated Values file but tab delimited which is not a file format option to begin with.

Suggested fix:
1. Make the CSV export create a truly comma separated file preferably matching the format exported by the prior tool.
2. Add "Tab Delimited" as a File Format option and have it use this current functionality.
[12 Feb 2010 4:17] Valeriy Kravchuk
This is a duplicate of Bug #49303.