Bug #51101 Exporting results as CSV actually exports a tab-delimited file
Submitted: 11 Feb 2010 14:23 Modified: 11 Feb 2010 16:29
Reporter: Christopher Gervais Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.15 OS:Mac OS X (10.6.2 (10C540))
Assigned to: CPU Architecture:Any
Tags: export CSV

[11 Feb 2010 14:23] Christopher Gervais
Description:
Exporting results from a query as CSV (as indicated in the user interface for export) actually results in the creation of a tab-delimited file.

How to repeat:
1. Connect to a database
2. Execute a query to create a multi-column result set
3. Choose Query > Export Results...
4. Make sure File Format is CSV
5. Select a location to save the file
6. Export the file
7. Open the file in a text editor and notice the tabs instead of commas separating values
8. Open the file in Microsoft Excel 2008 for Macintosh and import the text file -- notice the tabs instead of commas

Suggested fix:
Export the file with commas for delimiters instead of tabs OR change the option to indicate tab-delimited export
[11 Feb 2010 14:37] Valeriy Kravchuk
Thank you for the bug report. Verified just as described.
[11 Feb 2010 16:29] Johannes Taxacher
this is a duplicate of Bug #49303