Bug #48327 Some crashes specific to FreeBSD ("embedded")
Submitted: 26 Oct 2009 19:26 Modified: 16 Jul 2010 19:32
Reporter: Joerg Bruehe Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:5.1.40, 5.1.41 OS:FreeBSD (6.3 + 7.0, x86 + x86_64)
Assigned to: Assigned Account CPU Architecture:Any
Triage: Triaged: D1 (Critical)

[26 Oct 2009 19:26] Joerg Bruehe
Description:
Sorry, the information I have is pretty incomplete - here goes:

In the tests of 5.1.40, I found 4 crashes which are specific to FreeBSD when running the "embedded" tests.
All look identical (as far as logged) for FreeBSD 6.3 and 7.0.

They have been observed in "classic" builds, so InnoDB was not configured.
The configurations that include InnoDB had other problems, so they didn't proceed to these tests.

One of them happens in both 32 and 64 bit:
=====
main.merge                               [ retry-fail ]
        Test ended at YYYY-MM-DD HH:MM:SS

CURRENT_TEST: main.merge
mysqltest got signal 11
Backtrace not available.
Writing a core file...

 - saving '/PATH/mysql-test/var/log/main.merge/' to '/PATH/mysql-test/var/log/main.merge/'

Test has failed 2 times, no more retries!
=====

The other three happen only on 64 bit:
=====
main.gis-rtree                           [ retry-fail ]
        Test ended at YYYY-MM-DD HH:MM:SS

CURRENT_TEST: main.gis-rtree
mysqltest got signal 8
Backtrace not available.
Writing a core file...

 - saving '/PATH/mysql-test/var/log/main.gis-rtree/' to '/PATH/mysql-test/var/log/main.gis-rtree/'

Test has failed 2 times, no more retries!
=====

=====
main.type_float                          [ retry-fail ]
        Test ended at YYYY-MM-DD HH:MM:SS

CURRENT_TEST: main.type_float
mysqltest got signal 8
Backtrace not available.
Writing a core file...

 - saving '/PATH/mysql-test/var/log/main.type_float/' to '/PATH/mysql-test/var/log/main.type_float/'

Test has failed 2 times, no more retries!
=====

=====
main.type_newdecimal                     [ retry-fail ]
        Test ended at YYYY-MM-DD HH:MM:SS

CURRENT_TEST: main.type_newdecimal
mysqltest got signal 8
Backtrace not available.
Writing a core file...

 - saving '/PATH/mysql-test/var/log/main.type_newdecimal/' to '/PATH/mysql-test/var/log/main.type_newdecimal/'

Test has failed 2 times, no more retries!
=====

Sadly, the build trees have already been deleted, so I cannot provide the core dump or a backtrace.

How to repeat:
Found while running the test suite.
[18 Nov 2009 9:30] Sveta Smirnova
Bug is easily repeatable with current version 5.1.41. Probably duplicate of bug #38965
[23 Nov 2009 18:09] Georgi Kodinov
Sveta, the current pb2 tests run embedded and they don't show up any problem. 
Can you please prove steps to reproduce ?
[24 Nov 2009 7:04] Sveta Smirnova
how to repeat log

Attachment: bug48327.log (application/octet-stream, text), 4.86 KiB.

[24 Nov 2009 7:06] Sveta Smirnova
Georgi,

see file attached.
[22 Feb 2010 17:13] Joerg Bruehe
In 5.5.2-m2, I have this crash just on the x86_64 (64 bit) variants of FreeBSD, on plain x86 (32 bit), the failure does not occur (tests pass).

So this behaves more like described in bug#38965.
[14 Jul 2010 13:10] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/113585

3482 Davi Arnaut	2010-07-14
      Bug#48327: Some crashes specific to FreeBSD ("embedded")
      
      Backport fixes from ndb: Rework the constructors of some static
      object's to not call dbug functions since the constructors will
      be called before main, and consequently, before the dbug library
      is initialized.
[14 Jul 2010 16:27] Davi Arnaut
Patch above pushed to mysql-5.1-bugteam.
[16 Jul 2010 17:23] Davi Arnaut
The merge test case failure is a duplicate of Bug#47139
[16 Jul 2010 17:34] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/113784

3490 Davi Arnaut	2010-07-16
      Bug#48327: Some crashes specific to FreeBSD ("embedded")
      Bug#47139: Test "merge" crashes in "embedded" run
      
      Backport patch for Bug#47139
[16 Jul 2010 19:32] Davi Arnaut
The remaining failures are a duplicate of Bug#38965
[23 Jul 2010 12:22] Bugs System
Pushed into mysql-trunk 5.5.6-m3 (revid:alik@sun.com-20100723121820-jryu2fuw3pc53q9w) (version source revid:vasil.dimov@oracle.com-20100531152341-x2d4hma644icamh1) (merge vers: 5.5.5-m3) (pib:18)
[23 Jul 2010 12:29] Bugs System
Pushed into mysql-next-mr (revid:alik@sun.com-20100723121929-90e9zemk3jkr2ocy) (version source revid:vasil.dimov@oracle.com-20100531152341-x2d4hma644icamh1) (pib:18)
[19 Aug 2010 15:41] Bugs System
Pushed into mysql-5.1 5.1.51 (revid:build@mysql.com-20100819151858-muaaor6jojb5ouzj) (version source revid:build@mysql.com-20100819151858-muaaor6jojb5ouzj) (merge vers: 5.1.51) (pib:20)
[14 Oct 2010 8:27] Bugs System
Pushed into mysql-5.1-telco-7.0 5.1.51-ndb-7.0.20 (revid:martin.skold@mysql.com-20101014082627-jrmy9xbfbtrebw3c) (version source revid:martin.skold@mysql.com-20101014082627-jrmy9xbfbtrebw3c) (merge vers: 5.1.51-ndb-7.0.20) (pib:21)
[14 Oct 2010 8:42] Bugs System
Pushed into mysql-5.1-telco-6.3 5.1.51-ndb-6.3.39 (revid:martin.skold@mysql.com-20101014083757-5qo48b86d69zjvzj) (version source revid:martin.skold@mysql.com-20101014083757-5qo48b86d69zjvzj) (merge vers: 5.1.51-ndb-6.3.39) (pib:21)
[14 Oct 2010 8:57] Bugs System
Pushed into mysql-5.1-telco-6.2 5.1.51-ndb-6.2.19 (revid:martin.skold@mysql.com-20101014084420-y54ecj85j5we27oa) (version source revid:martin.skold@mysql.com-20101014084420-y54ecj85j5we27oa) (merge vers: 5.1.51-ndb-6.2.19) (pib:21)