Bug #38965 test cases gis-rtree, type_float, type_newdecimal fail in embedded server
Submitted: 22 Aug 2008 16:01 Modified: 6 Jun 2011 18:47
Reporter: Daniel Fischer Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: General Severity:S2 (Serious)
Version:5.4.2-beta OS:FreeBSD (6.3 + 7, x86_64)
Assigned to: Alexey Botchkov CPU Architecture:Any
Tags: experimental, pb2, test failure
Triage: Triaged: D1 (Critical)

[22 Aug 2008 16:01] Daniel Fischer
Description:
The test cases gis-rtree, type_float and type_newdecimal fail in embedded mode on FreeBSD 7 x86_64 (only in 64 bit mode).

main.gis-rtree [ fail ]

ERROR: mysqltest returned unexpected code 136, it has probably crashed

main.type_float [ fail ]

ERROR: mysqltest returned unexpected code 136, it has probably crashed

main.type_newdecimal [ fail ]

ERROR: mysqltest returned unexpected code 136, it has probably crashed

How to repeat:
Build MySQL 5.1 on FreeBSD 7 x86_64 and run the test cases in embedded mode.
[20 Jan 2009 20:24] Valeriy Kravchuk
Thank you for a problem report. Do you have the same problem with 5.1.30 on FreeBSD 7?
[24 Jan 2009 19:15] Kent Boortz
Same problem in 5.1.30 and 5.1.31, in fact extended to FreeBSD 6.3 as well
[17 Aug 2009 11:29] Daniel Fischer
After a year has passed, I am no longer able to reproduce this failure on FreeBSD 7.0 amd64. Additionally tested on Mac OS X 10.5, where it also doesn't appear.
[7 Sep 2009 20:54] Joerg Bruehe
Sorry to bring bad news, but I had the same issue in the build of 5.4.2-beta,
on exactly these (and only these) platforms,
for exactly these tests:

=====
main.type_newdecimal                     [ retry-fail ]
        Test ended at YYYY-MM-DD HH:MM:SS

CURRENT_TEST: main.type_newdecimal
mysqltest got signal 8
Backtrace not available.
Writing a core file...

 - saving '/PATH/mysql-test/var/log/main.type_newdecimal/' to '/PATH/mysql-test/var/log/main.type_newdecimal/'
=====

=====
main.type_newdecimal                     [ retry-fail ]
        Test ended at YYYY-MM-DD HH:MM:SS

CURRENT_TEST: main.type_newdecimal
mysqltest got signal 8
Backtrace not available.
Writing a core file...

 - saving '/PATH/mysql-test/var/log/main.type_newdecimal/' to '/PATH/mysql-test/var/log/main.type_newdecimal/'
=====

=====
main.type_newdecimal                     [ retry-fail ]
        Test ended at YYYY-MM-DD HH:MM:SS

CURRENT_TEST: main.type_newdecimal
mysqltest got signal 8
Backtrace not available.
Writing a core file...

 - saving '/PATH/mysql-test/var/log/main.type_newdecimal/' to '/PATH/mysql-test/var/log/main.type_newdecimal/'
=====
[18 Nov 2009 9:30] Sveta Smirnova
See also bug #48327
[4 May 2010 12:23] Alexander Nozdrin
Test cases gis-rtree and type_float have been marked experimental
on FreeBSD due to this bug.
[16 Jul 2010 19:33] Davi Arnaut
Bug#48327 has been closed as a duplicate of this one.
[16 Jul 2010 19:37] Davi Arnaut
From a quick look, it seems FP_X_DNML does not get masked for 64bits builds. It seems we should ifdef on FP_X_DNML instead of __i386__.
[6 Jun 2011 18:47] Paul Dubois
Noted in 5.1.58, 5.5.14, 5.6.3 changelogs.

On FreeBSD 64-built builds of the embedded server, exceptions were
not prevented from propagating into the embedded application.

CHANGESET - http://lists.mysql.com/commits/138682